[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape

update
stable

#184

:cold_sweat::thumbsup: Happy to hear that :slight_smile:


#185

Here’s what I did, @scachemaille: I replaced freetype2-ubuntu and fontconfig-ubuntu with freetype2 and fontconfig respectively. I also replaced cairo-ubuntu with cairo. I then upgraded harfbuzz and harfbuzz-icu to the latest versions (remember, I had previously downgraded them). Doing all of this solved the problem with oblogout-manjaro, as you suspected it would. However, the system was ridiculously slow!

Following that, I rebuilt the font cache from scratch (made a backup of the original) using the fc-cache -vf command in the terminal. I did not witness any observable speedup to the system afterwards, though.

Almost two minutes from logging in to see the desktop. Another 35 seconds for the Tint2 panel to appear, 48 seconds for Conky to appear. It took 11 seconds for terminal to launch, 12 seconds for Thunar file manager to launch, etc. Every application took on average 11 seconds to launch, even oblogout-manjaro took 20 seconds! I timed these apps at least two times each just to verify.

After that, I reinstalled freetype2-ubuntu (no longer available in the AUR repo), fontconfig-ubuntu, and cairo-ubuntu. I also downgraded the two harfbuzz packages again and rebooted. Everything logged in and launched lickety-split just as they should. And the surprise bonus was that oblogout-manjaro continues to work!

Still, after all of this, icons are still broken. Don’t know what to do about that. Reinstalling them doesn’t work.

cc: @oberon


#186

Do you think that will solve the problem my system is having with icons? I did manage to get oblogout-manjaro working again. See the reply I wrote @scachemaille. Thanks.

Update: Also, @oberon, now that oblogout-manjaro is somehow fixed, it breaks when I install the newest versions of harfbuzz and harfbuzz-icu. But downgrading those packages returns things to normal. Of course, this still holds true for cadence, as well. Confirmation.

If I switch to unstable branch, is it easy to switch back to stable branch should things continue to break?


#187

After installing this update my account now seems to be able to launch applications that previously would have required me to enter my password, without one, such as Manjaro Settings Manager. That can’t be right, can it?


#188

I confirm this change in behaviour.


#189

I think that was made on purpose. It will ask for your password only when you choose an action that requires root privileges. You can launch the application and see settings without password now.


#190

Ah, in that case, all is right with the world again. Cheers mate.


#191

Yes, it’s like @kainonergon says :slight_smile:


#192

I use MATE GTk3. After this Update no composite works any more. I installed Metacity and changed to it in the Tweak app. Seems to work again.


#193

Thanks for your heads-up about infinality. With that knowledge update was without problems. Thanks.


#194

The latest thing I’ve found is that I can only use three icons sets. Gnome, Faenza, and Faenza-Green. Adwaita is installed but it only shows Gnome icons, as Gnome is the fallback for all icons that are not working. I uninstalled all non-working icons. Tried Masalla icon theme, but it didn’t work either. Booted that from the system, as well.

I guess my system has some old stuff on it that is just waiting for something like Freetype2 and harfbuzz to come along and break it. Even found old icon themes in the /usr/share/icons directory that needed to be discarded. Pacman cache nor the Manjaro/AUR repos had any mention of those icon sets ever existing. So I just deleted that stuff. Anyway… :disappointed_relieved:

cc: @oberon


#195

While my laptop update has been perfecty smooth as usual, I ran into troubles updating my desktop pc.
I have experienced the same behaviour described by luc4s in the topic 126:

Logging in lightdm caused an inmediately freeze of the system with the only exit option thru the power button. Switching TTY and logging in text mode caused the same. Not so logging with the root account, and starting X from there.

So, after testing with xfce configuration files, switching a few kernels (4.4 and 4.9 in normal and rescue mode, creating a new normal account and so on, I’ve found the problem:
my wifi usb adapter, this one:

Bus 002 Device 003: ID 0846:9043 NetGear, Inc. WNA1000Mv2 802.11bgn [Realtek RTL8188CUS?]

This device caused that every login as normal user ended with a crash, or kernel panic. Booting the system without the device connected gave no problems at all.
And finally: I reinstalled the kernel 4.1, and no problems at all, the system boots and the wifi device works perfectly again.

I’m figuring out that probably the problem is related with some missing firmware, or module of the new kernels. I have no extramodules installed, I have to try with some tests when I can.
Anybody knows if is this possible?


#196

@lightbeam one more thing you can try?


#197

Update on 12 Machines without Problems.

DK3


#198

I have problems with audio. I cannot start blender

connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory) 
attempt to connect to server failed

and when i try to run “alsamixer” , nothing happens. it just does not open. Any hints?


#199

OK. zero issues with the update on the laptop…running kernel 4.1 the lts WITH XFCE
lets see how it goes with the desktop…

UPDATE: the desktop too went 100% without issues that running XFCE as well
gj guys :wink:


#200

I updated my plasma and there is no problem, but i have a question about the other pc with lxqt, that i know use the infinality bundle: there a chance that it runs into some kind of problem with the harfbuzz update?


#201

Yes… and also with clementine-lxqt If you have it installed and that @Esclapion didn’t update it between


#202

This is an awesome tweak, team!


#203

The update went fine, as far as I can tell.

However, I have the problem that my Xserver crashed twice today. All applications closed and I was thrown back to the login screen.

I think it happend while I was watching youtube videos in Chromium, but I’m not sure if that is connected to the crashes. I could find anything in /var/log/Xorg.1.log or dmesg.

I’m using xfce and I’m on the new kernel 4.9.2.