[Stable Update] 2017-01-17 - Python, Xorg, Ruby, Gcc, Inkscape

What should I do?

I don’t know from where you get them. check if thre is updates for those pacakge.
or replace them with
freetype2 and fontconfig from repository

I get them from AUR but I see now that they are orphaned and deleted… So I can easily just install freetype from repo and everything should be ok??

I’ve been seeing this issue with the disappearing notification as well, but not consistently. Just updated 3 Manjaro Cinnamon machines. It’s gone on one, but not on the other 2. Although on one of those two, it took a couple of reboots to re-appear.

I tried the trick with disabling/enabling it at startup, but that didn’t work for me.

My theory was that it will reappear by itself the next time there actually are updates.

normaly yes… replace both package. (freetype2 and fontconfig).
maybe there is also some more package that depend on the ubuntu package. I don’t know. I let you find out.

I uninstalled freetype2-ubuntu and installed freetype2 from repos (I did the same thing with fontconfig package). Do I need to make some adjustments in the config file like Phil explained here or?

it’s up to you… you can try to change too see if the font randering looks better. it’s dependent on gpu, font, screem.

Ok, thank you very much @scachemaille!

And one more small problem left: I don’t see some application icons anymore (redshift, kaffeine etc.) - how to fix that?

UPDATE!
Everything works great (icons are “alive” :slight_smile: ) after reboot!

Those having a shaky connection might consider editing /etc/pacman.conf and uncomment the line:
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
to use wget for downloading packages. An advantage is that it resumes the download if it fails in between, but it produces some terminal spam.

1 Like

Small issues:

Aktualisiere pacman-mirrorlist                                                   [#####################################################] 100%
Fehler: Befehl konnte nicht korrekt ausgeführt werden


==> Lade PKGBUILD von xf86-input-joystick aus dem AUR herunter...
x .SRCINFO
x 50-joystick.conf
x PKGBUILD
xf86-input-joystick 1.6.3-1  (2017-01-12 11:50)
(Nicht unterstütztes Paket: Potenziell gefährlich!)
==> PKGBUILD bearbeiten? [J/n] („A“ zum Abbrechen)

The first: In which way can i update the mirror-list manually?
The second: I don’t use a joystick and therefore i don’t need this package, but would know, why this package will be load from aur?

I found the solution here https://gist.github.com/cryzed/e002e7057435f02cc7894b9e748c5671

Useful for those who have installed bohoomil’s infinality bundle. Pay special attention to run gdk-pixbuf-query-loaders --update-cache as root after you finished. This will bring back the pretty icons.

Update: I already miss infinality-bundle

I guess you used yaourt -Syyua to update right? or maybe pamac call it? I don’t know pamac then I can’t say if it also update AUR package.
those package has been removed from repository and moved to AUR. then yaourt find them and things they are comming from AUR.

1 Like

Hi, here the KDE Version updated without hickups, opted in Octopi to go into the Terminal for this biggie (700MB of downloads).

Update went fine. Thanks to the team. :+1:

There’s one question for me. Can someone explain main what oberon means with:

1. After update I can’t find the font “Xos4 Terminus”.
$ locate Xos4
and
$ pacman -Qs Xos4
find nothing

I still find only the font terminus:
$ pacman -Qs terminus
local/terminus-font 4.40-2.1
Monospace bitmap font (for X11 and console)

Do I have to change/rename something?

2. …rename the font accordingly in your settings!..
In which settings should I have to rename the font now?

1 Like

It is needed only if you use Terminus font. Check fc-match Terminus and fc-match 'xos4 Terminus' and see. If you use Terminus in config files you have to change “Terminus” to “xos4 Terminus” in those files.
Or you can make an alias:

1 Like

everything ok so far, but there were a couple messages just before “welcome to Manjaro” that i didn’t quite catch because they scrolled by so fast…
and then i got “nohz local_softirq_pending 02” on the login screen (i don’t use a DM). i believe this might be something to do with the RT kernel i’m using. currently googling for more info

Yes, that’s with the update of the rt-kernel to 4.9 base-kernel. It simply indicated the NOHZ_FULL config we are applying.

The package is still terminus-font, it wasn’t even updated. But in your config (with lxappearance and other tools) now you have to set “Xos4 Terminus” to use it - don’t ask why, but apparently freetype thinks that this provides more information about the font and that this is an improvement :wink: :rolling_eyes:

2 Likes

should i disregard?

Yes, it’s fine!

Forum kindly sponsored by Bytemark