[Stable Update] 2016-12-31 - Kernels, LibreOffice, KDE5, VirtualBox, Cinnamon, Budgie

update
stable

#21

I had this strange error, everything seems fine though and the upgrade did proceed.

11/14) Updating the appstream index...
The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata.            Refer to the verbose log for more information.
error: command failed to execute correctly

I checked out pacman.log and nothing else was listed there.


#22

Thank you, @philm,

your link fixed my problem.

BUT

Why are there packackes like libgeomap4 from AUR in my system? I never had installed some packages from AUR and I never used yaourt. Yaourt is not installed for me.

Into Oktopi there was never an AUR - repo visible …

My way to update is only “sudo pacman -Syu” or sometimes “sudo pacman -Syyuu”.

Now I delete all the packages from the AUR without Problems for my system.

Into Oktopi there was never an AUR - repo visible.

I would be glad for an answer …

Happy New Year :relaxed:
caho


#23

Another update with no problems on kde and xfce. Everything went smooth like always.
Everyone a good new year.


#24

No problems on Cinnamon and i3.

Happy New Year at All !!!

Quad core Intel Core i5-4570
Kernel: 4.9.0-1-MANJARO x86_64
Cedar [Radeon HD 7350/8350 / R5 220]
Display Server: X.Org 1.18.4 driver: radeon
Desktop: Cinnamon 3.2.7 (Gtk 3.22.5)
Desktop: i3 4.13-non-git


#25

XFCE - update was smooth, it even even resolved my problem that I was having with the last stable update :grinning:, which was that with the hybrid video driver (video-hybrid-intel-nvidia-bumblebee) applications coulnd’t load the gpu driver whilst /proc/acpi/bbswitch stated that the gpu was always turned on.


#26

Can’t wait to get hands for Python 3.6. When does the package made into stable???

Already got in Ubuntu 16.10. Please get in stable fast :wink:


#27

libgeomap4 doesn’t come from AUR. it’s because you had this package installed, but this package was removed from official repositories. it’s why octopi think it comes from AUR, as octopi put the alien icons for all “foreign” packages. packages that are not in repositories.
you can safely remove it. from octopi or terminal.
sudo pacman -R libgeomap4


#28

Two issues:

  • What should I do: ?
    :: kmail-account-wizard and kdepim-common are in conflict. Remove kdepim-common? [y/N]

  • I chose the recommended option in:
    :: Replace kdebase-kdialog with extra/kdialog? [Y/n]
    but that resulted in:
    error: failed to prepare transaction (could not satisfy dependencies) :: kde-servicemenus-pkg-tools: removing kdebase-kdialog breaks dependency 'kdebase-kdialog'


#29

error: failed to commit transaction (conflicting files)
python-pip…exists in filesystem

I solved this error, I remove python-pip, and try pacman-su again, and success. :neutral_face:


#30

you have to remove kde-servicemenus-pkg-tools before to update your system, because there is a dependency name problem. that should be solved. but maybe the new package is missing in stable?? after the update you can try to reinstall it. if there is still dependencies problem. you may need to wait the new package is in stable.

@philm it seems that kde-servicemenus-pkg-tools 0.9.4-1 update is missing in stable. to solve kdialog package name change.


#31

Okay, I’ll remove it and try. What about kmail-account-wizard and kdepim-common. Which one should I keep?


#32

if pacman ask you to replace… just answer yes. if it ask to remove… answer yes too.


#33

The recommended option is to NOT remove kdepim-common. But no, I want to know why there is a conflict. I assume that kmail-account-wizard is a new thing; why should I not allow its installation?


#34

it does not exist anymore in repository, I guess the function has been put in kmail-account-wizard. then answer yes.


#35

Smooth update without any issues. Thanks Manjaro team!

Happy New Year to you all! :fireworks:


#36

Thank you very much for your explanation.

Now I feel reassured and can go to a funny silvesterparty.

Happy New Year To You @scachemaille :slight_smile:
caho


#37

No problems with update. I really like maia2 over maia.


#38

Hi and happy new year in advance everybody!

Smooth update as usual, thank you all for develope and support Manjaro!

P.s: xreader 1.2.2-1 doesn’t show pdf’s thumbnails anymore, I think it’s a bug/regression, can anyone confirm this?


#39

And I’m going to avoid it for a while. (python beginner) Don’t want that some libraries stop working. Well, I will need to learn how to start using virtual env. with pycharm. so I can lock in 3.5 env. before switching to 3.6


#40

Smooth update and no issues at all, as usual. All my gratitude to the Manjaro Team for that superb work and happy new year (and always green) to everyone, from Spain :slight_smile: