[Stable Update] 2016-12-31 - Kernels, LibreOffice, KDE5, VirtualBox, Cinnamon, Budgie

update
stable

#1

Hi community,

only few hours left of the year 2016! During the past few days, most of us spend X-Mas with their families and friends. However some of us still found some time, to add some more packages to our repositories and new features to our tools.

The whole development team wishes you all the best for 2017 and the coming years. Let us finish 2016 with a bang, as the best comes always last.

So what changed and got added?

  • Bernhard pushed out some more Cinnamon packages
  • I had the pleasure to update Budgie and some of our kernels
  • David is working on our new theme Breath (aka Maia2)
  • Hugo joined our team and designs our new welcome screen, which is now translatable
  • We added Plasma 5.8.5, KDE apps 16.12 and KDE Framework 5.29
  • Almost all Kodi addons got updated
  • LibreOffice is now at 5.2.4
  • Wine got updated to 2.0rc3
  • Virtualbox got updated to 5.1.12
  • Additonally we updated some kernels, haskell and some python packages

As usual report your findings and enjoy the last hours of the year 2016 with friends and family. Detailed package changes can be viewed here.

kind regards,
Philip and the Manjaro Development Team


Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.69
  • linux316 3.16.39
  • linux318 3.18.46
  • linux41 4.1.37
  • linux44 4.4.39
  • linux48 4.8.15
  • linux49 4.9.0
  • linux-RT-LTS 4.4.38_rt49
  • linux-RT 4.8.14_rt9

Package changes (Thu Dec 29 09:02:56 CET 2016)

  • stable community i686: 601 new and 564 removed package(s)
  • stable community x86_64: 604 new and 567 removed package(s)
  • stable core i686: 18 new and 18 removed package(s)
  • stable core x86_64: 18 new and 18 removed package(s)
  • stable extra i686: 773 new and 772 removed package(s)
  • stable extra x86_64: 774 new and 773 removed package(s)
  • stable multilib x86_64: 14 new and 10 removed package(s)

Update instruction

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec

Check if your mirror has synced, then do the following steps to have a smooth update:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su

Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn’t affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.22. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.22-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.22 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


KDE Plasma System Settings Segfault, Reproducible Steps
#2

Wow, you have been busy. Thank you for that.
A very happy New Year to you all.


#3

I can´t update because the following error:

Suche nach in Konflikt stehenden Paketen…
:: marble und libmarble4 stehen miteinander in Konflikt. libmarble4 entfernen? [j/N] j
:: kmail-account-wizard und kdepim-common stehen miteinander in Konflikt. kdepim-common entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: libkgeomap4: das Entfernen von libmarble4 löscht ein benötigtes Packet von ‘libmarble4’

Into Oktopi there is no "libmarble4 " inside ?!?

What can I do?

regards
caho


#4

Maybe try with a search :wink:


#5

Thx for your work Manjaro Team.
Smooth update - no issues.
Happy New Year!


#6

On KDE - a breeze, for which I am thankful eternally.

be well


#7

Did the latest update but at the top of the activity list I see this:

resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: kinit will be installed before its kio dependency

It is a waning, not an error, so I guess all is well. If not, please let me know.
Thank you.


#8

Smooth update and no issues at all. Thanks Manjaro team, especially to @oberon for the holiday gift! :wink:

Happy New Year to all! :fireworks:


#9

I had a few conflicts with obsolete packages that pacman was unable to propose the right choice. Additionnally the system shutdown afterwards took quite some time, while only showing a black screen.

So the update wasn’t the smoothest. Still the system seems to be working flawlessly and Breath is looking rather nice.


#10

Yes, it’s fine! :slight_smile:


#11

No, it’s breath!! :laughing:
…sorry, couldn’t resist :zipper_mouth:


#12

No issues, like 99,5% of the time.

Happy New Year everyone!


#13

Thanks!
and Happy New Year.


#14

Oh my yes. Yet another flawless update.
And what perfect timing, to be last one for 2016.


#15

Super Smooth uptade with CLI, Manjaro KDE edition.
No issues at all.
Thanks to Philm and all the Team.


#16

Or the first for 2017. Happy new year. :fireworks:
Smooth update, no problems so far.


#17

My Cinnamon DE crashed midway through the update, when asked if I wanted to restart Cinnamon i selected “No” and that was it, game over. I assume the “No” was wrong since I had to do a hard power-off on my system. My system started at power up as if everything was normal and so far, so good. Should I have selected “Yes” and had the DE restart? FYI - This is my first update since loading Manjaro a few days ago.
Cheers and Happy New Year - Mark


#18

I had to remove libkgeomap4 and libmarble4 manually to fix to get an update.

JohnW


#19

Smooth as always! Great job guys!

Happy New Year \o/


#20

Ditto, I received this message as well. [quote=“DeMus, post:7, topic:14906, full:true”]
Did the latest update but at the top of the activity list I see this:

resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: kinit will be installed before its kio dependency

It is a waning, not an error, so I guess all is well. If not, please let me know.
Thank you.
[/quote]