[Stable Update] 2016-12-15 - Linux v4.9.0, Haskell, Steam, X-Apps, Flash

update
stable

#41

Everything is working smoothly. I was a bit scared and was expecting some crashes or errors as I didn’t update my system for the last 2 weeks, but everything went smooth! Thanks a lot for another amazing update guys.

DE: Gnome
Kernel: linux44


#42

Update on 10 Systems without Problems.

On Two Systems Kernel 4.9 is NOT starting. Kernel 4.8 without Problems.

First System Fails to Load Kernel-Module "linux49-nvidia-340xx 340.98-0.12"
Second System Hangs on “Initiale RAMDisk is loading”

DK3


#43

What about:

error: failed retrieving file ‘amdgfx.db’ from flatchest.org : The requested URL returned error: 403
error: failed to update amdgfx (unexpected error)

Is this something i should worry about?

That and Replace fuse with extra/fuse2.


#44

This repo was removed, please also remove it from your pacman configuration


#45

Seeing the same here with Nvidia 304 and 340.98 drivers on the 4.9 kernel.

The error reported while booting is: Error: Driver ‘nvidia’ is already registered, aborting…
and the system stops. Alt-F2 gets me to a command line. Kernel 4.8 has no issues.

Seems the issue is with 340.98 as 340.101 builds fine without patching according to https://devtalk.nvidia.com/default/topic/973807/nvidia-linux-x86_64-340-98-driver-not-building-with-kernel-4-9-0-rc2-git-ed99d36-/

Patch file > https://devtalk.nvidia.com/default/topic/982052/latest-nvidia-driver-340-101-builds-compiles-properly-but-fails-to-load-has-errors-with-linux-kernel-4-9-resolved-with-patch-/


#46

Only one problem here: Dropbox doesnt auto start with kernel 4.9 (Im using manjaro xfce). When using kernel 4.4 it works fine and autostart as expected


#47

I don’t know if it is this last version of Flash, but it isn’t working. Sorry I don’t use it much and can’t say for sure if it was working before.

When I allow the plugin nothing happens, the content is blank and nothing happens. Also a more serious problem, I can see firefox asking to stop (or wait) the plugin because is affecting the whole browser, when I try to use the plugin. Then, I can see a loading wheel in a white background for all tabs/pages that I try to visit/reload.

Is this a problem/bug with Flash? Can somone confirm it? I’m using the last Firefox version.

EDIT: I got it working for a while but it kinda crashes and stays blank… doing the loading wheel in white background for all tabs until I click stop it.


#48

Couple of unexpected questions, accepting defaults led to another successful update. :slight_smile:

:: Starting full system upgrade…
:: Replace fuse with extra/fuse2? [Y/n] y
resolving dependencies…
:: There are 2 providers available for libx264.so=148-64:
:: Repository extra

  1. libx264 2) libx264-10bit

Enter a number (default=1): 1


#49

I concur with those having problems with linux49 and the legacy Nvidia-304.134 drivers. I get the same “Error: Driver ‘nvidia’ is already registered, aborting…” message that keeps repeating itself. All other 4.x kernels appear to be working fine with the new Nvidia legacy drivers.


#50

I also see cpu miss match errors during bootup for all 4 cores along with a cant find input interupt.
At the desktop everything appears to be fine though


#51

Ask your Mainboard vendor to provide a bios / efi update. :wink:


#52

Hi guys! With the new kernel 4.9 docker stop working, the error is saying:

level=error msg="[graphdriver] prior storage driver “aufs” failed: driver not supported"
level=fatal msg=“Error starting daemon: error initializing graphdriver: driver not supported”

Could it be that the new kernel removed the aufs driver?

thanks!


#53

I can confirm this. I get a similar message during boot, however Manjaro does boot.


#54

Noone seems to have replied to this guy. I had a similar size update, only the following packages:

ecryptfs-utils-111-1 ffmpeg2.8-2.8.9-1 flashplugin-24.0.0.186-1 fuse-common-3.0.0-1
fuse2-2.9.7-3 hexchat-2.12.4-1 icu-58.2-1 openjpeg2-2.1.2-2 udisks2-2.1.8-1 xfce4-whiskermenu-plugin-1.6.2-1 (and the removal of fuse-2.9.7-1).

Quite happy if this was a smaller update than normal, would just like confirmation that this is correct.


#55

Please test this fix:

For v304 series I’ve to check. That driver seems to be different in build.


#56

Please report back also for that driver.

Please report back also for that driver.


#57

Cannot install nvidia 340xx Fix:

[dk3@Home18 ~]$ sudo pacman -U http://repo.manjaro.org.uk/pool/overlay/linux49-nvidia-340xx-340.101-0.13-$(uname -m).pkg.tar.xz
[sudo] Passwort für dk3: 
Lade Pakete...
Löse Abhängigkeiten auf...
Warnung: Kann "nvidia-340xx-utils=340.101" nicht auflösen (eine Abhängigkeit von "linux49-nvidia-340xx")
:: Das folgende Paket kann aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
      linux49-nvidia-340xx

:: Möchten Sie das obengenannte Paket bei dieser Aktualisierung überspringen? [j/N] n
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: linux49-nvidia-340xx: benötigt nvidia-340xx-utils=340.101
[dk3@Home18 ~]$

Pakage “nvidia-340xx-utils” is installed as Version “340.98-1” !

DK3


#58

Same error result as DK3:

error: failed to prepare transaction (could not satisfy dependencies)
:: linux-49-nvidia-304xx: requires nvidia-304xx-utils=1:304.134

Should we say YES to the “skip the above package for this upgrade” ?


#59

@philm I can report back that the updated Nvidia legacy driver linux49-nvidia-304xx-1:304.134-0.13 is now working as expected with the latest linux49 kernel. Thanks!!!


#60

Same here, getting the messages but Manjaro boots and appears to be working fine. Same CPU.