[Stable Update] 2016-12-12 - Kernels, Python, Deepin, Haskell, Systemd, Dbus, PHP

update
stable

#1

Hi Community,

some might already have noticed, that we are working on our new logo. Almost all applications already adopted the new logo by now. We also removed the unsecure linux47 kernel. All users should adopt to another kernel series as we stopped maintaining extramodules for that kernel series from now on.

On the package-side we updated haskell, eric, python, php and dbus. Also we have now the latest mainline kernel v4.9-rc8 added to our repos. We also updated linux44 and linux48 series, renewed most or our Deepin packages, worked on the python and haskell stacks and fixed some issues with systemd. So this update should be smooth. Detailed package changes can be reviewed here.

Upstream packages are up till: Sun Dec 11 11:39:06 CET 2016

Report back your findings as usual …


Update instruction

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec

Check if your mirror has synced, then do the following steps to have a smooth update:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su

Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn’t affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.22. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.22-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.22 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.68
  • linux316 3.16.39
  • linux318 3.18.45
  • linux41 4.1.36
  • linux44 4.4.38
  • linux48 4.8.14
  • linux49 4.9rc8
  • linux-RT-LTS 4.4.32_rt43
  • linux-RT 4.8.11_rt7

Package changes

  • stable community i686: 323 new and 319 removed package(s)
  • stable community x86_64: 343 new and 339 removed package(s)
  • stable core i686: 26 new and 28 removed package(s)
  • stable core x86_64: 26 new and 28 removed package(s)
  • stable extra i686: 119 new and 132 removed package(s)
  • stable extra x86_64: 119 new and 132 removed package(s)
  • stable multilib x86_64: 2 new and 6 removed package(s)

#2

Another smooth update. :+1: Whisker menu looks good in green. :slight_smile:


#3

Smooth KDE update, only issue is Calibre is still dbus segfaulting on exit, new version didn’t fix the issue.

Many thanks Phil and Manjaro team.


#4

Have u guys seem that? https://www.exploit-db.com/exploits/40871/
It’s a new bug that a guy found in the kernel. A user can explore this vulnerability to gain root access. It’s been there for 5 years and never was explored


#5

amd athlon k125 netbook, intel core-i3 2367m notebook, smooth update.

thank you manjaro team


#6

Already fixed within linux44, linux48 and linux49 kernel series. All others are still affected, though.


#7

38 votes and all for “no issues”! Great update as always, thank you!


#8

I actually had quite the opposite - one of the issues I had got fixed! A day ago I removed some old 3.* kernel and the Windows 10 entry disappeared from the boot loader with it. I was just thinking about what a pain it’s going to be to edit GRUB, but after this update the Windows 10 entry showed up again :sunglasses: .


#9

No problems on Plasma. All good.

Quad core Intel Core i5-4570
Kernel: 4.8.14-1-MANJARO x86_64
Cedar [Radeon HD 7350/8350 / R5 220]
Display Server: X.Org 1.18.4 driver: radeon
Desktop: KDE Plasma 5.8.4 (Qt 5.7.0)


#10

the dreaded “a stop job is running…” after running kernel linux49 on it’s first outing after the updates.
I also had removed nvidia proprietary drivers 340.xx series using the instructions in the wiki.
machine now running nouveau drivers - if you recall nvidia modules did not compile for linux49 and I had a great notion of seeing how the free drivers were doing. Pretty good, if you ask me, which you didn’t.

I seem to recall editing a system file and changing start and stop times from 90 seconds to something sensible.
Unfortunately I can’t recall where I got that particular instruction from. I’m finding plenty of references to the “stop job is running…” but not the one with the particular file that needs tweaked.
edit: found the info -

It appears you can reduce the timeout in /etc/systemd/system.conf:

DefaultTimeoutStartSec=10s
DefaultTimeoutStopSec=10s

Checked the file and had already edited in in the past - so that’s not the fix anymore. Drat!

I’m back with Linux48 this morning and am about to reboot - just to check if the “stop job is running…” has gone away,

back soon


#11

When are you getting this? At shutdown/reboot?

When you replace systemd, as this update did, and the old version has a shutdown task expected, it often fails to shut it down, because the flag that says its running is not owned by the current systemd process after the update, (or some such reason). Its usually a one boot occurrence that you can simply wait out.

Also 10 seconds can be too short, especially if you have a virtual machine running which you expect to save-state on before shutdown.


#12

Update 2 machines with no errors, everything works fine :slight_smile: ! Thank you, and good work for the next releases!

P.S.: thank you for update palemoon’s languages packs!


#13

cor blimey!
Thanks for the information.
Yes, that old “a stop job is running…” used to be a frequent flyer - drove people mad watching the countdown from 90 secs.

If you say it is a one off message because of systemd replacement by update, and not the old curse come back to make this user more insane than he is…then I take great comfort from your counsel!

many thanks


#14

No problem on KDE Edition using Octopi.


#15

No apparent issues on xfce kernel 48. Didn’t have to use force for a change as well :slight_smile:


#16

Nor on the Netbook Edition using its GUI Package Manager. Thanks for another smooth experience…Now looking for the poll.


#17

Updates went fine on my three maschines. Great work, thx to all.

After them i install the Kernel 48 and remove 47.


#18

If that happens again, you can just run
sudo update-grub
and hopefully Windows 10 will reappear.


#19

Sorry to burst the bubble, but the last update has left my system completely without wifi (I’m currently using another computer). Looking at the update log, it doesn’t look like there has been an update to networkmanager (the usual culprit), in fact I can’t see anything that has much relevance with network connectivity. Here’s my inxi output:
System: Host: DragonWarrior Kernel: 4.8.14-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.8.4 Distro: Manjaro Linux Machine: Device: desktop Mobo: MSI model: Z87-G45 GAMING (MS-7821) v: 1.0 UEFI: American Megatrends v: V1.6 date: 12/02/2013 CPU: Quad core Intel Core i5-4670K (-MCP-) speed/max: 886/4000 MHz Graphics: Card: NVIDIA GK104 [GeForce GTX 760] Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@60.00hz GLX Renderer: GeForce GTX 760/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 370.28 Network: Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller driver: alx Card-2: Ralink RT2070 Wireless Adapter driver: rt2800usb Drives: HDD Total Size: 3120.6GB (36.2% used) Info: Processes: 195 Uptime: 0 min Memory: 753.1/15996.5MB Client: Shell (bash) inxi: 2.3.4

My wifi adapter is a usb dongle - TP-Link TL-WN321G

Thanks for any help.

Edit: I’ve found a temporary solution. Rolling back the package linux-rt-manjaro-ndiswrapper seems to fix the problem.


#20

No problem with update, but xfce-terminal dropdown is still broken and always opens on monitor 1. Finally got tired of waiting for a fix and downgraded. The bug appeared in 4) while 5) is the last working version:

  1. xfce4-terminal-0.8.0-2.1-x86_64.pkg.tar.xz (local)
    5) xfce4-terminal-0.8.0-2-x86_64.pkg.tar.xz (remote)