[Stable Update] 2016-11-11 - Cinnamon 3.2, Gnome 3.22.3, KDE Apps 16.08.3, Calamares

update
stable

#42

All smooth, and LibreOffice still working…

Last time I’ve checked Wayland, it ran quite crappy. Decided to try again, but the session is gone as an option in my login screen…

I have:

  • Gnome
  • Gnome
  • Gnome Classic
  • Gnome on Xorg

The first Gnome is default, the second Gnome I cannot select. Both ‘Gnome’ and ‘Gnome on Xorg’ seem to run on Xorg though… any clues?


#43

on KDE

Kernel: 4.4.31-1 to Kernel: 4.4.31-2

Haven’t upgraded yet…


#44

Oh man!
Krusader KF5 port v2.5 finally released, so the AUR package became orphan!


#45

same here on Gnome, wait&see…


#46

For some reason the update killed my audio, have to use pavucontrol to get it back. An entry called CubebUtils: Audiostream defaults to zero on every playback and has to be made louder.


#47

Smooth kernel upgrade


#48

Seems safe. On KDE, worked fine.


#49

^I can confirm the upgrade works just fine. KDE


#50

The topic says this upgrade brings Gnome 3.22.3, but it actually brings 3.22.2 (an upgrade from 3.22.1 to 3.22.2).


#51
@@ -89,6 +91,10 @@ prepare() {
   # https://github.com/manjaro/packages-core/issues/27
   patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
 
+  # fix megaraid_sas regression
+  # see also: http://www.spinics.net/lists/stable/msg150603.html, http://www.spinics.net/lists/stable/msg150608.html
+  patch -Np1 -i "${srcdir}/scsi-megaraid_sas-fix-macro-MEGASAS_IS_LOGICAL-to-avoid-regression.patch"
+
   # set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
   # remove this when a Kconfig knob is made available by upstream
   # (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)

#52

Kicad work perfectly, solved the segfault issue.


#53

I have to try. But I thought git version may have bugs while stable version might not have.


#54

I did, no difference.


#55

My network manager icon is blank again after resume from suspend since upgrading to kernel 4.4.31-2.

Edit: apparently resolved by re-installing network-manager-applet and logout/login.

Edit 2: sort of…it seems to only show up now when changing networks while in suspend.

Edit 3: issue seems to have been resolved for me with 4.8.7-1


#56

Same issue here since Manjaro 15.12


#57

pamac tray-icon is gone with this update (cinnamon). process is running. will show, when internet connection is up.

setting the unhide option makes no difference.


#58

I cannot reproduce this error on either of my Manjaro machines (both are running Cinnamon).


#59

What about keyboard layout changer applet? does it work?
In my case it says there is an error, I guess related to the them, but when I try different themes, it still does not work


#60

EDIT : @svooo, I was just looking at you other thread about this and only now realized I misunderstood your question.

I can confirm the keyboard layout applet does not function properly; I was able to reproduce your exact issue.

If you only have one layout active in your keyboard settings the keyboard layout applet can be successfully added to a desktop panel but it will never actually draw the indicator. This behavior may be intended. Your error only seems to appear when multiple layouts are active.

I’ll take a look into the problem sometime tomorrow and maybe see if I can track down the error (looks to be JavaScript-related).


#61

Ok, thanks a lot! I will try it with one layout only and play with settings (maybe it fails to draw all flags properly, but can show the name of the language). I am just guessing, I didn’t know that it works with only one language.