[Stable Update] 2016-10-31 - Manjaro Fringilla finally released

stable
release

#22

Please install dbus-x11, which might solve that issue.


#23

Acer 7540g amd laptop. KDE, no problems

Thanks a lot


#24

That helped a little bit. There are now fewer errors.

The following errors still occur:

sudo mousepad

(mousepad:2244): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion ‘GTK_IS_SOURCE_STYLE_SCHEME (scheme)’ failed

(mousepad:2244): GLib-CRITICAL **: g_variant_new_string: assertion ‘string != NULL’ failed

(mousepad:2244): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion ‘GTK_IS_SOURCE_STYLE_SCHEME (scheme)’ failed

(mousepad:2244): GLib-CRITICAL **: g_variant_new_string: assertion ‘string != NULL’ failed

(mousepad:2244): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion ‘GTK_IS_SOURCE_STYLE_SCHEME (scheme)’ failed

And:

sudo gedit

(gedit:2362): Gtk-WARNING **: Failed to get the GNOME session proxy: The name org.gnome.SessionManager is not owned

(gedit:2362): Gtk-WARNING **: Failed to get the Xfce session proxy: The name org.xfce.SessionManager is not owned

(gedit:2362): Gtk-WARNING **: Failed to get an inhibit portal proxy: The name org.freedesktop.portal.Desktop is not owned

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:138:54: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:169:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:179:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:188:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:195:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:202:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:210:71: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:219:73: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:228:72: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:440:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:510:72: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:548:72: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:619:75: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:625:77: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:651:73: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:657:75: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:724:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1295:60: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1307:62: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1359:62: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1372:72: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1426:54: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1437:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1447:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1456:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1465:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1534:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1588:74: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1594:76: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1620:73: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:1626:75: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:2476:9: Not using units is deprecated. Assuming ‘px’.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:2476:9: Expected a string.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3322:53: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3352:51: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3355:53: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3360:53: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3360:87: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3548:8: not a number

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3548:17: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3887:8: not a number

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3887:20: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3907:54: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3915:8: not a number

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3915:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3918:8: not a number

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3918:28: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3921:8: not a number

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:3921:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:4350:54: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:4359:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Theme parsing error: gtk.css:4369:56: Using one color stop with linear-gradient() is deprecated.

(gedit:2362): Gtk-WARNING **: Allocating size to GtkOverlay 0x184c860 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?


#25

The battery detection bug just came back, Halloween trick? :slight_smile:
See: [Stable Update] 2016-10-23 - Manjaro 16.10 Package Release

The 4.4 kernel does not detect my battery, first declared on the update of the last 24th, then went away with update 3 days ago, and came back today.

As before, kernel 4.1 works right.

Rgds,
jss


#26

The 4.9-rc3 doesn’t boot on any of my 3 computers > (1 laptop & 2 desktops) – In fact Linux Kernel 4.9 seems like a complete washout.

I’m not sure why they’ve buggared 4.9 – complete aggravation if you like compiling from source.


#27

Well, the x86_64 seems not to find any harddrives. However the i686 is fine and dandy:

phil@manjaro ~/Arbeitsfläche $ inxi -S
System:    Host: manjaro Kernel: 4.9.0-1-MANJARO i686 (32 bit)
           Desktop: Xfce 4.12.3 Distro: Manjaro Linux
phil@manjaro ~/Arbeitsfläche $ uname -a
Linux manjaro 4.9.0-1-MANJARO #1 SMP PREEMPT Sun Oct 30 16:52:22 UTC 2016 i686 GNU/Linux
phil@manjaro ~/Arbeitsfläche $ pacman -Q linux49
linux49 4.9rc3-1
phil@manjaro ~/Arbeitsfläche $ cat /etc/lsb-release
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=16.10
DISTRIB_CODENAME=Fringilla
DISTRIB_DESCRIPTION="Manjaro Linux"

#28

Minor (at least i hope so ^^) issue here:
first i tried “sudo pacman -Syu” and got:

> (48/48) Prüfe Schlüssel im Schlüsselring                                                                                        [##############################################################################] 100%
> (48/48) Überprüfe Paket-Integrität                                                                                              [##############################################################################] 100%
> Fehler: linux44: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is invalid
> :: Datei /var/cache/pacman/pkg/linux44-4.4.28-2-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
> Soll die Datei entfernt werden? [J/n] 
> Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
> Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

then did “sudo pacman -Syyu” and everything seems to run, but i got 2 messages:

(25/48) Aktualisiere lib32-mesa                                                                                                 [##############################################################################] 100%
Using default
Default lib32 support: true
xorg configuration symlink valid...
libGl and libglx symlinks valid...
==> use mhwd-gpu to set catalyst as default: 'mhwd-gpu --setgl catalyst'
==> use mhwd-gpu to set mesa as default: 'mhwd-gpu --setgl mesa'

(did “sudo mhwd-gpu --setgl mesa” now)

and at the end:

If you are running x86_64, you need the lib32 opt depends for your driver - check that mhwd has it correctly set
If you are having problems with the steam license, remove .steam and .local/share/Steam
Library issues can be fixed with the Steam (Purge Libraries) launcher
Check https://forum.manjaro.org/index.php?topic=16054.msg149783 for info
:: Starte post-transaction hooks...
(1/5) Compiling GSettings XML schema files...
(2/5) Probing GTK3 input method modules...
(3/5) Updating icon theme caches...
(4/5) Updating the desktop file MIME type cache...
(5/5) Updating the MIME type database...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'

doesn’t seem to matter, but i thought i’d mention it :wink:


#29

@philm. No NET ISO this time?


#30

HAPPY HALLOWEEN!!! to everyone. I hope you get to have some spooky good fun.


#31

No, we removed the function to use the cli-installer and the NetInstall function of Calamares is not finished. We might add a netinstall disk with Manjaro 17.0 Gellivara in Spring.


#32

Okay. Just wondered why only kde and xfce versions where up.

Torrents are now live though!


#33

Indeed, old problems with sddm seem to be cleaned up on this update (or perhaps one of the prior ones). I’ve closed my whiny bug report on sddm github for now.


#35

During the non graphical boot the ok in systemd are not couloured. Is this normal?


#36

All good. No issues on KDE 4.4 kernel. Will stay on 4.4 until 4.9 is stable, then use 4.4 as backup.

Many thanks.


#37

I cannot install my system the way I want it using Calamares (lvm on luks), only cli-installer is capable of doing that, is there an alternative for an oddball like me?:confounded:

I have been using lvm with /swap /root /home on luks for years, I don’t want to change that.

Edit: @eugen-b
I can use cli-installer from 16.08, it does not generate mkinitcpio hooks but I can handle that, the problem is the updates galore later!
Anyway, I have high expectations for Calamares.

Edit 2: Thanks guys, gonna give it a try!


#38

The last version with the CLI installer working properly was 16.06.
Edit: If you can handle mkinitcpio with 16.08, use one of those ISOs. The updates should run smoothly, only update systemd 231-1 -> 231-4 in TTY and separately from the rest:
sudo pacman -S systemd systemd-sysvcompat libsystemd


#39

Its still in the repo’s “manjaro-cli-installer” you can install and use it in the live enviroment


#40

I installed the Manjaro KDE 16-10. Kernel 4.9-rc3 did not boot.

But the kernel 4.4.28 works without any problem for me.

Finally, a great KDE distro where everything seems to work.

Many thanks to Manjaro KDE Team.


#41

And, once again, am very pleased with another flawless update.
Keep them coming devs!. :smiley:


#42

Update was smooth. Thank you … Is that Manjaro KDE shown in the pic ?