[Stable Update] 2016-10-23 - Manjaro 16.10 Package Release

stable
release

#165

Thank you, but when I unmaximize, I can drag the windows edges, but they snap back to their original dimensions. Fortunately Virtual Box seems to work, but I wonder what could have changed the way VMware works with Manjaro KDE.


#166

Yeah, you are right i just forgot that one, ALWAYS verify the content of a link, you could be rickrollled!!! or worst. I just put it shortened because if not, i have to write like 40 words. Thanks by the advice, i just wanted to help but it looked insecure at first sight, what that script does is download other scripts for update/upgrade Manjaro, Ubuntu and also download screenfetch right from KitttyKatt Github Page. but also you can see what an script like that one does without the ( | bash ) part. Anyways thank for the advice.


#167

Did you switch kernels in the process of updating your VM? If so you might need to make sure you got the manjaro guest packages from the right place.

I remember getting caught in that same situation, but it was so long ago I can’t remember how I dug my way out of it.


#168

This is the first Manjaro stable update that I have had significant problems with, though the cause was undoubtedly my ailing hardware and not a fault with the update itself.

Anyway, all was going fine until mid install the login session locked up. We’re talking frozen display, no keyboard or mouse input detected and no HDD activity light to give me any indication that the install was still progressing. Couldn’t even switch to the other ttys. After leaving it for an hour, I decided I had to force a shutdown.

After starting the station back up I was chucked into a black screen with a flashing cursor.

Ctrl Alt F1 showed me that Network Manager had failed to start and after examining the journal I began to realise that a number of shared libraries were corrupted (file too short).

What then followed was a couple of hours of chroot’ing into my install to get to the stage where Network Manager would work again, so I could finish the update process, only to then discover that my trustdb.gpg file had also become messed up and gpg couldn’t resolve the issue because a library it relied on was also corrupted.

After fixing that and getting the database recreated and all the keys re-imported, the update completed and I rebooted, only to end up back at a black screen because systemd couldn’t launch lightdm due to another corrupted library.

10 minutes later, and another package forcibly removed and then reinstalled, I was back and able to log into my XFCE session.

As interesting as it was to fix, may I never have to experience anything like that again. Good job it was the old machine I use at work, and not my personal rig. That would have been less learning experience and more gut-wrenching panic.


#169

This hint fixed my problem. Now my wlan runs as fast as usual.
Thank you very much for your support @philm :slight_smile:
regards
caho


#170

Thank You! Fingers crossed for a bug fix soon :slight_smile:


#171

You actually get an error message “Manjaro is not configured properly to boot” (basically or not)?
You would get to a kernel panic and that’s it.

What exactly is that message and what distro (and grub version - “grub-install -V”) is this?
Got to try it out.


#172

Same here on xfce. Gvim is just empty.


#173

I want to know what file system you were using, so I know what to avoid in the future.
Yeah, it could have been your old disk, but if that were the case Its unlikely a reinstall would have worked.


#174

I’m just using ext4.

Well, the disk was also encrypted using luks.


#175

I am using gnome with lxde login manager. After the update when i log in i see only a black screen with some small white artifacts. Whatever option i give to lxde (gnome, gnome xorg, classic gnome etc) the result is the same. Black screen.


#176

well, I installed the aur - git version of gvim and at least these problems are gone. These have their own share of problems (no spell check). Anyhow, I guess gvim needs to be rebuilt in the official repo to solve this.


#177

Hi, my update of Plasma went fairy well. I had 3 issues:

Other than that smooth sailing. Thanks guys.


#178

Read the manual, smooth update on XFCE. Could do with less lengthy update instructions, though.

Thanks to the Manjaro team.


#179

Thanks a lot Philm [next time I would search a litle more before asking for help :smirk:]

So If you’re on Gnome 3.22 and if your screen flickers :

  • First,verify if you’re on wayland (do a “alt+F2” and “r”, if gnome shell can’t reboot, the system tells you you’re on wayland by default > if so like me, log off and chose gnome on Xorg)

  • Next, commenting(#) or removing the “CLUTTER_PAINT=disable-clipped-redraws:disable-culling” in /etc/environments (don’t forget to save)

  • Reboot

and voila !


#180

thanks again for your help, my problem is solved :relaxed:


#181

No problems on xfce


#182

Evince don’t show my printers.

The solution is install the package gtk3-print-backends that i found in a post of eugen-b [Testing Update] 2016-10-13 - Plasma 5.8.1, Framework 5.27, Gnome 3.22.1.


#183

Same problem for gvim here, all the editor is empty.

You can just revert back to the last version if you have it in your cache:

pacman -R vim-runtime gvim
cd /var/cache/pacman/pkg
pacman -U vim-runtime-8.0.0005-1-x86_64.pkg.tar.xz gvim-8.0.0005-1-x86_64.pkg.tar.xz

Version 8.0.0005 works fine for me.


#184

I followed the instruction in this page and I found that my systemd is alredy is 231-4 and all the other packages mentioned there is installed.

Am I safe???