[Stable Update] 2016-10-23 - Manjaro 16.10 Package Release

stable
release

#61

Not sure exactly what just happened.

sudo pacman -Syyu

It synced the package databases, then prompted me to upgrade the keyrings, completed okay, then prompted me to continue installation.

I must have fat fingered hitting ‘Y’ as installation stopped. Now running…

sudo pacman -Syyu

… tells me my system is up to date and there is nothing to do, but NO updates were applied.

Can anyone explain what happened here and how I can remedy and apply this update?


#63

Hi anything is Green and we are Go! Thank You Manjaro Team :heart_eyes:


#65

Your mirror probably hasnt synced. Check at repo.manjaro.org

You can use pacman-mirrors to set mirror or automatically set fastest with (use “-i” for interactive)

sudo pacman-mirrors -g

then

sudo pacman -Syyu

#66

Thank you Philip and the Manjaro Development Team for another great release.

Thank you also Cubanpit for the help with the keys/signature related errors.

My XFCE is running without problems after the update.

All the best,
Richard


#67

It had. I ran

sudo pacman-mirrors -g

before I ran

sudo pacman -Syyu

and installation started before it suddenly stopped abnormally after upgrading the keyrings package.

No updates were applied, due to abnormal pacman termination, and my system now thinks it is up to date.

Running

sudo pacman -Syyu --force

does nothing either, just tells me there is nothing to do…

EDIT: Moved into its own update issue thread


#70

No issues, but I noted a huge speedup on kernel (4.4) load time.

systemd-analyze
Startup finished in 7.681s (firmware) + 756ms (loader) + 1.225s (kernel) + 2.294s (userspace) = 11.958s

I was getting around 10s on kernel load before, so this almost halves the startup time.


#71

KDE and Intel I5. Update was very smooth. All done and I have rebooted. Seems to be a little faster. Thank you to philm and the rest of folks.

Manjaro Rocks!!!


#72

Thanks, fixed the same issue on my laptop. Bookmarked :relaxed:


#73

This fixed my issue, ( see above posts) but I have no idea why?

How does keyring regeneneration affect pacman identifying which packages are required to be updated?

Everything works fine now, a big thank you to the Manjaro Team, my system is flying along. Said it before, say it again, best distro on the planet!


#74

On KDE, followed the tips - working!

But have the issue with small tray icons -
edit the file ~/.config/plasma-org.kde.plasma.desktop-appletsrc

[Containments][179][General]
extraItems=org.kde.plasma.devicenotifier,org.kde.plasma.printmanager,org.kde.plasma.volume,org.kde.discovernotifier,org.kde.plasma.networkmanagement,org.kde.plasma.clipboard,org.kde.plasma.notifications,org.kde.kdeconnect,org.kde.plasma.
mediacontroller,org.kde.plasma.bluetooth,org.kde.plasma.battery
hiddenItems=org.kde.plasma.battery
iconSize=1
knownItems=org.kde.plasma.devicenotifier,org.kde.plasma.printmanager,org.kde.plasma.volume,org.kde.discovernotifier,org.kde.plasma.networkmanagement,org.kde.plasma.clipboard,org.kde.plasma.notifications,org.kde.kdeconnect,org.kde.plasma.
mediacontroller,org.kde.plasma.bluetooth,org.kde.plasma.battery

I am still to green to figure this one out on my own - what do I edit? how do I do that? where is the file? is it safe?
Help please


#75

#76

I used recoll to find the file but inside there is no ‘iconSize=1’

At least when edited in Kate.


#77

Its not there, the file fills the data that is not default. You just need to add it and logout login.


#78

This looks like one of the cleanest Stable Releases I’ve seen.
I’ve had literally nothing wrong so far.


#79

Which position? Top bottom?I have never done it and wish to avoid screwing things up…

bear with me


#80

Open file with kate ~/.config/plasma-org.kde.plasma.desktop-appletsrc then press Ctrl+F and search for extraItems There you will find few entries, choose the one that will be inside [Containments][45][General] I have 45 number, you may have different. And add iconSize=1 (or 2) at the next line after knownItems


[Stable Update] 2017-06-06 - Plasma 5, Boost, Deepin, Mesa, GCC
KDE taskbar icons are too small
#81

The day I found Manjaro has gone down in history as the most memorable in 2016.

Thank you.

p.s. one thing thats been bothering me - my partition is only 30GB, this update has taken 2GB, does it mean I will run out of space within 3,4 years with each huge upgrade?


#82

Upgrade impossible

fzf-0.15.4-1-x86_64
udiskie-1.5.1-1-any
checking keys in keyring
checking package integrity
error: fzf: signature from "Ambrevar " is unknown trust

:: File /var/cache/pacman/pkg/fzf-0.15.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: udiskie: signature from "Ambrevar " is unknown trust

:: File /var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Befehl endete mit FEHLERN !

What can I do ?

I tryed
sudo pacman-key --init >> ok
sudo pacman-key --populate archlinux manjaro >> ok
sudo pacman-key --refresh-keys >> error

gpg: 98 Schlüssel werden per hkp://pool.sks-keyservers.net aktualisiert
gpg: Refresh vom Schlüsselserver fehlgeschlagen: Kein Schlüsselserver verfügbar
==> FEHLER: Ein spezifizierter lokaler Schlüssel konnte nicht vom Schlüssel-Server aktualisiert werden.

regards
caho


#83

Manjaro’s pacman keeps 3 latest versions of a package. Its better not to change the behaviour because if anything goes wrong you’ll not be able to roll back the changes.
Here go to Cleaning the package cache section, there you’ll find your options. If you want to clean cache do it atleast after a week of usage so that you could see if its ok to do so.


#84

Just installed the update, everything went smoothly (although my touchscreen is a little finicky; seems to only register hard presses on the screen. My stylus and eraser work just fine, though, probably just have to reinstall the wacom drivers).

However, I was using Linux version 4.7.1 and it bumped me up to 4.7.10. Nothing groundbreaking, but apparently 4.7.10 is now un-maintained? Does this mean I should update the kernel to 4.8? How long do you all plan on keeping 4.7.10 around before its completely abandoned?