[Stable Update] 2016-10-23 - Manjaro 16.10 Package Release

stable
release

#1

Hi Community,

After several months hard work we are happy to announce Manjaro 16.10 Fringilla to the public. This is the package-wise release of our current stable release. Install medias (Release Candidates) can be downloaded here. All the packages added with this update can be viewed here.

Some of you might have noticed the dirtyCOW issue which got now fixed by this update. All currently running kernels should be updated to the latest available kernels. Also read here about this issue and how the Manjaro Development Team has fixed it. Users of the kernel series linux314 and linux46 should update to the next higher kernel release as both of these series got removed from our repositories as they reached end of life status a while ago.

This update has more key parts to offer than our last updates. So here are some we like to mention:

  • Firefox got updated to 49.0.2, which fixes some issues in that series
  • The Gnome Desktop got updated to 3.22.1, which brings new enhancements
  • The Budgie Desktop is now at version 10.2.8
  • The Lumina Desktop is now at version 1.1
  • Also the MATE Desktop got updated to its latest point release of 1.16 series
  • On KDE side we have now Plasma 5.8.2, Framework 5.27 and Apps in version 16.08.2
  • Octopi got ported to alpm and we updated our plasma themes in regard of given plasma changes
  • VirtualBox is now at version 5.1.8

All upstream packages got updated to snapshot Sun Oct 23 19:35:45 CEST 2016.

A full release announcement of our install medias will follow, when the final ISO images got reviewed and tested. Expect them in the next couple of days depending on the testing results.

Kind regards,
Philip Müller and the Manjaro Development Team

Update instruction

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec

Check if your mirror has synced, then do the following steps to have a smooth update:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su

Install medias including this update


Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn’t affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries
  • steam: is the upstream client by Archlinux
  • steam-native-runtime: is the addon by upstream Archlinux to use native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • Linux310 3.10.104
  • Linux312 3.12.66
  • Linux316 3.16.38
  • Linux318 3.18.43
  • Linux41 4.1.34
  • Linux44 4.4.27
  • Linux47 4.7.10 [EOL]
  • Linux48 4.8.4
  • Linux49 4.9rc2 (git-preview)
  • Linux-RT-LTS 4.4.27_rt35
  • Linux-RT 4.8.4_rt2

Package Changes

  • stable community i686: 764 new and 715 removed package(s)
  • stable community x86_64: 796 new and 748 removed package(s)
  • stable core i686: 51 new and 54 removed package(s)
  • stable core x86_64: 51 new and 54 removed package(s)
  • stable extra i686: 997 new and 1006 removed package(s)
  • stable extra x86_64: 998 new and 1006 removed package(s)
  • stable multilib x86_64: 36 new and 34 removed package(s)

Manjaro stuck when startup after update today
Segmentation fault krita
Отвалился интернет после перезагрузки
#2

i did sudo pacman -Syyu and nothing happened ;-;


#3

it takes a few hours until the repos get synced.


#4

You probably have to wait for the mirrors to catch up.


#5

Well, you should use one mirror which is already synced :wink:


#6

http://repo.manjaro.org/


#7

i’ll update my mirror list ^-^
thanks guys


#8

I am getting this odd error, looks like I am too updated somehow.

looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-shell-extension-mediaplayer: requires gnome-shell<3.21

#9

I got this one too.


#10

Please uninstall that AUR package. It is outdated and not supported by Manjaro.


Manjaro GNOME - can't install latest update
#11

Big Warring on for anyone that want to try linux49. Some of us can’t boot into are system. You have been warn!


#12

@Days: I assume most of our users know that an early preview of a kernel may break or not boot. That is why you install kernels additionally and don’t replace existing working series. Everybody is free to install those kernels which are available. You have to test them. On my end it works. I can boot into linux49. However I know it may be unstable and not wise to use at this state …


#13

Install went like this: Since I had bad luck with pacman last time I tried octopi. Almost got through the install but froze at the end. No keyboard, no mouse. I kept it running for awhile in case it was still downloading and shut down. Restarted and pamac cleaned up the mess and finished the install. All good here, my tray icons have shrunk but kernel 4.8.4 runs well. No problems, good work.


#14

I keep getting the following error.

File /var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

It asked me if I want to delete it and I have answered yes but keep getting the same error. I even tried sudo pacman -Syyu and getting the same error.


#15

try it a couple more times and if doesnt work report back


#16

Nope still same error.

error: udiskie: signature from “Ambrevar ambrevar@gmail.com” is unknown trust
:: File /var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]


#17

Yes…

you could always just sudo rm /var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz


#18

I have always answered yes deleting it with no change. Your command yielded.

rm: cannot remove ‘/var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz’: No such file or directory


#19

Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.


#20

try sudo pacman-mirrors -g