[Stable Update] 2016-10-09 - Kernels, Manjaro Tools, Deepin, NM, LibreOffice, Steam

update
stable

#171

not sure but I took a pic of the screen with my phone.


#172

[quote=“philm, post:1, topic:10663”]
IF WE BROKE YOUR SYSTEM WITH THIS - WELL WE ARE SORRY.
[/quote]Thanks for that …
It is broken.
It broke during the upgrade with a kernel panic. (yes tty was being used; kernel was 4.8.1)
The system survived that so started the upgrade again. It completed(with systemd v.234).
Reboot and got a blank screen, completely blank/black - no cursor/pointer, nothing.
At tty2 I found that sddm and Xorg(as well a dbus for sddm) were all running.
…(hours of uninstall, reinstall, downgrade, upgrade, reboots …)
There is some issue with QML, hence sddm won’t (ever) display the login.

Tried lightdm but lightdm won’t run as long as sddm is installed{*}. Of course the problem is not the DM so no point in removing SDDM even if I wanted to switch(& I do not).

The startkde won’t start X (:confused:) …etc.

I finally got to KDE with startx but plasma will not start because it, now, cannot use OpenGL 2 …which is what it has been using until this update borked the GUI system.

I am fring tired and need a break … and lunch.

The last couple updates were not good either, tho’ I did not experience the broken system like so many did; guess I was just lucky. …not this time, :frowning:.

Maybe instead of having updates on a timed schedule, they should be on a participation schedule which lasts (up to) two weeks. @philm, WDYT?

{*} installed really means sddm.service is enabled by/with systemd. When a [DM] is enabled a symlink is created: /etc/systemd/system/display-manager.service → /usr/lib/systemd/system/[DM].service.
…“installed” a lot easier and shorter, ;), albeit not accurate.


#173

[quote=“Aditya, post:40, topic:10663”]
and has linux dumped the LTS concept?
[/quote]The next LTS is kernel 4.9. Greg K-H announced on Google+ as his blog is/was broken:
https://plus.google.com/+gregkroahhartman/posts/DjCWwSo7kqY\

But one should read this in the responses too:


The LTS kernel has nothing to do with the “normal” kernel cadence or release cycle or stability at all. It’s all for those companies that somehow feel that sticking with a specific kernel version fits their business/product model.

IOW, LTS kernels have no more magic than any other kernel.


#174

I’m still wondering about this question.


#175

@neognomic: sorry to hear that you have some issues with your system. As I always test on regular basis if a vanila installation of Manjaro KDE still runs it was enough for me. At some point we have to push the update to stable branch. Manjaro KDE 16.10-rc1 seems to run just fine. We try to avoid these issues, but not all can be avoided … nvidia-304xx is known to have some issues with release v304.132 producing black screens. Maybe that combination creates some issues on your end …

@double-gulp: seems some issue with your encrypted swap-drive. Some similar got already posted due our reviews of this update. You may want to edit your grub.cfg on bootup to avoid mounting your swap. Check the resume= line within your boot entry and remove it temporally. How to edit it I already posted in regard of the plymouth disable.


#176

Check out this guide, but verify if it apply for encrypted system!


#177

says nothing about encrypted drives.


#178

@double-gulp: Here is some guide for encrypted systems. Also it is recommended to disable the swap temporally so you might be able to boot. Which graphical driver do you use?


#179

say i do get into my system. once there i have no idea what’s broken or how to fix it.

i’m just going to use the liveCD to copy files from my computer to a usb drive and reinstall Manjaro completely.

but thanks for the help. still love Manjaro and won’t be switching.


#180

I second this. I use Spyder heavily for work (I tried the Qt5 version on AUR, but it was still not at all usable…). Please, do not remove Qt4 in the near future, still many apps depend on it (KDE or outside KDE).


#181

Just updated a freshly installed Mate Desktop install from the latest stable ISO. Used TTY2 for the update and had no issues.


#182

I think they can both be installed, but only one can/would be enabled in systemd

I switched to lightdm from sddm, and it fixed another problem I was having.
See: Switching to LightDM instead of SDDM

So if you think sddm might be at fault, just try lightdm for a bit. It
did solve my problem. And switching back to sddm is just as easy.


#183

@double-gulp: sorry that we couldn’t figure out what went wrong on your end. Good luck on installing Manjaro 16.10-rc1.


#184

XFCE/Stable/Systemd/4.7(4.4 also installed)/Intel


Ctrl+Alt+f2

Login with username/password

sudo pacman -Syyu

Remove qtchooser? - Y

reboot -n

###No Problem.


#185

I just followed the revised upgrade instructions, and all went well!

Wonderful! Thank you :wink:


System:    Host: manjaro1 Kernel: 4.4.24-1-MANJARO x86_64 (64 bit)
Desktop:   KDE Plasma 5.7.5 Distro: Manjaro Linu

` Machine: System: Hewlett-Packard product: HP Compaq 6200 Pro
Mobo: Hewlett-Packard model: 1497
UEFI: Hewlett-Packard v: J01 v02.06 date: 06/09/2011
CPU: Dual core Intel Core i3-2100 (-HT-MCP-) cache: 3072 KB
Graphics: Card: Intel 2nd Gen Core Processor Family Integrated
Graphics Controller


#186

Hate to say it but the new systemd crashes calamares-dev on your 16.10 rci iso with a report about systemctrl and lightdm broken


#187

I did not yet install 16.10-rc1 at all. I only started CAL and did a quick check. That is why I didn’t announce it yet publicly. When does CAL crash?


#188

Towards the end, it says the call of systemctl enable lightdm.service returns with non zero


#189

Well, I don’t know about Amarok because I don’t use it, but I disagree on krusader. 2.4 is a beta version. It is as unstable as the git version. In fact, on my experience (I used it for a long time), the git version has more stability and is faster. I haven’t had an issue with the git version until now. The only “surprise” I had was that if you switch sides in the synchronizer (to delete some files that were on the right side) it might not work properly (so I just don’t do it). Despite this issue and despite having no support/maintainer at the moment, the git synchronizer still works way better than the one from version 2.4 (constantly loosing network connections).

Krusader doesn’t have an official launch for 4 years, and its last stable version was more than 7 years ago (2.0). How long are you going to wait? It is a superb peace of software but the people working on it obviously aren’t many and/or are too busy to give the attention it deserves. If you’re scared about bugs, take a look at the mailing lists for some time before updating it. Just because you use a git version you don’t need to constantly update it. Just try it, it’s worth the try!


#190

For my problem of game not running after this update, I removed steam-manjaro and installed steam, and now it works.

Problem in steam-manjaro ?