[Stable Update] 2016-09-20 - Linux 4.8, KDE Framework 5.26, Gambas3, Mesa, Octopi

Hi community,

one week passed and we have the next update-pack for you. We have now also the latest KDE Framework 5.26 added. Kernel v4.8 got introduced with its sixth release candidate, php, haskell and gambas3 updated to their latest versions and some work went into our tools. Additionally we fixed some issues in Octopi, Pamac and updated our manjaro-tools to 0.13.x series. Please contact our dev-team if you have issues on creating Manjaro Spins with this new tool set.

Archlinux upstream fixes are now from: Tue Sep 20 07:22 CEST 2016.

Please report any issues you may have with this update. Also read our troubleshoots to avoid known issues. A detailed list of package changes can be found here.

Kind regards,
Philip Müller and the Manjaro Development Team


Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn’t affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

Steam might not work due incompatiblity of libgpg. You my try followed command to “fix” it:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • Linux310 3.10.103
  • Linux312 3.12.63
  • Linux314 3.14.79 [EOL]
  • Linux316 3.16.37
  • Linux318 3.18.41
  • Linux41 4.1.32
  • Linux44 4.4.21
  • Linux46 4.6.7 [EOL]
  • Linux47 4.7.4
  • Linux47 4.8-rc6
  • Linux-RT-LTS 4.4.19_rt27
  • Linux-RT 4.6.7_rt13

Package Changes

  • stable community i686: 510 new and 502 removed package(s)
  • stable community x86_64: 537 new and 529 removed package(s)
  • stable core i686: 29 new and 27 removed package(s)
  • stable core x86_64: 29 new and 27 removed package(s)
  • stable extra i686: 427 new and 405 removed package(s)
  • stable extra x86_64: 427 new and 405 removed package(s)
  • stable multilib x86_64: 17 new and 17 removed package(s)
10 Likes

Woo-woo, thank you!
I hope it fixes:
https://forum.manjaro.org/t/octopi-just-killed-the-desktop-and-rebooted-the-system/?source_topic_id=9692
(I’m getting a little tired of using LXQt, :rolling_eyes:.)

BTW, Firefox 49 dropped today …prbly to late for this Stable Update, huh? [but it is in AUR as firefox-beta-bin so just an update for me]

Fixes LXQT for me too :).

Blocking problem for LXQt : lxqt-session uses libQt5Xdg.so.1 who is replaced by libQt5Xdg.so.2

So, lxqt cannot start any more. I did a link:

libQt5Xdg.so.1 -> libQt5Xdg.so.2

and it works now, but et least the package lxqt-session is to recompile.

This should fix the LxQT issue we had …

### BoxIt memo ###

User philip created a snapshot of branch 'testing' to 'stable'.

 - stable community i686:  24 new and 26 removed package(s)
 - stable community x86_64:  25 new and 27 removed package(s)
 - stable core i686:  1 new and 1 removed package(s)
 - stable core x86_64:  1 new and 1 removed package(s)
 - stable extra i686:  4 new and 4 removed package(s)
 - stable extra x86_64:  4 new and 4 removed package(s)

Archlinux upstream fixes are now from: Tue Sep 20 22:16 CEST 2016.

:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                                cgal              4.8.1-1                4.9-1
                       diff-so-fancy             0.11.1-1             0.11.2-1
                                gliv              1.9.7-3                    -
                             go-ipfs              0.4.2-1              0.4.3-1
                          kdeconnect                1.0-1              1.0.1-1
                             liblxqt             0.10.0-6             0.10.0-7
                          libsysstat              0.3.1-3              0.3.2-1
                       libwebsockets              2.0.2-1              2.0.3-1
                          lxqt-about             0.10.0-4             0.10.0-5
                         lxqt-config             0.10.0-5             0.10.0-6
                     lxqt-globalkeys             0.10.0-3             0.10.0-4
                  lxqt-notificationd             0.10.0-4             0.10.0-5
                          lxqt-panel             0.10.0-5             0.10.0-6
                      lxqt-policykit             0.10.0-3             0.10.0-4
                lxqt-powermanagement             0.10.0-4             0.10.0-5
                       lxqt-qtplugin             0.10.0-4             0.10.0-5
                         lxqt-runner             0.10.0-4             0.10.0-5
                        lxqt-session             0.10.0-3             0.10.0-4
                           lxqt-sudo             0.10.0-3             0.10.0-4
                           mosquitto             1.4.10-1             1.4.10-2
                            openscad         2015.03.03-5         2015.03.03-6
                               opera       39.0.2256.71-1       40.0.2308.54-1
                            phonegap              6.3.2-1              6.3.3-1
                               qt5ct               0.26-1               0.27-1
                             setconf              0.7.2-1              0.7.3-1
                              xemacs            21.5.34-1                    -


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                                cgal              4.8.1-1                4.9-1
                       diff-so-fancy             0.11.1-1             0.11.2-1
                                gliv              1.9.7-3                    -
                             go-ipfs              0.4.2-1              0.4.3-1
                          kdeconnect                1.0-1              1.0.1-1
                             liblxqt             0.10.0-6             0.10.0-7
                          libsysstat              0.3.1-3              0.3.2-1
                       libwebsockets              2.0.2-1              2.0.3-1
                          lxqt-about             0.10.0-4             0.10.0-5
                         lxqt-config             0.10.0-5             0.10.0-6
                     lxqt-globalkeys             0.10.0-3             0.10.0-4
                  lxqt-notificationd             0.10.0-4             0.10.0-5
                          lxqt-panel             0.10.0-5             0.10.0-6
                      lxqt-policykit             0.10.0-3             0.10.0-4
                lxqt-powermanagement             0.10.0-4             0.10.0-5
                       lxqt-qtplugin             0.10.0-4             0.10.0-5
                         lxqt-runner             0.10.0-4             0.10.0-5
                        lxqt-session             0.10.0-3             0.10.0-4
                           lxqt-sudo             0.10.0-3             0.10.0-4
                           mosquitto             1.4.10-1             1.4.10-2
                            openscad         2015.03.03-5         2015.03.03-6
                               opera       39.0.2256.71-1       40.0.2308.54-1
                            phonegap              6.3.2-1              6.3.3-1
                           qmapshack              1.7.1-1              1.7.1-2
                               qt5ct               0.26-1               0.27-1
                             setconf              0.7.2-1              0.7.3-1
                              xemacs            21.5.34-1                    -


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                      linux-firmware   20160730.6bc2c60-1   20160915.c4c07a8-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                      linux-firmware   20160730.6bc2c60-1   20160915.c4c07a8-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                              ffmpeg            1:3.1.3-1            1:3.1.3-2
                      python-twisted             16.3.2-1             16.4.1-1
                     python2-twisted             16.3.2-1             16.4.1-1
                             tomcat7             7.0.70-1             7.0.72-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-09-20           2016-09-21
-------------------------------------------------------------------------------
                              ffmpeg            1:3.1.3-1            1:3.1.3-2
                      python-twisted             16.3.2-1             16.4.1-1
                     python2-twisted             16.3.2-1             16.4.1-1
                             tomcat7             7.0.70-1             7.0.72-1
1 Like

when will this update be available to download through pamac?

Update went well here.

Virtualbox VM refused to start, but it was the same old drill of needing to re-fetch the extension pack, The message was:

The device helper structure version has changed.
If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH).

Jump to https://www.virtualbox.org/wiki/Downloads ,
Download that xtension, install into virtualbox via preferences menu and relaunch the VM.
And Sound in the VM works again!!! Hooray.

1 Like

please check if your mirror has already synced …

1 Like

Nope, and I don’t know why. I did the update of the lxqt-modules, removed my link on libQt5Xdg.so.2, but lxqt-session always needs libQt5Xdg.so.1, also if it doesn’t appear in a ldd lxqt-session. Another module called by lxqt-session ?

Be sure you have lxqt-session 0.10.0-4 installed …

[pat@lq64 ~]$ pacman -Qi lxqt-session
Name : lxqt-session
Version : 0.10.0-4

[root@lq64 lib]# rm libQt5Xdg.so.1
[root@lq64 lib]# lxqt-session
lxqt-session: error while loading shared libraries: libQt5Xdg.so.1: cannot open shared object file: No such file or directory

(edit)
[root@lq64 lib]# ln -s libQt5Xdg.so.2 libQt5Xdg.so.1
[root@lq64 lib]# lxqt-session
/build/lxqt-session/src/lxqt-session-0.10.0/lxqt-session/src/sessionapplication.cpp : 76 Session “session” about to launch (default ‘session’)
Environment variable GTK_CSD = 0
"/root/.config/lxqt/session.conf"
xrdb: Xcursor.theme:whiteglass
Xcursor.size:18
Xcursor.theme_core:true
(…)

(re-edit)
[root@lq64 bin]# ldd lxqt-session | grep Xdg.so
libQt5Xdg.so.2 => /usr/lib/libQt5Xdg.so.2 (0x00007f55fdc31000)

Thanks for the smooth update! :clap: :thumbsup:

The one little issue I’ve had:
ZFS went rouge on me after the update it failed to mount my pools, but everything worked after I manually mounted them.

So I checked the release notes for zfs-0.6.5.8:

https://github.com/zfsonlinux/zfs/releases/tag/zfs-0.6.5.8
Changes
This release contains updates to the systemd service files. In order to ensure the services are started properly it’s >recommended that after updating the systemd presets be reset to the defaults.
systemctl preset zfs-import-cache zfs-import-scan zfs-mount zfs-share zfs-zed zfs.target

and solved the issue by:

1 Like

i’ve had a very big issue. i upgraded to the latest upgrade and the screen turned off and stayed off. it does have power to it, the video stopped working upon boot

Another way to have an always up-to-date Firefox is to actually download it from mozilla. I use Firefox in this way for more than half a year without any problems. It updates itself automatically or your can switch off this option and update it from the “About Firefox” menu as soon as a new version is out.

2 Likes

I encountered this error while it was running post-transaction hooks:

(2/6) Updating icon theme caches...
gtk-update-icon-cache: The generated cache was invalid.
gtk-update-icon-cache: The generated cache was invalid.

Otherwise, the update went smoothly.

Another straight forward XFCE update

Except for osprober repeating the probe 3x, twice, update went smoothly,
LXQt and KDE run fine, AFAICT.

Unfortunately, the hard crash issue that is described in https://forum.manjaro.org/t/octopi-just-killed-the-desktop-and-rebooted-the-system/ remains and actually got slightly worse.

With a couple more tests, I did pin it down to kwin_x11 and octopi (or so it seems but maybe the plasma &| frameworks is involved too).

I’d like to uninstall octopi …it is just not a good app. Has nice bells & whistles but aggravates me more often than not and now have zero confidence in it.
I’ll hold off until y’all decide what is going to be done, if not too far away, ;).

c-ya

I run KDE and used Octopi for this update. Update ran very smooth, then I shutdown and then rebooted. All smooth. Thank you philm and the developers for their great work.

gary

Again thanks Development Team!
No buttons to push.:slight_smile:
xfce4 intel lap and desk pretty vanilla ready for the masses.
:kissing_smiling_eyes:

Forum kindly sponsored by Bytemark