[Stable Update] 2016-09-13 - Xorg-Stack, Firefox, Plasma5, KDE Apps, Manjaro Tools, GCC

Yes.

DK3

I’m not at home now but that causes the problem. If you have catalyst installed doing the upgrade doesn’t boot. No problem if you have open ati drivers. @philm?

WHY THE HELL IS X.ORG 1.18 in stable? while testers have a lot issues with it please downgrade X.org
@philm

2 Likes

The problem appears if you have only catalyst installed. After the update you can switch to catalyst but then you can’t switch to free ati driver with xorg1.18 (doesn’t boot)

I used LiveCD and mhwd-chroot to switch from Proritary to Free Driver, but the System won’t boot.

DK3

Xorg should not have been updated on stable for that reason @philm
you have to downgrade it as fast as possible before it bricks more people’s PCs

Yes I did.

there is an with catalyst and XORG do you have a laptop

Something with lightdm, but I,m not at home now for more details. Look the last lines of log.

I found the Problem on my Machines.

I found out, that my Systems are booting to a Point, that I can switch to tty2 and can Login.

When I do this and type „startx“ I become an Error Message that „libunwind.so.8“ was not found.

And thats the Problem:

After Updating the System I check for orphaned Packages and unistall them.
Under the Packages was "libunwind“ and it looks, that it is needed to Boot with Proritary Catalyst Drivers.

I reinstalled the Package under tty2, Reboot and it worked.

It looks that the Update makes Changes to Dependencies Tree and gives libunwind free for uninstalling, while it is needed to Boot.

DK3

4 Likes

I am at work right now. I have a laptop here but the issue was with my home PC(stationary)

No matter what I answer y or n to the questions at the beginning.

:: Starting full system upgrade…
:: Replace akonadi-contact with extra/akonadi-contacts? [Y/n] y
:: Replace grantlee-qt5 with extra/grantlee? [Y/n] y
:: Replace libdbus with core/dbus? [Y/n] y
:: Replace prison-frameworks with extra/prison? [Y/n] y
:: Replace qt5-gstreamer with extra/qt-gstreamer? [Y/n] y
:: Replace quazip-qt5 with extra/quazip? [Y/n] y
resolving dependencies…
looking for conflicting packages…
:: quazip and quazip-qt4 are in conflict. Remove quazip-qt4? [y/N] y
:: xorg-server and xf86-input-aiptek are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-aiptek? [y/N] y

The upgrade fails.

error: failed to commit transaction (conflicting files)
manjaro-base-skel: /etc/skel/.Xresources exists in filesystem
Errors occurred, no packages were upgraded.

Does this mean I need to rename /etc/skel/.Xresources or delete it rm -r /etc/skel/*?

I just deleted it and ran the upgrade and so far no problems.

No problem on the netbook edition.

i get this error during update

[adi@lucy ~]$ sudo pacman -Syu
[sudo] password for adi: 
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Some packages should be upgraded first...
resolving dependencies...
looking for conflicting packages...

Packages (1) manjaro-system-20160902-1

Total Download Size:   0.02 MiB
Total Installed Size:  0.00 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 manjaro-system-20160902-1-any        17.1 KiB  65.6K/s 00:00 [##################################] 100%
(1/1) checking keys in keyring                                [##################################] 100%
(1/1) checking package integrity                              [##################################] 100%
(1/1) loading package files                                   [##################################] 100%
(1/1) checking for file conflicts                             [##################################] 100%
(1/1) checking available disk space                           [##################################] 100%
:: Processing package changes...
(1/1) upgrading manjaro-system                                [##################################] 100%

:: Starting full system upgrade...
:: Replace akonadi-contact with extra/akonadi-contacts? [Y/n] 
:: Replace grantlee-qt5 with extra/grantlee? [Y/n] 
:: Replace libdbus with core/dbus? [Y/n] 
:: Replace prison-frameworks with extra/prison? [Y/n] 
:: Replace quazip-qt5 with extra/quazip? [Y/n] 
resolving dependencies...
looking for conflicting packages...
:: xorg-server and xf86-input-aiptek are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-aiptek? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xorg-server and xf86-input-aiptek are in conflict (X-ABI-XINPUT_VERSION>=22)
[adi@lucy ~]$ 

my inxi -Fxzc0

EDIT: unchecked, networkmanager(im scared it might be broken so i’ll do it after), xf86 stuff and x-org-server to proceed with update

1 Like

I Testet the “libunwind” thing on an third System:

I installed the Updates and make a Reboot without checking the orphaned Packages.

  • working without Problems.

After Reboot I open the Package Manager go to the “Orphaned” Tab and see the libunwind Package.
I marked it as “Installed as expressly”, so the Entry is gone.

Make a Reboot again and all is working fine.

DK3

2 Likes

1 DO NOT UPDATE WAIT for further info
2 do you have an AMDGPU

$ sudo pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
archlinuxcn is up to date
:: Starting full system upgrade…
:: Replace akonadi-contact with extra/akonadi-contacts? [Y/n]
:: Replace grantlee-qt5 with extra/grantlee? [Y/n]
warning: gtk2: local (2.24.30+95+g876b5f7-1) is newer than extra (2.24.30-3)
:: Replace kdegraphics-kolourpaint with extra/kolourpaint? [Y/n]
:: Replace libdbus with core/dbus? [Y/n]
:: Replace prison-frameworks with extra/prison? [Y/n]
:: Replace quazip-qt5 with extra/quazip? [Y/n]
resolving dependencies…
looking for conflicting packages…
warning: removing ‘xorg-server-common’ from target list because it conflicts with 'catalyst-server’
warning: removing ‘xorg-server’ from target list because it conflicts with 'catalyst-server’
warning: removing ‘xf86-input-acecad’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-elographics’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-evdev’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-libinput’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-joystick’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-keyboard’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-mouse’ from target list because it conflicts with 'catalyst-input’
warning: removing ‘xf86-input-void’ from target list because it conflicts with 'catalyst-input’
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-ati and catalyst-server are in conflict (xorg-server<1.18.0)

i’m using catalyst amd driver.

[quote=“BruceAuyeung, post:28, topic:9164”]
i’m using catalyst amd driver.
[/quote] @BruceAuyeung refrain from updating till the issue is fixed

What is up with this fugly battery icon? It stays the same, regardless of icon theme

you can add the xfce4-power-manager applet(right click on panel,panel preferences,add item,power-manager-plugin)instead of the system tray battery icon!

Forum kindly sponsored by Bytemark