[Stable Update] 2016-08-06 - Kernels, MSM, Pamac, Octopi, Tools

update
stable

#1

After more than a week we managed to prepare another stable update-pack for you guys. We concentrate more on our tools. Manjaro-Tools 0.12.4 includes needed fixes for QT 5.7 styling. Manjaro Settings Manager is now prepared to detect also our real-time kernels our Kernel Team is currently working in our testing branch. Some of our stock kernels got updated to the latest point releases.

Also our graphical package managers Pamac and Octopi gained both a new point release with needed fixes. Systemd is now at v231, Lumina Desktop got to its third beta release, VirtualBox is now at v5.1.2 plus Wine is now at 1.9.15. We sum this update-pack up with haskell and python packages and needed fixes to Mesa.

Archlinux upstream fixes are now from: Mon Aug 01 17:37 CEST 2016.

Please report any issues you may have with this update. Also read our troubleshoots to avoid known issues. Additional it would be good to test one of our preview install medias to check these changes on a fresh install. Detailed package changes can be viewed here.

Kind regards,
Philip Müller and the Manjaro Development Team


Troubleshoots

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

Steam might not work due incompatiblity of libgpg. You my try followed command to “fix” it:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Reference: Archlinux wiki



Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • Linux310 3.10.102
  • Linux312 3.12.62
  • Linux314 3.14.74
  • Linux316 3.16.36
  • Linux318 3.18.37
  • Linux319 3.19.8.23 [EOL]
  • Linux41 4.1.28
  • Linux42 4.2.8.13 [EOL]
  • Linux44 4.4.16
  • Linux45 4.5.7 [EOL]
  • Linux46 4.6.5
  • Linux47 4.7.0

Package changes

  • community i686: 281 new and 284 removed package(s)
  • community x86_64: 288 new and 289 removed package(s)
  • core i686: 23 new and 23 removed package(s)
  • core x86_64: 23 new and 23 removed package(s)
  • extra i686: 197 new and 177 removed package(s)
  • extra x86_64: 197 new and 177 removed package(s)
  • multilib x86_64: 7 new and 7 removed package(s)

Pamac Issue
[unstable] Layout errors after last update
How can i switch to Open-source amd drivers
I3: Cannot get steam to work
Where do I find "Widget Styles" for LxQT?
[solved ]Cannot start steam from "steam-manjaro"
#2

No problems with the update.

VirtualBox with i3 is still an unusable mess. Should not have been pushed to stable imho.
Still no nvidia drivers? 367.35 works fine here with a GTX 1070.


#3

amd single-core, xfce, kernel 4.7 no problems.
intel-i3 sandy bridge, xfce, kernel 4.7 no problems.

thank you, have a nice weekend


#4

What exactly do mean? Please be more specific. I’m using i3 in unstable without any problems everyday, so your statement sounds a bit surprising to me…
EDIT: Ah. You mean virtualbox in i3 because of the window size issue of vbox, I see … :no_mouth:


#5

Exactly :slight_smile:


#6

Smooth update, all working well. Many thanks Manjaro Team :smiley:


#7

21 votes and 100% success? OK, that’s good enough for me, I’m going to update also I’m not even going to wait mandatory minimum one day delay to meet guidelines for extra safe stable distro update :wink:


#8

All good on Plasma 5.


#9

Same here Good to go for Netrunner. Tho can’t Vote? Only shows “Show Results” and I haven’t voted.


#10

@Orbmiser: you have to press one of the circles.


#11

All’s well. Another good update.


#12

When upgrading from “Manjaro 16.08-pre2 Ellada” I get the following error

http://hastebin.com/awahurokob.coffee

error: failed to commit transaction (conflicting files)
memtest86+: /etc/grub.d/60_memtest86+ exists in filesystem
Errors occurred, no packages were upgraded.

Any ideas?


#13

@BryzNSTY you mean this?


#14

I received the message "gtk2: local (2.24.30+95+g876b5f7-1) is newer than extra (2.24.30-3)


#15

I used the command line so I didn’t see that exact screen, but yes - it’s the same error.


#16

This bug has been reported once someone finds a solution i will link it to you(if someone hasn’t done that by then)


#17

Yep was using Stylish dark theme and the circles were invisible thanks for the assist.


#18

The forum has been updated and the POLL window look different (and broken in the dark theme) But you can still see that is sayies


#19

Yep noticed that if I sit up higher and lean in can see it vaguely as Black text on too dark gray makes for harder reading.


#20

… Is using testing branch. You might be on an outdated mirror as the memtest86+ is already fixed.