[Stable Staging Update] 2021-05-13 - Nvidia, Kernels, KDE Frameworks, Plasma, Systemd, Mesa, LibreOffice, KDE Gear Mobile, FF, TB

Hello community,

Another stable staging branch update with some usual updates for you.


Get 20 % off on all of our Merch. Visit one of our stores.

  • Most of our Kernels got updated
  • Nvidia got updated to 460.80
  • We added Plasma Mobile Gear Apps. More info about them here.
  • Gnome Apps got mostly updated to 40.1. We are still shipping 3.38 shell!
  • Maui Apps are now at 1.2.2
  • We updated Systemd to 247.7
  • Firefox 88.0.1 and Thunderbird 78.10.1 got updated.
  • LibreOffice is at 7.1.3
  • Mesa got updated to 21.1.0
  • KDE Frameworks got updated to 5.82.0
  • KDE Plasma is now at 5.21.5
  • Lot of KDE-git package updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux44 4.4.268
  • linux49 4.9.268
  • linux414 4.14.232
  • linux419 4.19.190
  • linux54 5.4.118
  • linux510 5.10.36
  • linux511 5.11.19
  • linux512 5.12.2
  • linux513 5.13-rc1
  • linux54-rt 5.4.106_rt54
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed May 12 09:56:17 CEST 2021)

  • stable-staging community x86_64: 1189 new and 1155 removed package(s)
  • stable-staging core x86_64: 34 new and 33 removed package(s)
  • stable-staging extra x86_64: 627 new and 830 removed package(s)
  • stable-staging kde-unstable x86_64: 360 new and 358 removed package(s)
  • stable-staging multilib x86_64: 23 new and 24 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

At first attempt I’ve encountered issues with unsynchronized mirrors I guess. All packages were newer and python-dbus was in conflict with dbus-python (or something like that).
I’ve repeated switching branch procedure and at the final stage I had Dbus error and screen gone black :laughing: After reset, I didn’t see any errors on boot and system seams to work fine.

Yesterday I didn’t encounter any issues switching to testing and unstable branch on VMs (clean XFCE install).

I made backup before update so no issue for me, do you need any outputs before I roll back? Don’t see anything useful in pacman log :confused:

I have issue with KDE, plasma-desktop cannot loaded after update. I got black screen and nothing don’t happen after login. I can only move mouse pointer.

Also In SDDM I got error:

The current theme cannot be loaded due to the errors below, please select another theme.

file:///usr/share/sddm/themes/breath2Main.qml:26:1: plugin cannot be loaded for module “org.kde.plasma.core”. Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebindingsplugin.so: (/usr/lib/libKF5PlasmaQuick.so.5: undefinded symbol: _ZN14KWindowEffects11slideWindowEP7QWindowNS_17SlideFromLocationEi)

I tried select anothere theme changing parameter in config file /etc/sddm.conf, clean up cache folder but it don’t help me.

After so I removed package plasma-framework and all its dependencies, change branch to stable and install all packages from that branch.

sudo pacman  -Rcs plasma-framework
sudo pacman-mirrors -aB stable
sudo pacman -Syyu
sudo pacman -S plasma-desktop plasma-disks sddm-kcm kgamma5 systemsettings powerdevil plasma-pa ....

During my tests with the 21.0.5 Preview ISOs it seems that PoP-Shell is freezing Gnome@Chrysostomus

Currently we try to downgrade gjs to see if that helps …

When installing from the latest ISO, updating to latest stable and then changing branch to stable-staging& full update does nor trigger a freeze when using pop-shell.

Why I don’t get any updates, I did many times

sudo pacman-mirrors --fasttrack
sudo pacman -Syyu

Have you done:
sudo pacman-mirrors --api --set-branch stable-staging ?
Also: Your mirror might be behind.

1 Like

Thanks that worked :slight_smile:

1 Like

This is not an announcement for the Stable branch, this is for the Stable STAGING branch. This branch should only be used for testing. Just saying it because it seems your are oblivious to that fact.

mhwd-nvidia 465.27-1 is from/in the AUR ?
It looks like “core”. Just wondering …

After this update, I see graphical glitches in KDE. Right-clicking on a file on the desktop causes the context-menu to appear shifted to the left by quite a large amount. Also, in the KDE settings and some other places there are graphical glitches, with text disappearing or becoming highly distorted before reappearing again.

They are the same issues seen by this user of Reddit: https://www.reddit.com/r/archlinux/comments/n6wdno/if_anyone_can_help_i_will_be_gratefull/

He even posted a video: https://www.youtube.com/watch?v=6EyhsrycUaM

https://bugs.kde.org/show_bug.cgi?id=436732

I have reverted back to stable, but I worry when the update comes that these issues will persist.
Perhaps it only affects people with AMD R9 graphics cards. Does anyone know a workaround to these issues?

It only happens on first start-up of Gnome. Since you already use Gnome you won’t have that issue. However everyone who wants to try Manjaro Gnome the first time might have it.

Thx for the feedback. Currently all our staff is testing Gnome, when done we might switch to KDE Plasma to see what issues are there. Also this seems to be a dual-monitor issue …

1 Like

Any ETA when Gnome 40 will reach stable?

@Yiannis128: Chrysostomus told Gnome 40 was targeted for the next release (21.0.5 or 22.x ?). As I see the previewing 21.0.5 version is still with Gnome shell 3.38. :thinking:

@philm, using nvidia 460.80 leads to the very same KERNEL NULL POINTER DEREFERENCE described here:

it seems that the bug was “propagated” to the “production-ready” branch - which, hopefully, will upset someone important and eventually suggest nvidia to finally fix it.

Please do not move nvidia 460.80 to stable.

Maybe you want to report that to Nvidia. Seems there is an internal issue already for that: 3302807
Also it seems to be affected by some 4k Monitors connected via Display-Port.

Known broken Monitors are:

  • BenQ SW271 4K monitor
  • Dell 2418D (1440p) over display port
  • DELL P2415Q
  • Dell Alienware AW2518HF
  • Acer RC271U
  • iiyama gb2730qsu (DP, 1440p, freesync)
  • Acer v247y
  • Dell U3419W
  • Dell Alienware AW2518H

Reported cards are:

  • NVIDIA 2060 SUPER
  • RTX 2060
  • Quadro P5000
  • NVIDIA GeForce GTX 1080 Ti
  • GTX 1070ti

Simply put: don’t use Nvidia Hardware on Display Port for now …

There is also a problem with systemd ( cryptenroll --recovery-key crashes · Issue #19203 · systemd/systemd · GitHub ), ive just stubmled over it and found that bugreport

So in other words you’re not able to decrypt your harddrive with systemd 248 series …