[Stable-Staging Update] 2021-04-05 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

Hello community,

Another stable staging branch update with some usual updates for you.


We joined up with Pine64 to close the digital gap. Find out more on their blog

  • We updated Gnome Apps to 40. Shell and extensions are kept at 3.38 series.
  • Systemd is now at 247.6
  • Most of our Kernels got updated
  • We updated pipewire, Wine and AMDVLK
  • Mesa is now at 21.0.1
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from SourceForge.


Our current supported kernels

  • linux44 4.4.263
  • linux49 4.9.263
  • linux414 4.14.227
  • linux419 4.19.183
  • linux54 5.4.108
  • linux59 5.9.16 [EOL]
  • linux510 5.10.26
  • linux511 5.11.10
  • linux512 5.12-rc5
  • linux54-rt 5.4.106_rt54
  • linux59-rt 5.9.1_rt19

Packages Changes (Tue Mar 30 10:30:35 CEST 2021)

  • testing community x86_64: 1434 new and 1415 removed package(s)
  • testing core x86_64: 49 new and 49 removed package(s)
  • testing extra x86_64: 577 new and 738 removed package(s)
  • testing kde-unstable x86_64: 237 new and 236 removed package(s)
  • testing multilib x86_64: 37 new and 37 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

Known issues and solutions

  • For TL3s and up: This is a wiki post; please edit as necessary.
  • Please, consider subscribing to the Stable Staging Updates Announcements RSS feed
  • Please,, please, please don’t comment “Everything is fine with my upgrade” but use the voting buttons instead and leave the replies for actual solutions. (Pretty please with :unicorn: :unicorn: :unicorn: and :rainbow: :rainbow: :rainbow: )

New issues:

  • If you need dual-boot you can reactivate os-prober the easiest with the following command combination in a terminal:

echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

  • Apache error:  httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server

    Please click the ► at the beginning of this line to view this solution

    Full error message:

    MMM DD HH:MM:SS ServerName httpd[45914]: httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server: /etc/httpd/modules/libphp7.so: cannot open shared object file: No such file or directory
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Control process exited, code=exited, status=1/FAILURE
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Failed with result ‘exit-code’.‘exit-code’.
    
    • Execute:

      sudo nano --backup  /etc/httpd/httpd.conf
      
    • change the following lines:

      LoadModule php7_module modules/libphp7.so
      Include conf/extra/php7_module.conf
      

      to:

      LoadModule php_module modules/libphp.so
      Include conf/extra/php_module.conf
      

      Respectively! (They are not necessarily next to one another!)

    • Save (Ctrl+X Enter Y)

    • Restart Apache (or reboot if you don’t know how or to to get that Window$ feeling again)

  • Pulseeffects stopped working

    Please click the ► at the beginning of this line to view this solution

    Execute:

    pamac install manjaro-pipewire
    pamac install gst-plugin-pipewire
    

    OR

    pamac install pulseeffects-legacy
    

    pulseeffects-legacy does not depend on Pipewire and does not require removal of PulseAudio packages

  • gnome-shell-extension-desktop-icons  cannot be updated

    "Please click the ► at the beginning of this line to view this solution
    error: failed to commit transaction (conflicting files)
    gnome-shell-extension-desktop-icons: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/schemas/gschemas.compiled exists in filesystem
    Errors occurred, no packages were upgraded.
    

    please run the following command:

    sudo pacman -S gnome-shell-extension-desktop-icons --overwrite /usr/share/gnome-shell/extensions/\*
    

    and the issue will be resolved.

  • I’m still running on nvidia-450 and I want to recompile the 450 driver (Kernel 5.4 LTS):

    Please click the ► at the beginning of this line to view this solution
    1. Add the line IgnorePkg = lib32-nvidia-utils lib32-opencl-nvidia mhwd-nvidia opencl-nvidia in file /etc/pacman.conf

    2. Upgrade your packages (using the pamac GUI) or:

      pamac upgrade
      
    3. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    4. Boot will be stuck because no driver has been found, just open a console with Ctrl+Alt+F2

    5. First read Note 2 below, then get the sources for your driver (in my case, 450xx):

      git clone https://gitlab.manjaro.org/packages/extra/nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-450xx.git
      
    6. Compile the driver (if you get an error, see Note 3):

      cd nvidia-450xx-utils && makepkg -si
      cd ../lib32-nvidia-450xx-utils && makepkg -si
      cd ../nvidia-450xx && makepkg -sif
      
    7. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    Now, everything is working again! To check if you’re indeed running kernel Linux 5.4, you can run uname --kernel-release in a console, and to check if you’re running the driver you just compiled, you can run inxi --graphics --display OR nvidia-smi

    Note 1: to choose which kernel to boot on, you need to edit those two lines in /etc/default/grub to match those (5 as in 5 seconds to make your choice on the menu, you can put whatever):

      GRUB_TIMEOUT=5
      GRUB_TIMEOUT_STYLE=menu
    

    Then, run sudo update-grub. When booting, you’ll now see a menu with all installed kernels so you can choose which one to use for this session.

    Then finally execute the reboot command:

      sudo reboot 
    

    Note 2: During step 5 and 6: If you already have compiled the nvidia driver during last update, you can skip cloning nvidia-450xx-utils and lib32-nvidia-450xx-utils (you already have the sources, you just need to compile them again), but I suggest you remove your older nvidia-450xx folder (rm -rf nvidia-450xx) and clone it again before compiling this one, otherwise you will get an error like “folder already exists” when trying to compile.

    Note 3: When trying to compile the driver, you might get an error with two nvidia packages creating conflicts (I think lib32-nvidia-utils was one of them, I don’t remember the other one). To fix that, just uninstall those packages with pamac remove <package>.

  • I’m still running on nvidia-450 and I want to upgrade to 460 (Kernel 5.10):

    Please click the ► at the beginning of this line to view this solution
    • Print this page so you have it as a reference while in TTY2

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      pamac remove nvidia-450xx-utils
      #you will get some warnings about optional components needing this: 
      #  no worries, you'll install 460 in the next line
      sudo mhwd --install pci video-nvidia
      sudo reboot
      

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/

Moving to Zstandard images by default on mkinitcpio

Moving to Zstandard images by default on mkinitcpio

2021-02-19 - Giancarlo Razzolini

As linux-lts moved to the 5.10 version, all official kernels of Arch Linux now support zstd compressed initramfs images, so mkinitcpio is switching to zstd compressed images by default with version 30, which is currently on [testing].

If, for any reason, you are using a kernel version prior to 5.9, make sure to change mkinitcpio.conf COMPRESSION to use one of the compressors supported, like gzip, otherwise you will not be able to boot images generated by mkinitcpio.

https://archlinux.org/news/moving-to-zstandard-images-by-default-on-mkinitcpio/


Older Issues

Please click the ► at the beginning of this line to view the older issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

xf86-video-intel already exists in filesystem errors

Please click the ► at the beginning of this line to view this solution

If you get something like this:

error: failed to commit transaction (conflicting files)
xf86-video-intel: /usr/bin/intel-virtual-output exists in filesystem
xf86-video-intel: /usr/lib/libI810XvMC.so exists in filesystem
...
xf86-video-intel: /usr/share/man/man4/intel.4.gz exists in filesystem
xf86-video-intel: /usr/share/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy exists in filesystem
Errors occurred, no packages were upgraded.

Just delete the files that are in conflictand perform the upgrade again.

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

3 Likes

Latest ISOs

With this update we also prepared ISOs for Ornara 21.0.1 for review.

https://sourceforge.net/projects/manjarotest/files/xfce/21.0.1-rc1/
https://sourceforge.net/projects/manjarotest/files/gnome/21.0.1-rc1/
https://sourceforge.net/projects/manjarotest/files/kde/21.0.1-rc1/

3 Likes

I have this when updating in stable-staging:

 :: Iniciando atualização completa do sistema...
 :: Substituir hunspell-en_US por extra/hunspell-en_us? [S/n] s
 :: Substituir python-dbus por extra/dbus-python? [S/n] s
 :: Substituir python-dbus-common por extra/dbus-python? [S/n] s
 resolvendo dependências...
 procurando pacotes conflitantes...
 :: dbus-python e python2-dbus estão em conflito. Remover python2-dbus? [s/N] s
  • not a problem, just in case somebody need to know how to deal with this. Or maybe I am wrong?
1 Like

Do exactly that. However, you may need to manually remove whatever depends on python2-dbus first.

2 Likes

I had an issue with pipewire/bluetooth audio after this update.

pipewire (and pipewire-pulse, etc.) were updated to 1:0.3.24-1. After this, I was no longer able to connect to my bluetooth headset.

I was seeing:

a2dp-sink profile connect failed for XX:XX:XX:XX:XX:XX : Protocol not available

Downgrading pipewire back to 1:0.3.23-1 fixed this issue.

2 Likes

But, if I will uninstall python2-dbus, pacman will notify me if there are dependencies.

This update is now available on stable branch but did not have official announcement yet but after updating mirrors and system, I found audio not working with pipewire update to v0.3.24 after reboot.

Here are logs from pipewire on reboot in reverse order of time(recent first):

systemd[1076]: Failed to start Multimedia Service Session Manager.
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
systemd[1076]: pipewire-media-session.service: Start request repeated too quickly.
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
pipewire-media-session[1399]: can't start monitor: Operation not supported
pipewire-media-session[1399]: core 0x5598ead5f6f0: can't find protocol 'PipeWire:Protocol:Native': Operation not supported
blueman-mechani[1390]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
pipewire-media-session[1298]: can't start monitor: Operation not supported
pipewire-media-session[1298]: core 0x5580e0d3e6f0: can't find protocol 'PipeWire:Protocol:Native': Operation not supported
kernel: nvidia-modeset: WARNING: GPU:0: BOE Technology Group Co., Ltd (DP-2): G-SYNC Compatible: EDID min refresh rate invalid, disabling G-SYNC 
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
pipewire-media-session[1235]: can't start monitor: Operation not supported
pipewire-media-session[1235]: core 0x55b04f4cb6f0: can't find protocol 'PipeWire:Protocol:Native': Operation not supported
tumblerd[1212]: Failed to load plugin "tumbler-gepub-thumbnailer.so": libgepub-0.6.so.0: cannot open shared object file: No such file or directory
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
pipewire-media-session[1194]: can't start monitor: Operation not supported
pipewire-media-session[1194]: core 0x5558d21ee6f0: can't find protocol 'PipeWire:Protocol:Native': Operation not supported
systemd[1076]: pipewire-media-session.service: Failed with result 'exit-code'.
pipewire-media-session[1162]: can't start monitor: Operation not supported
pipewire-media-session[1162]: core 0x55cd2c9f76f0: can't find protocol 'PipeWire:Protocol:Native': Operation not supported

Here is my system config:

System:
	Kernel: 5.11.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
	Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 wm: xfwm4 dm: LightDM 
	Distro: Manjaro Linux base: Arch Linux

Audio:
	Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
	v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348 
	Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo 
	driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 
	Sound Server-1: ALSA v: k5.11.10-1-MANJARO running: yes 
	Sound Server-2: JACK v: 0.125.0 running: no 
	Sound Server-3: PulseAudio v: 14.2 running: no 
	Sound Server-4: PipeWire v: 0.3.24 running: yes

After downgrading pipewire to v0.3.23 audio started working again.

1 Like

I am getting these updates in todays update, but I never asked for installing from staging repo!?!?!
In the stable update announcements there is no word of these updates at all… What’s up?

im getting too

Also tried manually building and installing pipewire packages v0.3.25 which are in unstable branch right now hoping for fix but still the audio is not working. Same error logs as above.

Relax it’s because the announcement somehow drops a while later. You can check what branch you are on with pacman-mirrors --get-branch if you want to make sure.

1 Like

Is there an ETA on when the Gnome 40 shell will reach the stable branch?

Well this sequence is kind of in conflict with the general advice of reading release notes before installing updates… There is nothing to read in this case… Should I cancel the update?

There are some showstoppers with the manjaro default extensions, for example dash to dock and dash to panel. My guess would be that gnome-shell will be delayed until those extensions are ported to gnome 40 and more stable, but I don’t know.

1 Like

Yeah it’s far from ideal. If you are already installing the update I would let it finish if not just wait for the announcement to see if there are any known issues.

Since the update one hour ago my audio doesn’t work anymore. Besides the desktop background picture is gone and the desktop is only white. And my network is awfully slow.

Since I’m making music with my computer this is a minor catastrophy and I want to undo the last update. Is there a simple solution or should I use my timeshift backup from last week?

Right now I’m doing “pamac install manjaro-pipewire” but the download is soo slow (~40kb/s) that I thought I use the time to file this report. :crazy_face:

~ >>> inxi -Fxz                                                                
System:
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: GNOME 3.38.4 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Acer product: Aspire A515-51 v: V1.15 
  serial: <filter> 
  Mobo: KBL model: Charmander_KL v: V1.15 serial: <filter> UEFI: Insyde 
  v: 1.15 date: 01/08/2018 
Battery:
  ID-1: BAT1 charge: 41.4 Wh (100.0%) condition: 41.4/48.9 Wh (84.5%) 
  volts: 16.9 min: 15.2 model: COMPAL PABAS0241231 status: Unknown 
CPU:
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check rev: A cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 703 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 703 2: 754 
  3: 726 4: 700 5: 700 6: 700 7: 700 8: 717 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus-ID: 00:02.0 
  Device-2: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:4 
  Display: wayland server: X.org 1.20.10 compositor: gnome-shell driver: 
  loaded: intel unloaded: modesetting resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.1 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.17 running: no 
  Sound Server-4: PulseAudio v: 14.2 running: no 
  Sound Server-5: PipeWire v: 0.3.24 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 01:00.1 
  IF: enp1s0f1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus-ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB 
  driver: btusb v: 0.8 bus-ID: 1-5:3 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:
  Local Storage: total: 238.47 GiB used: 162.16 GiB (68.0%) 
  ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
Partition:
  ID-1: / size: 224.77 GiB used: 162.16 GiB (72.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 230 Uptime: 29m Memory: 7.65 GiB used: 3.35 GiB (43.7%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1633 Shell: Zsh v: 5.8 
  inxi: 3.3.03

No audio device found after pipewire was updated to 1:0.3.24-1.

This helps me:
sudo cp /etc/pipewire/media-session.d/media-session.conf.pacnew /etc/pipewire/media-session.d/media-session.conf

And i also copying this:
sudo cp /etc/pipewire/media-session.d/alsa-monitor.conf.pacnew /etc/pipewire/media-session.d/alsa-monitor.conf

17 Likes

That was helpful, indeed. Thanks @polilla !

That was useful, thank you :nerd_face:

I was very frustrated to lost my sound because I have lot of input/output issue since the switch from ALSA so I didn´t expected it could be worse… Hope it´ll be better soon :smiley:
So very happy to be able to listen music again !