[Stable Staging Update] 2020-08-11 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

Hello community,

Another stable-staging branch update with some interesting updates for you!

Get the second alpha of our Phosh edition! #stayhome, #staysafe, #stayhealthy

  • We updated grub to fix the boot hole issue. Please test, so we can forward it to stable fast.
  • All of our Kernels got updated
  • Plasma is now at 5.19.4
  • Frameworks is now at 5.73.0
  • Firefox 79.0 comes with new features
  • Most of the ukui packages got updated to 3.0
  • Mesa is now at 20.1.5
  • A new AMDVLK release
  • Usual Python and Haskell package updates and rebuilds
  • Some Browsers got updated
  • Systemd is at 246.1. See also News
  • Updated Linux-Firmware
  • Pamac adds more support to AUR
  • Virtualbox is 6.1.12
  • Nextcloud got its first point-release to its 19 series
  • Riot is renamed to Element
  • More updates to Xorg-Fonts
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest RC of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Security Updates

Xorg-Server 1.20.8-4

Fixes CVE-2020-14347. No manual user intervention needed. Just update regularly.

Avoid leaking un-initalized memory to clients by zeroing the whole pixmap on initial allocation.
This vulnerability was discovered by: Jan-Niklas Sohn working with Trend Micro Zero Day Initiative

Grub 2.04-11.1

Fixes Boot-Hole issue.
You need to re-install grub on your system to complete the security fix: Bios-MBR, UEFI Systems

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.232
  • linux49 4.9.232
  • linux414 4.14.193
  • linux419 4.19.138
  • linux54 5.4.57
  • linux57 5.7.14
  • linux58 5.8.0
  • linux54-rt 5.4.52_rt31
  • linux56-rt 5.6.17_rt9

Package Changes (Tue Aug 11 13:56:54 CEST 2020)

  • stable-staging community x86_64: 1269 new and 1241 removed package(s)
  • stable-staging core x86_64: 19 new and 19 removed package(s)
  • stable-staging extra x86_64: 315 new and 307 removed package(s)
  • stable-staging multilib x86_64: 21 new and 21 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable-Staging Updates Announcements RSS feed

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at “Preparing…”

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at “Preparing…” without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in “Preparing…”, you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.


khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below…



… have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON’T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac



the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

A post was split to a new topic: How do I set time manually

Updated when it came out, update works great here on two KDE machines.

However, I wasn’t able to test the Nvidia hardware video encoder yet. (Last time it was broken with newest ffmpeg.) Still waiting for the Nvidia v450 driver to fix this (and other incompatibilities).


No problem here in XFCE. Everything went smoothly

I wonder if Libreoffice-fresh 7 could be push on stable-staging branch. Thank you.


It is not available on Archlinux stable repository. So, you won’t have it.

1 Like