[Stable Release] Manjaro Openbox 18.0

openbox

#1

Openbox 18.0 stable ISO kernel 4.19

Download from OSDN

direct | sig | sha1 | sha256 | torrent

Download from OSDN (minimal)

direct | sig | sha1 | sha256 | torrent


If I Can't Ask Questions On a Topic Why Would I Trust It?
PacUI: Bash script providing advanced Pacman and Yay/Pikaur/Aurman/Pakku/Trizen/Pacaur functionality in a simple UI
Ways to swap themes of programs? [Openbox Build]
PacUI: Bash script providing advanced Pacman and Yay/Pikaur/Aurman/Pakku/Trizen/Pacaur functionality in a simple UI
#2

Where can I download that sweet wallpaper?


#3

Oh… that’s sexy…

Is the OpenBox 18.0 profile now part of Manjaro Architect? Minimal & Full?


#4

It can be installed from repo

pamac install manjaro-wallpapers-by-lunix-cool-logo

Not yet - but it will and minimal is very minimal - besides the desktop theming and the needed theming apps, there is only thunar and chromium and some disk tools available.


#6

I installed it but it’s not showing up in /usr/share/wallpapers. Is it located somewhere else? I’m using KDE.


#7

It resides in /usr/share/backgrounds/lunix/cool-logo

Power tip: Open the Add/Remove Software app (Pamac) and locate the package - Double click the package and look in the Files section to find where the files are installed to.


#8

Thanks!


#9

It is a nice logo. What is the default kernel version for this stable version?


#10

Linux 4.19


#11

Sounds just like what I’m looking for :slight_smile:

Btw, how do you change the default programs in this openbox spin? Is there is a GUI way and a text file edit way and/or other ways?


#12

It isn’t showing up in the Community Editions page.


#13

PreferencesSystemSettings ManagerPreferred Applications

It will as some point - just use the links in OP.


#15

Openbox Minimal

I noticed that this Openbox build doesn’t show the battery level of laptops automatically.

Attempting to add this to polybar, I tried adding this line into modules.conf, but it doesn’t seem to be working:

include-file = $HOME/.config/polybar/modules/battery.conf

I currently have my tint2 to see my battery level until I can get polybar working.

Edit: I was able to get this working… I am dumb and forgot to edit one of the .conf files to show it.


Also… I noticed that hitting the volume icon only mutes and unmutes it. Is alsamixer the only way (with the current packages) to change the volume of the computer?

I tried using my volume button on my keyboard, but I get “Failed to execute child process “pamixer” (No such file or directory)”. I installed pamixer and those buttons started to work again. I assume it wasn’t included since I’m on the minimal install.


Currently, pressing “[Super] + m”, it pops up “Failed to execute child process “deadbeef” (No such file or directory)”. Maybe instead, it should pop up a “select default” GUI. Because if I currently install anything other than “deadbeef”, I have to go PreferencesSystemSettings ManagerPreferred Applications to set it up.


#16

I must admit - I am not using all modules my self - they are inherited from ArchLabs - so some of them will require manual intervention.

Even the volume section can require manual intervention as I have not found a one-size-fits-all solution.

I have included link in the Help and Info section of the Openbox root menu to polybar wiki.


#17

When you use the minimal and the install the apps of preference, there will be some extra work in adjusting the shortcuts to your prefs.

There is no default application selection for a music player, so you have to edit the rc.xml file and replace deadbeef with the music player of choice.

You can edit the rc.xml either by opening it from the Openbox section in Preferences (text editor) or by using the GUI keybind editor.


#18


I get this error sometimes when I use the meta/super key and JG menu won’t open. It seems to start happening when I click the meta key 2+ times too fast, and it doesn’t work until I log out then back in.


Sometimes when I turn on my computer, this happens:

And once I log in, it is that same ratio, but then it “fixes” itself after a few seconds to:

I have to log out then back in to fix it. I thought it might be an issue due to using LUKS somehow… but it happens on ext4 too.

~ >>> inxi -Fxz                                                                 
System:
  Host: rmlap Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP EliteBook 820 G3 v: N/A 
  serial: <filter> 
  Mobo: HP model: 807C v: KBC Version 85.77 serial: <filter> UEFI: HP 
  v: N75 Ver. 01.33 date: 07/17/2018 
Battery:
  ID-1: BAT0 charge: 37.4 Wh condition: 44.5/44.5 Wh (100%) 
  model: Hewlett-Packard Primary status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i7-6600U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22472 
  Speed: 783 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 510 2: 510 
  3: 511 4: 506 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.5 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 12.85 GiB (5.4%) 
  ID-1: /dev/sda vendor: Intel model: SSDSCKKF256G8H size: 238.47 GiB 
Partition:
  ID-1: / size: 233.63 GiB used: 12.85 GiB (5.5%) fs: ext4 dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 163 Uptime: 1h 48m Memory: 15.55 GiB used: 1.32 GiB (8.5%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: zsh v: 5.6.2 inxi: 3.0.27 

#19

This is known to happen - I don’t know. The message you see is from xfce. This happens because xfce sometimes takes over the hotkeys. I have no idea why.

I have changed some of xfce’s keymappings to match Openbox keymappings to work around this issue.

If you are keeping your system up-to-date you should have a the keyboard shortcuts definition in your skel folder. Copy the file to the same location in your .config folder

 /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

The monitor issue I have seen once but after a reboot it dissappeared and I have not seen it since.

Does it happen often?

My initial guess is a driver issue but I really don’t know and I am as stunned as you are.


#20

This happens across editions, configurations in the (/home/username/) that don’t get updated, I wonder if a symlink to /etc/skel would be a good practice, it would surely solve that issue.


#21

That is due to the fact that updates only afflicts on /etc/skel - any user need so forcibly apply any changes to the settings.


#22

I know that, What i am asking is, doing this at iso level would it be a bad practice, since the user could always replace the symlinks to its own custom files, that would guarantee configurantion files to be always updated.

symlink /home/username/.bashrc to /etc/skel/.bashrc and so on.