SSL Error 4 with Citrix Receiver

Hi there

Thanks for this beautiful Linux Distribution. I’m running it on a Macbook Air 2013 since beginning of the year.

For remote work I’m using Citrix Receiver to access the company VDI. This has worked well for several week. Since about 3 weeks, I get a SSL Error (No 4), that means somethings with the ssl certicates is not correct.

Has somebody also this errors?


Without the actual error message there’s not much to go on.

However, from experience with horribly outdated company requirements, I believe it’s a case for your IT department to update their certificates.

Hi and welcome!

I’ve used the icaclient from the AUR a year ago but don’t use it anymore. I suspect you use the same client. When setting it up I remember having to do some copy and / or linking of directories to get the client to use/see the right certificates. (This might be solved in the PKGBUILD)

If you have not updated in a while that could be a cause of the issue.


Hi thank you for your reply.

The Error Message is:

Please send the following information to the helpdesk:
A network error occurs (SSL-Error 4).

thank for the hint.

I wonder that the ICA Client is working several times normally and now no more.