SSL Configuration completely broke down and i don't know what happened no HTTPS requests possible anymore

I just wanted to install poetry for python

❯ curl -sSL | python -
curl: (77) error setting certificate verify locations:  CAfile: /home/user/.cache/yay/anaconda/pkg/anaconda/opt/anaconda/ssl/cacert.pem CApath: none

But for some reason curl started to use a weird anaconda path and i literally don’t know why it does that, but sadly it is not only curl because the corresponding python script also isn’t able to verify the certificates anymore.

I tried reinstalling certificates multiple times. Tried desperately searching with rip grep for the path if it is in some random config file of something.

But nothing worked so far and i am slowly going insane. Because it happens for every single https connection i try to establish over the terminal.

❯ curl -sSL --insecure | python -

i can run it like this or create a .curlrc where i set it to the normal certificates file but then it soon goes to

  File "/opt/anaconda/lib/python3.11/urllib/", line 1351, in do_open
    raise URLError(err)
urllib.error.URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1002)>

I don’t understand enough about the ssl structure in arch to know what is going on here and why it suddenly tries to access this completely non existent certificate which i never even used in the first place and why would it even be in the yay cache, that makes even less sense.

So yeah if fsomeone has any idea on what i should do or where i should look for this i would be very happy because not being able to use curl or in general https requests in something other than my browser is kind of not good.


❯ sudo find / -maxdepth 4 -xdev -type f -print0 | sudo xargs -r -0 rg "/home/user/.cache/yay/anaconda/pkg/anaconda/opt/anaconda/ssl/cacert.pem"
/opt/anaconda/lib/ binary file matches (found "\0" byte around offset 7)

I tried this one but this seems kind of weird

Well … thats probably good … because you probably dont actually want to install that way.
python-poetry exists in the repos.

Indeed i know that already but funnily enough the version in the repo broke down after the last update so i tried to uninstall it and here we are.

And for someone who doesn’t know

❯ poetry
poetry may be found in the following packages:
  extra/python-poetry 1.5.1-1   /usr/bin/poetry

i think it might not be hard to find for anyone

What do you mean ‘broke down’ ?

Indeed your certs error may be a problem in and of itself … but still the repo package should be preferred.

Have you installed lots of software this kind of way too ?