Sshfs share sometimes not mounted


I have a raspberry pi “server” (debian) and a manjaro client. I want to mount a folder from the pi which permanently runs, on the manjaro client.

The following entry is added to manjaro fstab:

user@pi-IP:/shared/ /home/user/Shared fuse.sshfs noauto,x-systemd.automount,defaults,_netdev,allow_other,gid=1001,uid=1000 0 0

most of the times the mount succeeds flawlessly. Every now and then the folder is not mounted and remains empty. Executing sudo mount -a fixes the problem but it’s annoying.

I also tried mount option “auto”, deleting “noauto,x-systemd.automount”

Any ideas what could be the problem? Or better how to debug this…I’m not aware of a log file logging mount failures!?


sshfs requires network to be up and connected - which may lead to unmountable shares it not handled correctly.

Begin with this topic and continue with the examples found there

1 Like

Thanks …however, the tutorial states: " fstab is the preferred approach" and I’d like to stick with this since it worked for more than a year and started crashing a few weeks ago.