Ssh+svn password. How to set up ksshaspass?


I must access a remote SVN server through SSH with password. So I set up the following config line in ~/.subversion/config:

ssh = ssh -l username

And it works not fine but ok. Whenever I use svn through cli on thesvn+ssh://server repository, it asks for password for user “username@server” or something like that.

It doesn’t work for Dolphin Subversion extension, though, and I get to enter the password every single time on cli. I get the following response:

ssh_askpass: exec(/usr/lib/ssh/ssh-askpass): No such file or directory 
Permission denied, please try again. 
username@server: Permission denied (publickey,password). 
svn: E170013: Unable to connect to a repository at URL 'svn+ssh://server/repo'

I’m not finding any clear way of configuring SSH to use ksshaspass instead of the non-existant /usr/lib/ssh/ssh-askpass. Setting SSH_ASKPASS env didn’t produce any effect.

Any pointers?