SSH agent on Manjaro KDE missing causing issues with VSCode

kde
#1

Hi,

I do web development using VSCode. I was using the Solus Budgie distro before switching to Manjaro KDE, and there whenever git needed my SSH key it would graphically prompt for a password and then allow me to remember that forever by keeping it in Seahorse I guess?

On Manjaro KDE none of this works. I have to enter my passphrase every time I want to use the SSH key for anything and it does not work at all in VSCode, saying that authentication has been denied?

My question is: what's the best way to set this all up, and why is it not done out of the box like on Solus?

My goal is being able to press the sync button in VScode and have it perform pull and push git operations, asking for the password of the key graphically unless provided before. This is how it works out of the box on Solus Budgie.

I looked at similar issues and the arch wiki but was not able to set up KWallet to keep the SSH keys and bash sessions to use it

0 Likes

#2

You can make use of ksshaskpass from terminal and set it to use KWallet. Then you set the Access Control in Wallet Manager > Settings.

0 Likes

#3

I have SSH_ASKPASS set to the path to ksshaskpass

When I use git from the command line I get: Enter passphrase for key '/home/fazo/.ssh/id_rsa':

When I use git from VSCode I get this:

Screenshot_20190417_124014

I installed keychain as a SSH Agent and now from the command line it at least remembers the passwords and asks them through ksshaskpass otherwise.

However I have the same problem with VSCode

0 Likes

#4

Not very knowledgeable about all this, but did you update your credential manager?
Do you get the same error on the command line?

0 Likes

#5

It all works on the command line now, but not in VSCode.

I googled the problem and I also found the credential manager stuff, but according to here https://wiki.archlinux.org/index.php/Git#Speeding_up_authentication git should use the SSH Agent when used with SSH repos (like mine).

It works, git uses the ssh agent, but only in the command line, not in VSCode

0 Likes