Spotify Won't Read Music On Secondary Drive

I have Manjaro installed on a 500GB SSD but have all my data on a 4TB HDD. I have created symbolic links in my $HOME directory linking to folders on the HDD.

I am trying to import my Music folder contents to Spotify. When I try to enter the path “/run/media/username/drivename/foldername/Music” I get an error, “Error when getting information for file “/run/media/username/drivename/foldername”: No such file or directory”

When I click on File System and select the run directory, it only displays the following folders: flatpak, host, systemd, user.

I haven’t had to “hack” config files and permissions in ages, so I’m a bit rusty. Any help would be appreciated.


Could the folders be hidden? Try unhiding the folders in dolphin and see it this helps.

Maybe this will help,

Do you have package ffmpeg-compat-57 installed? This is needed for spotify to read local mp3 files.

Did you install via flatpak or snap or some such? Applications installed as containers need special permissions to access the local drive.

How about this? How to install Spotify on Manjaro 18 Linux - I’ve used this strategy on two manjaro 20 instances and have no problems with access.

1 Like

Yes, it was a snap install.

The method you linked worked perfectly! I had to import the gpg key to get makepkg to work, but I now have Spotify working and reading compatible local files.

Problem: SOLVED!

Thank you SO much!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.