Split_help_question. Firefox has no spellcheck/resolution messed up

i really dont know what to do, Firefox has no spellcheck and its resolution is messed up


i was last one to post here^
i dont know how to get the direct link to my post…sorry. only reason 2nd pic resolution is ok is cause the CSS i use for that site fixes it

please help :sob:

For spell check you need to add the add-on language pack for Firefox from the preferneces addons.
Or can intsall it via pamac. You need aspell and the right Firefox language pack and then logout and back in and start up firefox.

Wow, 60C on your cpu seems a little hot. Mine stays @ 40C or so.

Also, I am not seeing the resolution problem. Looks fine to me.

1 Like

ok. thank you. yeah my sys runs hot, when i did that i was just listening to music. im getting a cooling pad when i have spare cash. well in the pic of google you see the scroll bar at bottum and page is at 100%. i dont know if this helps but im on hdmi with labtop screen off, oh and pacman goes outside of the screen and it will not let me fit it to screen. ask me anything and i shall answer asap. i just remember one day i booted it up and the res or dpi is all messed up

1 Like

Oh OK I see now, have you tried the display settings in your Desktop? Otherwise I am not the person to answer that question. :grin:

1 Like

well i switched my resolution to 800x600 cause its easer to see stuff. im guessing thats the problem? somethings dont want to be forced to 800x600
i didnt think about it till you said something… i have sometimers disease,lol

that fixed it, ill just go to dpi settings i guess to try to fix everything being small. thanks :vulcan_salute:

1 Like


at the top of screen, how do i make that stuff bigger? thats my only problem other than sound icon but that was solved for me, just havent fixed it yet. you see my green temp bars,lol, almost 70c

nevermind issue solved. i mess arround with a lot of stuff cause i was tring to fix stonesoup resolution a different way than what was recomended. well i had fun. i love tinkering with linux

doing that fixed spell check…for google but dont work here or anywhere else on the web…weird. i can only find spellcheck for RU in pacman

What?
Please update your system with sudo pacman -Syyu
And then install aspell sudo pacman -S aspell
Then sudo pacman -S aspell-en
Log out and back in and restart firefox, and in preference turn on spell check as you type.
It works.

Well if that does not work then I am confused and it could be something wrong. :face_with_raised_eyebrow: :grin:

1 Like

https://addons.mozilla.org/en/firefox/language-tools/

1 Like

oh, yeah i saw that,lol. i just didnt know what that was. im up todate every day :sunglasses: ill get that. thanks

i got lang eng/us in addons. im just used to all this pre-installed :exploding_head:

i pm mod but if i give this person solved issue can i give it to someone else too? i didnt think about this till now…

spellcheck works, didnt use the pacman install, just the addon im sure they both work. but i choose firefox addon solution just cause im using firefox and addon is from firefox. thanks guys
yeah

I’m sorry for this mess of a thread but I know there was an update browser-settings not sure if this did it or cause I switched back to default resolution but now that bottom scroll bar won’t show up anymore…my problem was just the resolution of the web page I was viewing… Its fixed but now there is no bottom scroll bar.

Try to change zoom, Ctrl+Scroll up/down

If anyone here (or stumbling here later) wants a way to set firefox resolution/DPI/PPI - there is a way.
Point browser to
about:config
Find string
layout.css.devPixelsPerPx
And set prefered value (with 1 = 100%). On an 11 inch with HD screen, I had to set 1.2 as the text was too small for the user. In the reverse situation try something like 0.6 .

1 Like

In Firefox preferences -> language you can switch “Check your spelling as you type” on.