Splash screen hang after self user switching in KDE

I’ve just started in using manjaro a few days ago, I use to interact alot with other distros on virtual machines and vps for a long time so I do know some basics. And I’m not “testing”, I just eventually meet the problems when my brother switch user.

Yes, well, what you did still doesn’t make any sense: choosing to switch user in order to log in again as the same user.

So, again, you could file a bug with the KDE developers upstream, but I doubt whether they’ll take it seriously. :man_shrugging:

1 Like

similar issue

1 Like

So I guess I’ll just have to not mind it and just wait until the bug is patched?

You could first and foremost check whether the bug has already been reported, because if it hasn’t been, then chances are that the KDE developers themselves aren’t even aware of it. However, considering that the login screen does on occasion seem to hang ─ which, mind you, is only temporary, because if you wait a bit and move the mouse a bit, then it does eventually log you in ─ I suspect that they’ll already know.

And that said, if they do indeed already know, then it’s a matter of how important they think it is. There are still bugs in Plasma now that were already in the previous release, and that they do certainly know about, but which they still haven’t bothered to fix.

Eventually, it will get fixed, but nobody can predict when that is the case. :man_shrugging:

1 Like

I could see a situation where that would make sense, for example to reload groups permission after adding/changing them, correctly apply themes, things like that. Sometimes you need to log again for things to be applied.

Yes, but then you log out and log back in, but choosing “Switch User” in order to log back in as yourself doesn’t make any sense.

Fair enough, however in my opinion, logout then switching user to the previously logged in user is basically the same as a logout then login, so this is probably a KDE bug.

I recall the KillUserProcess=yes setting in one of the system config file that was required to simply be able to log back in after a logout, long time ago, maybe there is still some kind of issue unresolved in KDE.

I use my system as single user and never logout so I don’t really know these issues.

I was unable to login after resuming from sleep. Just kept saying “Login failed.” I tried switching user to no avail. Was reading in this post and another post about a KDE bug and was going to try lightdm as a work around but decided to boot with the 5.4 kernel instead of the 5.15 to check that first and the behavior was not there.

I’ve experienced a similar/same issue. I’ve accidentally clicked switch user, but want to immediately log back into my account, the system would freezes and a hard reboot was required, but after enabling REISUB, I can avoid a hard reboot but I still need to use alt+sysrq+k to unfreeze and log back into my user.

1 Like

Well, there’s obviously something very buggy in this version of sddm, but unfortunately we’ll have to wait for the KDE developers to fix it. :man_shrugging:

1 Like

i had the same issue.
i fixed it by editing sddm config file.
edit /etc/sddm.conf

make sure ReuseSession=true


Thank you. This works.

Here I thought it was a bug but rather a “feature”. LOL.

I don’t understand why the default would be set in such a way as to leave a user hanging (I suppose it’s some kind of theoretical security issue they’re trying to prevent?). Anyway if a manjaro dev reads this, may I suggest switching this setting this to true?

I still think it’s a bug.

1 Like

I have to agree. Users should not be left in a frozen login purgatory. There should be at least an error message.

Maybe it is worth the effort searching for and reporting it if nothing matches, on the KDE bug tracker.

FWIW, I believe the devs know of this issue, on kde neon testing the default is set to: ReuseSession=true

OK then maybe the defaults will get changed in a later update.

Yup that works for me!

For someone who don’t know where ReuseSession are located:

> ReuseSession=true

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.