Spectacle segfaults after recent update

Currently Spectacle is segfaulting on launch. I’m running 24.0.1, all up to date. Running Wayland. I get this message popping up in a notification window when I press prnt scr:

Message recipient disconnected from the message bus without replying.

I see some similar issues where Plasma applications are segfaulting:

As other users suggest I’ve tried removing files in .local, .cache and .config having anything to do with “kde”, “plasma”, or “spectacle”. Uninstalled and reinstalled Spectacle. Rebooted my computer. Still get segfault on launch.

dmesg shows:

[  658.607537] Thread (pooled)[5115]: segfault at d8 ip 00007f0a5983cab4 sp 00007f0a355f7d78 error 4 in libX11.so.6.4.0[7f0a5982d000+8b000]
[  658.607543] Code: 84 00 00 00 00 00 f3 0f 1e fa 8b 47 1c c3 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 8b 47 74 c3 0f 1f 84 00 00 00 00 00 f3 0f 1e fa <48> 8b 87 d8 00 00 00 c3 0f 1f 40 00 f3 0f 1e fa 48 63 f6 48 c1 e6

I don’t see anything particularly helpful from running the app with gdb.

Any ideas how I can get screenshots working again? Unlike these other threads I linked to, other Plasma/QT apps are working fine for me, it appears to be just Spectacle that’s broken.

Update: Spectacle does work when I reboot into X11 instead of Wayland. That’s not ideal, but good to know I have a workaround.

Quite strange - as spectacle work on my systems - I am guessing the only difference is our branches.

Spectacle version 24.05.0-1 is the defacto state of spectacle also upstream.

With relation to a plasma reset - it seems you have tried everything.

The only idea left is that - if your housecleaning was done inside a plasma session - as opposed to logging off and switch to a TTY - plasma may have cached configs which is then written to disk - with the settings causing the crash.

This is pure speculation.

I would log out - switch to a TTY - login as my user - remove the ~/.cache and the spectacle related files.

  • file ~/.config/spectaclerc
  • folder ~/.local/share/spectacle

Then refresh user-space

systemctl soft-reboot

Login and retry the screenshot

testing and unstable branches is update more frequently than stable.

Looking at announce

  • stable snap at May 29.
  • testing snap at June 3.

unstable had several syncs since - latest today - but nothing that seems to be related to spectacle - plasma-workspace is the only candidate.