Spectacle not taking screenshots correctly

So I wanted to capture my screen with a terminal window and my desktop and it doesn’t capture that, instead it captures my desktop without the terminal window and with the splash screen. Has anyone witnessed something similar?

do you have the right shortcuts ?

This is not really a solution to your spectacle issue, but I use flameshot as that has a ton of features and the developer is really active when you report bugs. (and I only ever encountered one)

  • Activate the AUR

  • Execute:

    pamac install flameshot-git
  • Bind PrtSc to flameshot instead of spectacle in the KDE System Settings.


I’ve never seen such behaviour.

What screenshot option did you choose? “Full Screen”?
Try “Rectangular Region” and expand the region manually.

1 Like

I tried Flameshot too but it has the same issues, which makes me think this is a bug in my display rather than their applications. In OBS too, only window capture works. Display capture flickers weirdly.

And selecting rectangular region doesn’t fix things either.

I’ll try reporting a bug at Flameshot’s Github, but it seems like there is currently no way for me to take a screenshot.

Wait, something suddenly just worked haha. I deleted Zoom and somehow now all the screenshot utilities are working, which is weird because Zoom isn’t related to any screenshot utility at all.

1 Like

Did you use a snap or flatpack for zoom?


I used the AUR

Are snaps and flatpaks known to give issues?

me too and I don’t have this weird problem. The poutput to pamac list | grep zoom on my system is:

zoom                               5.7.1-1                                  AUR        203.2 MB

Please read this:

More specifically this bit:

Snaps and flatpacks are easier for the developer to create but they have their disadvantages so with the AUR available to us, that should be your first port of call after the community packages.


1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Thanks, I’ll make sure I do that in my next forum post. Thanks for the guidance everyone :smiley:


Uninstalling Zoom only disabled the issue for a few days. I ran into it again, and after a few hours of researching I found another thread that matches my issue.

The solution is to disable compositing on startup whenever you need to take a screenshot. This issue is Manjaro-specific and does not happen in other Arch-based distros.

If the compositor is the cause, you can disable/enable it quickly via alt+shift+f12.

I have to compositor running and can take screenshots flawlessly with flameshot


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.