Speciall buttons dont work after switching from windows to Manjaro KDE

Newbie here

I have a keyboard, mouse and headphones with extra buttons. And then I switched from windows (it worked before) to Manjaro KDE it stopped working. I noticed that when someone had similar problems no one could solve it.
So my question is: can I somehow bind my buttons to corresponding functions, via terminal or some other software?


Buttons on keyboard:
Sleep
Search
Internet
Mail
Pause video
Stop video
Fast Back(ard?)
Fast Forward
Mute sound
Special scrolling wheel to change volume
Mouse buttons:
Mouse 4, 5
Headphones buttons:
Volume up, down
Mute mic

If the issue is not yet solved - I won't help opening a new one.

This only clutters the efforts.

No they did not. Linux is not Windows and a lot of proprietary hardware functions only works within Windows. So they did not stop working - Linux kernel does not recognize them.

This is inevitable as the majority of development is focused on Microsoft Windows.

You may be able to catch some of the functionality and divert it to scripts but it is a huge taske and probably not worth the effort.


One method of getting the key pressed is using

sudo showkey --scancodes

or

sudo showkey

or

sudo dumpkeys

or pipe it into a file and open it in a text editor

sudo dumpkeys -f > dumpkeys.txt
1 Like

maybe not then, but it shouldnt stop you from trying now.

yes, as long as those keys provide some kind of output. your system info would be helpful, you may not need to set custom keys if you can make the keys work the way they should and usually you can.

post output of these commands, use the </> button above post entry box when pasting terminal output so it's formatted properly.

inxi -Fxxxza
lsmod | grep -Ei 'wmi|laptop|kbd|i80'
journalctl -k|grep -Ei 'wmi|hotkey|i80|kbd'
System:    Host: ManjaroJoo Kernel: 4.19.62-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=32e2cd34-9312-42a9-9203-97f13f702109 rw quiet 
           Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Acer product: Aspire M3203 v: N/A serial: <filter> Chassis: type: 3 serial: <filter> 
           Mobo: Acer model: RS780HVF serial: <filter> BIOS: American Megatrends v: P01-A1 date: 09/08/2009 
CPU:       Topology: Dual Core model: AMD Athlon II X2 240 bits: 64 type: MCP arch: K10 family: 10 (16) model-id: 6 
           stepping: 2 microcode: 1000098 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 11175 
           Speed: 800 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 800 2: 1600 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass status: Not affected 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
Graphics:  Device-1: NVIDIA GT216 [GeForce GT 220] vendor: PC Partner Limited / Sapphire driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:0a20 
           Display: x11 server: X.Org 1.20.5 driver: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: NVA5 v: 3.3 Mesa 19.1.3 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: NVIDIA GT216 HDMI Audio vendor: PC Partner Limited / Sapphire driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0be2 
           Device-3: C-Media CM108 Audio Controller type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-2:2 
           chip ID: 0d8c:013c 
           Sound Server: ALSA v: k4.19.62-1-MANJARO 
Network:   Device-1: Marvell 88E8071 PCI-E Gigabit Ethernet vendor: Acer Incorporated ALI driver: sky2 v: 1.30 port: e800 
           bus ID: 02:00.0 chip ID: 11ab:436b 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 935.25 GiB used: 13.67 GiB (1.5%) 
           ID-1: /dev/sda vendor: Seagate model: ST31000528AS size: 931.51 GiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC44 
           ID-2: /dev/sdg type: USB model: UFD 2.0 Silicon-Power4G size: 3.73 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: PMAP 
RAID:      Hardware-1: Advanced Micro Devices [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [Non-RAID5 mode] driver: ahci v: 3.0 
           port: 8000 bus ID: 00:11.0 chip ID: 1002.4392 rev: N/A 
Partition: ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%) used: 13.67 GiB (1.5%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 31.5 C mobo: N/A gpu: nouveau temp: 36 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 160 Uptime: 5h 14m Memory: 7.77 GiB used: 1.77 GiB (22.8%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.7 running in: yakuake inxi: 3.0.35
snd_rawmidi            36864  1 snd_usbmidi_lib
snd_seq_device         16384  1 snd_rawmidi
mxm_wmi                16384  1 nouveau
snd                   102400  24 snd_hda_codec_generic,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
wmi                    28672  2 mxm_wmi,nouveau
atkbd                  32768  0
libps2                 16384  2 atkbd,psmouse
i8042                  32768  0
serio                  28672  6 serio_raw,atkbd,psmouse,i8042

aug 10 14:54:07 ManjaroJoo kernel: ACPI: AWMI 0x00000000BF7BE0C0 00004E (v01 ACRSYS A c e r  20090908 MSFT 00000097)
aug 10 14:54:07 ManjaroJoo kernel: i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
aug 10 14:54:07 ManjaroJoo kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
aug 10 14:54:07 ManjaroJoo kernel: serio: i8042 AUX port at 0x60,0x64 irq 12

when using sudo showkey/ sudo showkey --scancodes my terminal recognised the inputs, even with the buttons that didn't work, I guess if i now know the keycode of my buttons I can write them function as I want.

Exactly - but I have no idea how - while having a lot of experience, this is not a task I have any experience in.

will try to make it work somehow.
Google will give me power :slight_smile:

1 Like

i thought this would of been a laptop issue, what keyboard is this?
hwinfo --keyboard

Sorry forgot to mention it was a PC

22: USB 00.0: 10800 Keyboard                                    
  [Created at usb.122]
  Unique ID: PYMB.K3cnp_SxtrC
  Parent ID: zPk0.uYbnlyRCGC6
  SysFS ID: /devices/pci0000:00/0000:00:12.1/usb4/4-1/4-1:1.0
  SysFS BusID: 4-1:1.0
  Hardware Class: keyboard
  Model: "Lite-On USB Multimedia Keyboard"
  Hotplug: USB
  Vendor: usb 0x04ca "Lite-On Technology Corp."
  Device: usb 0x002f "USB Multimedia Keyboard"
  Revision: "1.17"
  Driver: "usbhid"
  Driver Modules: "usbhid"
  Device File: /dev/input/event4
  Device Files: /dev/input/event4, /dev/input/by-path/pci-0000:00:12.1-usb-0:1:1.0-event-kbd, /dev/input/by-id/usb-Lite-On_Technology_Corp._USB_Multimedia_Keyboard-event-kbd
  Device Number: char 13:68
  Speed: 1.5 Mbps
  Module Alias: "usb:v04CAp002Fd0117dc00dsc00dp00ic03isc01ip01in00"
  Driver Info #0:
    XkbRules: xfree86
    XkbModel: pc104
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #18 (Hub)

part of the Manjaro install process allows user to select keyboard layout for language
but also the keymap for specific hardware keys on keyboard
so if a user didn't change default keymap to one for a multimedia keyboard then only the basic keyboard would work

some keyboards get automatically detected
but there is nothing listed for 'Lite-On' in /usr/share/kbd/keymaps/

there is package keyboardctl that may help you get keyboard reconfigured

will reply if it works

not used that package myself and not aware of any previous discussion on here so anything you can tell us about getting keymap changed will be helpful for future users

Forum kindly sponsored by Bytemark