Speaker profile

Can anyone tell me why Plasma / Manjaro thinks I have a surround speaker system connected please.

I have an old set of Harman Kardon soundsticks. They have two small speakers for mid and high tones, and a big subwoofer. They are not surround. In my previous install of Manjaro KDE they were seen as a two speaker setup. I’m now on a newer computer and this is how the system sees them (see picture below).

I’m connected via a 3.5mm audio output jack so the DAC in use is the one on the motherboard. There’s no option to connect via usb with this speaker system (like I said it’s old).

I don’t think I’m losing any part of the sound, but not 100% certain. When I listen to music or play videos all sounds ok.

When I click on the various test points you see in that image I only get a response from two of them.

There are no other profiles available. Can you add more? I have searched the forum, and used a general search engine, but so far found nothing.

The same thing hss started in Cinnamon too.
I have two speakers and a subwoofer but the subwoofer has no independent input, so it used to show just two speaker which was correct. In terms of what I hear all work except the subwoofer.

Ah well - at least I’m not alone.

Do you feel there’s any difference in your sound? I think my speakers are working just like they used to. I just posted to ask the question in case something was going on with my particular setup.

No of course not.

Ah - sorry. I see you already said your subwoofer does not work. Mine still works, but I cannot activate it with the test icons. It works when I listen to music or anything else though.

If an onboard audio codec only has two Profile options Hifi and Off, the Hifi profile should have a number of Ports for surround and stereo outputs

I suggest you check pactl list cards to see further information about Profiles and Ports

and pactl list sinks to check if the Sample Specification or Channel Map are using 2 channel stereo output

If speakers are only connected via one 3.5mm audio jack there will be a low-pass filter within the speakers to direct low frequencies to subwoofer and a high-pass filter for the stereo pair speakers
If the subwoofer is not working it is probably a malfunction within the filter or amplifier for the subwoofer

The subwoother does work its just in the settings the subwoofer does nothing but all other icons produce a sound, they should not, as most of those speakers are not present. The sinks are right they show two channels so that’s what the settings should show but they don’t.

Because you are plugged in as stereo speakers. The subwoofer in the test like that, if for a dedicated plugged in subwoofer in a 5.1 setup, which you are not using.

It’s not even 5.1 it’s 8.1
I have no idea what’s going on, anyone know?

Xfce does not have a speaker test GUI, but speaker-test commands can be run from terminal
speaker-test -f dat -c6 -l2 plays a couple of seconds of pink noise to one of six 5.1channels at a time

 0 - Front Left
 4 - Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE

Audio mixer and pactl list sink-inputs show that the speaker-test audio stream is using all 6 surround channels
but pactl list-sinks shows audio output stream is playing to stereo output with most of the surround channels remixed to stereo – Center channel can be heard in both left and right speaker; Rear Right is faintly audible in right speaker and Rear Left faintly audible in left speaker

Subwoofer/LFE is not audible because LFE remixing is turned off by default and LFE crossover frequency is set to 0 ( pulseaudio --dump-conf | grep lfe )

remixing-produce-lfe = no
remixing-consume-lfe = no
lfe-crossover-freq = 0

If both settings for remixing LFE are changed to yes and crossover frequency increased,
LFE audio can be heard remixed to both left and right speakers

If audio remixing is disabled in PulseAudio
( enable-remixing = yes changed to enable-remixing = no )
only Front Left and Front Right channels are audible in speaker-test

Thanks for this information. It looks like there is nothing I need to worry about.