Sound's keep muting and going on

Sound’s go to mute suddenly…and comes to previous place and that problem keeps happening nonstop
It keeps doing that after running linux for about 1-2 hours and it keeps doing that even after I’m not playing

You posted system information in a previous post showing 2 sound servers running

Everything lags including mouse pointer when copying files in nautilus - #3 by rakin09

  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: yes

Pipewire might be trying to take control of audio devices from PulseAudio, but Pipewire cannot work unless all PulseAudio packages are replaced with Pipewire dependencies

I suggest you check if both sound servers are still active

inxi -Aa

and disable the pipewire socket and service

systemctl --user disable --now pipewire.socket
systemctl --user disable --now pipewire.service

If the above solution works, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:1c20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.5-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: yes 

I did what u told me to do but PipeWire turned on after restarting…
And ALSA is running also…Is it causing this problem too?

try using these simpler commands one at a time

systemctl --user stop pipewire.socket
systemctl --user disable pipewire.socket
systemctl --user stop pipewire.service
systemctl --user disable pipewire.service
systemctl --user mask pipewire.socket

ALSA is running also…Is it causing this problem too?

ALSA is not a sound server like the other 3. It is part of the kernel and provides the drivers for audio hardware. If ALSA was not running the 3 sound servers would not be able to use most audio hardware

1 Like

Well I did what you told me to do but nothing much changed…
The problem is still the same.

I suggest you check both servers for errors

 systemctl --user status pulseaudio.*
 systemctl --user status pipewire.*

If PulseAudio is still active, try this command to clear user databases of old settings

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

and reboot system for PulseAudio to create new files

1 Like

I’m sorry, but that did not really help…

Did the first command show pulseaudio.service was active (running) ?

please post the response to this command to show more information about PulseAudio

pacmd dump
1 Like

Please find the information you requested below:

### Configuration dump generated at Mon Aug  9 21:10:10 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 0x18675
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1b.0.analog-stereo yes

set-source-volume alsa_output.pci-0000_00_1b.0.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1b.0.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1b.0.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1b.0.analog-stereo 0xae67
set-source-mute alsa_input.pci-0000_00_1b.0.analog-stereo no
suspend-source alsa_input.pci-0000_00_1b.0.analog-stereo yes

set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo

That data all appears to be OK

Recent updates include new versions for both PulseAudio and Pipewire, so I suggest you update the system next

If the audio issue persists after rebooting system, please post response to this:

systemctl --user list-unit-files | grep -E 'pulseaudio|pipewire'
1 Like