Sound working but no devices in plasma applet

I seem to be beset with weird problems on this fresh install :smiley:

  • Sound works, can change volume with hardware keys

  • Kmix works, though the icon shows muted all the time.

  • pa-applet works.

What I have tried:

  • Deleted ~/.config/pulse and rebooted

  • Edited /etc/pulse/client.conf chagged autospawn to yes.

pavucontrol:


Alsamixer:

No devices:

And to boot, spectacle segfaults, but runs fine from a terminal :confounded:

Any ideas?

System:    Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 tk: Qt 5.13.2 
           info: latte-dock wm: kwin_x11 dm: LightDM 1.30.0, SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Notebook product: W65_67SZ v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Notebook model: W65_67SZ serial: <filter> BIOS: American Megatrends v: 1.03.05 date: 02/26/2014 
Battery:   ID-1: BAT0 charge: 47.0 Wh condition: 47.0/48.8 Wh (96%) volts: 12.3/11.1 model: Notebook BAT type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-4310M bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21561 
           Speed: 870 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1106 2: 1109 3: 1314 4: 1162 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: CLEVO/KAPOK driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0416 
           Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.2.7 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 chip ID: 8086:0c0c 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:8c20 
           Sound Server: ALSA v: k5.4.2-1-MANJARO 
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: f040 bus ID: 04:00.0 chip ID: 8086:08b1 
           IF: wlp4s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8169 v: kernel 
           port: e000 bus ID: 05:00.2 chip ID: 10ec:8168 
           IF: enp5s0f2 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 306.54 GiB (14.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB speed: 3.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 0001 scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> rev: 1B6Q 
           scheme: MBR 
Partition: ID-1: / size: 228.23 GiB used: 31.57 GiB (13.8%) fs: ext4 dev: /dev/sdb1 
           ID-2: /home size: 1.79 TiB used: 274.97 GiB (15.0%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 242 Uptime: 40m Memory: 7.70 GiB used: 2.77 GiB (36.0%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: zsh v: 5.7.1 running in: server inxi: 3.0.37 

How did you install this? Any nice trick used? or standard installers (which one?)?
Try with a new user.

No need to say... update packages :laughing:!
And of course... check the logs!!

check
systemctl --user status pulseaudio.service pulseaudio.socket

and check if 'module-device-manager' is listed in
pactl list short modules
if module is absent may be cause of problem with plasma settings

2014 BIOS? (my personal favorite.)

My question is why is it showing 2 separate audio devices?
On all my core I3, I5, and I7 systems I only show one device.

Your system:

Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c

Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 Sound Server: ALSA v: k5.4.2-1-MANJARO

My System:

Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k4.19.85-1-MANJARO

Why pavucontrol?
Plasma has it's own pulse audio control built in:

To answer the questions:

  • Standard iso install, back to ext4 from btrfs, so all drives reformatted. Updated of course :smiley:

  • Don't think there is a bios update - couldn't find one on the clevo site.

  • Can't try @nikgnomic idea as I restored a timeshift backup.

All of the last 5 timeshift backups didn't fix it, but an on-demand from 2nd November did (late last night), I had 700+ updates. But am working.

@AJSlye - Two sound devices, HDMI & Normal

But working - I think the problems all relate to what ever changed my host-name to linux.local changing that back fixed a lot.

And spectacle now works...

Thinking about it - I have seen a linux.local hosts on here recently:

OK, my next question would then be, why is the hdmi output not showing up under pavucontrol?
This might just be what is messing with the mixer applet.

Because I am not using it, it is a laptop, I don't plug in an external monitor / TV so it is turned off:

Top one is HDMI, bottom one sound card. (Obviously this screenshot is from a restored machine :smiley: )

You might need to reverse their order.
The mixer applet typically picks up the first device in the list.

1 Like

What should be done if module-device-manager is missing? I tried the adding the module to default.pa as described here and additionally tried running pacmd load-module module-device-manager. However in both cases pactl list short sinks still doesn't show the module. Incidentally, running start-pulseaudio-x11 returns Failure: Module initialization failed unless I run pulseaudio -k beforehand. I don't know if that's normal. Just like the OP, I can control audio devices in pavucontrol just fine, and I've previously tried the same things regarding pulseaudio's config files.

reboot

wiki.archlinux.org - KDE Plasma Workspaces and Qt4

see the KDE page in the PulseAudio wiki.
One useful tidbit from that page is that load-module module-device-manager should be loaded. This usually happens automatically at login through the script /usr/bin/start-pulseaudio-x11

pavucontrol does not display changes to Pulseaudio server and systemd pulseaudio.service

Thanks for the tip on restarting pulseaudio. However my problem is that module-device-manager is never loaded (in that it appears in sinks), either when I runload-module myself or after start-pulseaudio-x11 has executed.

Edit: after updating plasma-pa to 5.17.4-1 it all started working normally! pactl list short sinks still doesn't show module-device-manager so I guess that wasn't the problem after all.

check pulseaudio systemd service and socket

systemctl --user status pulseaudio.service pulseaudio.socket

install and run pasystray

check server strings and 3 modules already mentioned
non-KDE users will only see two x-11 modules

command in post #3 was incorrect (now edited)
list of sinks would never show modules

correct command is - pactl list short modules

plasma-pa depends on pulseaudio and could be affected by absence of module-device-manager
i cannot be any more specific about packages or modules i do not have or use

That command indeed makes more sense - I should have spotted that too. Thanks for the help.

I have the same problem with my fresh install (just installed latest Manjaro with KDE). I did everything on this post, but nothing happened. Im about 3 hours searching for a solution and nothing. The thing with me is that just the new users have this problem, me as the firs user configured during installation do not have this... Can someone help me? BTW im very noob at this... :disappointed: :persevere: :confounded:

hi @neonoafs

you need to start a new topic
and post system information - inxi -Fxxxz
and Pulseaudio information:
systemctl --user status pulseaudio.service pulseaudio.socket

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by