Sound suddenly stop work

Hi switch to manjaro a month ago or less not two quite sure but all of a sudden my sound stops working Ive tried alsa mixer and all the other common sense things to try but it just doesn’t work please help i was starting to like this distro but i might consider switching back to windows if my problem isnt resolve by in a weeks time because i have online school and sound is really crucial for that

    sudo --upload
    Uploading information to ... Done!

Your ALSA information is located at
Please inform the person helping you.

    $ sudo dmesg | grep snd
    [    5.878261] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
    [    5.968734] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3227: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [    5.968777] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [    5.968781] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    [    5.968783] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
    [    5.968786] snd_hda_codec_realtek hdaudioC1D0:    inputs:
    [    5.968789] snd_hda_codec_realtek hdaudioC1D0:      Mic=0x19
    [    5.968792] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12

    inxi -Fxxxx
          Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
           Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
           Sound Server-1: ALSA v: k5.10.26-1-MANJARO running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 0.125.0 running: no
           Sound Server-4: PulseAudio v: 14.2 running: yes
           Sound Server-5: PipeWire v: 0.3.24 running: no

Remove all the configuration files in /etc/pipewire (sudo mv /etc/pipewire /tmp)

Reinstall pipewire, pipewire-pulse, and pipewire-media-session (sudo pacman -S pipewire pipewire-pulse pipewire-media-session)

Enable and start the relevant services (systemctl --user enable pipewire pipewire-pulse pipewire-media-session) and (systemctl --user restart pipewire pipewire-pulse pipewire-media-session). After that, my devices appeared as usual and I was back in business.

OP is using PulseAudio and would not have pipewire-pulse and pipewire-media-session installed

But there might be .pacnew files for PulseAudio from a recent update in /etc/pulse/

please post responses to

ls /etc/pulse/ | grep pacnew


pacmd dump

ls /etc/pulse/
client.conf daemon.conf

pacmd dump
### Configuration dump generated at Sat Apr 10 09:46:11 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_01.1" card_name="alsa_card.pci-0000_00_01.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_00_14.2" card_name="alsa_card.pci-0000_00_14.2" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0.0 xauthority=/home/teku/.Xauthority
load-module module-x11-xsmp display=:0.0 xauthority=/home/teku/.Xauthority session_manager=local/teku-hppavilion:@/tmp/.ICE-unix/2023,unix/teku-hppavilion:/tmp/.ICE-unix/2023
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_14.2.analog-stereo 0x10000
set-sink-mute alsa_output.pci-0000_00_14.2.analog-stereo no
suspend-sink alsa_output.pci-0000_00_14.2.analog-stereo no

set-source-volume alsa_output.pci-0000_00_14.2.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_14.2.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_14.2.analog-stereo.monitor no
set-source-volume alsa_input.pci-0000_00_14.2.analog-stereo 0x2def
set-source-mute alsa_input.pci-0000_00_14.2.analog-stereo no
suspend-source alsa_input.pci-0000_00_14.2.analog-stereo no

set-card-profile alsa_card.pci-0000_00_01.1 off
set-card-profile alsa_card.pci-0000_00_14.2 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_14.2.analog-stereo
set-default-source alsa_output.pci-0000_00_14.2.analog-stereo.monitor

### EOF

No response to first command confirms there are no .pacnew files
(a .pacnew file might have had changes not merged with PulseAudio configuration)

PulseAudio data appears to be OK
HDMI outputs are turned off. Analog input and output is not muted or suspended

I suggest you delete the PulseAudio cookie and databases in user home folder

rm ~/.config/pulse/cookie ~/.config/pulse/*.tdb

and reboot to ensure PulseAudio rebuilds new files

please still no audio
@nikgnomic not sure if this helps but i edited my comment now i earlier because i tried it again and i could see files

@nikgnomic ok since this is not working can you please guide me to reinstall my sound drivers or the whole sound system.

The 4 files shown are the usual configuration files for PulseAudio
client.conf daemon.conf

The filter used with the command I suggested (| grep pacnew) is to show only files with ‘pacnew’ in the name
If there were files daemon.conf.pacnew or, they may contain changes to PulseAudio configuration that were not added to daemon.conf or during an update
pacman/Pacnew and Pacsave - ArchWiki

I would not usually consider reinstalling drivers but it might be an option if hardware troubleshooting showed a problem with drivers
Data from dmesg in OP did not appear to show any problems with hardware detection

Please post ALSA information about audio devices for deeper inspection of hardware

sudo --upload
1 Like

@nikgnomic please respond
Uploading information to … Done!

Your ALSA information is located at
Please inform the person helping you.