Sound Stopped Working

Yesterday I ran some system updates and now my sound has just dropped working.

My system details are:
Kernel: 5.11.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.21.4 Distro: Manjaro Linux base: Arch Linux

Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           Sound Server-1: ALSA v: k5.11.14-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: yes

I’ve attempted to restart pulseaudio and its services but its made no difference, now when I run the following:

systemctl --user status pulseaudio

It is “active (running)” but it has the following error:

pulseaudio[71042]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security polic>

Disable either PipeWire or PulseAudio ─ they don’t work well together ─ or install the manjaro-pipewire metapackage.

2 Likes

Thank you very much :smile:

Just in case anybody else needs the info I did the following:

pacman -Rdd manjaro-pulse pulseaudio-alsa pulseaudio-bluetooth pulseaudio-ctl pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

pacman -S manjaro-pipewire

After a reboot my sound is good again :slight_smile:

3 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.