Sound stopped working

#1

I have been using manjaro for around 6 months and after the initial installation everything worked perfectly until today. Today when I turned on my laptop and tried to listen to music the audio would not work, which I found very odd because I had not made any changes to my system recently.

I am using pulseaudio. When I go open PulseAudio Volume Control I notice that there are no output devices even when my speakers are connected and under configuration all options for built in audio are unavailable.

0 Likes

Connexion audio bluetooth instable
#2

Have you rebooted? Just to make sure some thing didn’t go belly up at boot.

0 Likes

#3

Of course, first thing I tried

0 Likes

#4

Boot with a live media install and see if works. Might be a hardware failure … worst scenario …

0 Likes

#5

Could be this:
https://forum.manjaro.org/t/pulse-audio-is-broken

If you don’t want to downgrade, this might work:

0 Likes

#6

Gave both options a shot but it didn’t work

0 Likes

#7

@Mel I noticed you helped someone else with a similar issue. Any chance you can give me a hand?

0 Likes

#8

That’s possibly the worst phrase ever when it comes to troubleshooting. For example, what didn’t work?

In order for people to provide help you need to find a way of providing information which might point to a possible cause.

In this case, you might try running pulseaudio -vv in a terminal to check what output it provides.

If this is the same issue as the linked thread then there’s no known cause or solution, so it’s up to people who are having the issue to find the solution.

0 Likes

#9

@jonathon

That is the issue, I am not sure. First I ran the commands

$ systemctl --user stop pulseaudio
$ systemctl --user disable pulseaudio
$ systemctl --user enable pulseaudio

and rebooted as suggested, but still had the same issue. The only output shown on PulseAudio Volume Control was still Dummy output. So I decided to downgrade as suggested and the same issue persisted. I didn’t really know what additional information I could provide.

This is the command you asked me to run

[jp@jp-laptop ~]$ pulseaudio -vv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 12.0-dirty
D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 4.14.54-1-MANJARO #1 SMP PREEMPT Sun Jul 8 19:14:13 UTC 2018
D: [pulseaudio] main.c: Found 4 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is f57b45db5ba44d8a851e85862d42a7a0.
I: [pulseaudio] main.c: Session ID is c2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/jp/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-12.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
0 Likes

#10

I just ran that command with the same results, except the Machine ID and num CPUs. Sound is okay here.

Thinking about the hardware side of things:

  1. Are the speakers USB or 3.5mm jack connected?
    If USB, have you tried a different port?
  2. Have you tried the speakers on another computer? - test the hardware is not faulty.
  3. Does sound work without the speakers, using the laptops own speakers?
0 Likes

#11

According to this, PulseAudio is already running.

The issue does not appear to be with PulseAudio, but with your sound hardware being detected.

So, let’s get the output of inxi -Fxxz so we can see what you have.

0 Likes

#12
[jp@jp-laptop ~]$ inxi -Fxxz
System:    Host: jp-laptop Kernel: 4.14.54-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 
           Desktop: Gnome 3.28.2 dm: lightdm Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Laptop System: ASUSTeK product: X555QA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X555QA v: 1.0 serial: <filter> UEFI: American Megatrends v: X555QA.320 
           date: 09/08/2017 
Battery:   ID-1: BAT0 charge: 29.2 Wh condition: 30.6/37.3 Wh (82%) volts: 7.6/7.6 model: ASUSTeK X555-50 
           serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: AMD A10-9620P RADEON R5 10 COMPUTE CORES 4C+6G bits: 64 type: MCP 
           arch: Excavator rev: 1 L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19969 
           Speed: 1297 MHz min/max: 1300/2500 MHz Core speeds (MHz): 1: 1297 2: 1296 3: 1297 4: 1297 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] driver: amdgpu v: kernel 
           bus ID: 00:01.0 chip ID: 1002:9874 
           Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD CARRIZO (DRM 3.19.0 4.14.54-1-MANJARO LLVM 6.0.0) v: 4.5 Mesa 18.1.3 
           compat-v: 3.1 direct render: Yes 
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:9840 
           Card-2: Advanced Micro Devices [AMD] Family 15h Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:09.2 chip ID: 1022:157a 
           Sound Server: ALSA v: k4.14.54-1-MANJARO 
Network:   Card-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter driver: rtl8821ae v: kernel 
           port: e000 bus ID: 01:00.0 chip ID: 10ec:8821 
           IF: wlp1s0 state: up mac: <filter> 
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Card-3: IMC Networks type: USB driver: btusb bus ID: 1:3 chip ID: 13d3:3414 
Drives:    HDD Total Size: 931.51 GiB used: 40.81 GiB (4.4%) 
           ID-1: /dev/sda vendor: Hitachi model: HGST HTS541010A9E680 size: 931.51 GiB speed: 6.0 Gb/s 
           serial: <filter> 
Partition: ID-1: / size: 906.94 GiB used: 40.81 GiB (4.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A gpu: amdgpu temp: 0 C 
           Fan Speeds (RPM): cpu: 2500 
Info:      Processes: 161 Uptime: 3m Memory: 7.32 GiB used: 697.9 MiB (9.3%) Init: systemd v: 239 Compilers: 
           gcc: 8.1.1 clang: 6.0.0 Shell: bash v: 4.4.23 running in: terminator inxi: 3.0.12
0 Likes

#13

I’m pretty sure it is a software issue because when I booted into a live usb the sound worked.

  1. My speakers are connected to the audio jack
  2. I played music on the speaker from my phone and it worked fine.
  3. The sound does not work at all.
0 Likes

#14

@jonathon

Another weird detail is yesterday when I reinstalled the packages alsa-firmware, alsa-lib-x205ta, alsa-plugins, alsa-utils, pulseaudio, pulseaudio-alsa, pulseaudio-bluetooth and rebooted my sound worked for around 30 seconds but then broke again. The oddest part about this is when I did the same thing again nothing happened.

0 Likes

#15

It seems that way. I can’t offer much else I’m afraid.

0 Likes

General Discussion
#16

Did you boot from live media as i initially proposed? Doe the sound work there?

0 Likes

#17

Yes, and it works so I think it is a software issue

0 Likes

#18

Get the output of journalctl | grep audio from terminal and post it on https://pastebin.com/ then share it here … i’m curios if something will show up there as a culprit …

0 Likes

#19

The entire output was too long to post without pastebin pro so I posted the output in the month of July. I was not having any audio issues before July

https://pastebin.com/UnaDuP4p

0 Likes

#20

There are a couple of things that seems to be strange, at least as i understand it. I understand that we have different audio cards, but here is one thing on my end:

while on your end

after this, on your end, it fails with a duplicate “Successfully made thread” … and
pulseaudio[1381]: E: [pulseaudio] pid.c: Daemon already running.

So, can you check if the /usr/lib/systemd/user/pulseaudio.service looks like this or is different:

Requires=pulseaudio.socket
ConditionUser=!root

[Service]
# Note that notify will only work if --daemonize=no
Type=notify
ExecStart=/usr/bin/pulseaudio --daemonize=no
Restart=on-failure

[Install]
Also=pulseaudio.socket
WantedBy=default.target
0 Likes