Sound randomly goes away with Kernel 5.15.85-1

I’m using LTS Recommended Kernel 5.15.85-1 because the “Optimus Manager” does not work with any other Kernel at the moment. If the “Optimus Manager” doesn’t work, then the Nvidia card doesn’t work!

My problem is not with the Optimus Manager. It is with the sound. When watching youtube, the sound is randomly muted. Playing around with the sound control (volume) doesn’t solve the problem.

To solve the problem, I keeping exiting out the browser and keep launching the browser until I get sound.

I don’t have the sound problem with Kernel 6.1.1-1, but the “Optimus Manager” doesn’t work with Kernel 6.1.1-1. Does anybody have any idea why the sound randomly goes away with Kernel 5.15.85-1?

Thanks for your help.

it’s a known issue:

i switched to Kernel 6.0 for now where optimus manger works for me.

and this might be related to the the Nvidia & Kernel 6.1 issue:

something with an ibt=off parameter.

Yes, as said, some intel sound chips are failling on 5.15 kernels sin 5.15.82 or so. No way to solve it in 5.15 unless you can downgrade to 5.15.7x.
But both 6.0 and 6.1 work fine, though you have to add ibt=off to the grub boot line to une nvidia gpu with this 6.x kernels.

Thank you all for responding to my post. Much appreciated!

I have 2 quick questions. You mentioned that if I add ibt=off to the grub boot line, then I would be able to use the Nvidia gpu with 6.x kernels.

First question:
How do I edit grub and insert ibt=off and update grub?

Second question:
When I go to “System Settings”, and “Kernel” in Manjaro, I don’t see 5.15.7x kernel as an option to downgrade to. The one I’m currently using is LTS Recommended Kernel 5.15.85-1. As an option to downgrade to, only Kernel 5.10.161-1 and other previous kernels are listed. So, how do I manually add 5.15.7x kernels or any kernel of my choice to this list so that I can downgrade or upgrade to the recommended one?

Thank you.

To add something to the Grub line, the are two main options.
if you just want to try it once, not permanently, you can add this by hand on boot time entering the grub menu and adding this to the line (usually pressing Esc during the boot sequence).
But to get this automated and permanent, edit (as root user) /etc/default/grub
Search the line GRUB_CMDLINE_LINUX_DEFAULT= and add
ibt=off to the content inside the " ". For example,
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ibt=off"
Don’t remove nothing! Just add this to the line
After that, still as root, execute update-grub
And in next boots, the code will be executed.

About the kernel downgrade. This is not simple to be done. It depends on how you have configured pacman (or pamac, octopi, or what you use to install and update packages). If you have used before a 5.15.7x or older kernel, and you don’t have deleted the install package, you could downgrade using (as root) the downgrade command. But of you have not used this compiltion of kernel, or have erased the package, is not easy to get the package. In this case (and I would say in any case), the upgrade to 6.0 or 6.1 (best option) is the only way.

Thank you, Nacho, so much for your help! Adding “GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash ibt=off”” to grub fixed the Optimus Manager problem with the current kernel I’m using. Now both sound and the Nvdia graphic card are working fine. I appreciate your help. :smiley:

I don’t mean to piggyback on this with an unrelated question, but I think the issue may be fixed/solved by adding the correct instruction in grub.

I have an MSI laptop. The keyboard has a backlight. All keys light up. And it helps a lot when typing in low light or in the dark. But the laptop’s keyboard backlight doesn’t work in Manjaro. During boot-up, the keyboard lights up fine because, by default, the keyboard backlight is enabled in BIOS. But as soon as Manjaro takes over and starts, the keyboard light turn off.

Also, while shutting down Manjaro, as soon as Manjaro exists the GUI (graphic user interface), the keyboard backlight turns on momentarily again in the commandline screen. I was just thinking maybe inserting the correct instruction in grub could fix this problem.

I cannot say about that, but perhaps there is some module needed, or, as you said, there is some other code that could be inserted on boot time. But could also be a feature not supported actually by linux. You’ll have to search and try. Good luck!