Sound periodically mutes with blueetoth headphones/JBL

After less than a minute sound disappears for 5-50 seconds and then this behavour repeats (I’m using A2DP profile).
Tried with bluetooth headphones and JBL speakers. They both work fine with Win10/Android.

Already tried everything mentioned here - howto-bluetooth-headphones-paired-but-no-sound-after-a-while support page (adding modules loading, disabling module-suspend-on-idle)

rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no


sudo dmesg | grep -i bluetooth
[    1.314866] usb 3-3: Product: Bluetooth Radio
[    6.864353] Bluetooth: Core ver 2.22
[    6.864385] Bluetooth: HCI device and connection manager initialized
[    6.864389] Bluetooth: HCI socket layer initialized
[    6.864390] Bluetooth: L2CAP socket layer initialized
[    6.864395] Bluetooth: SCO socket layer initialized
[    7.142867] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    7.142882] Bluetooth: BNEP filters: protocol multicast
[    7.142894] Bluetooth: BNEP socket layer initialized
[    7.903560] Modules linked in: snd_usb_audio(+) snd_usbmidi_lib snd_rawmidi snd_seq_device cmac algif_hash algif_skcipher af_alg bnep btusb btrtl btbcm btintel uvcvideo bluetooth videobuf2_vmalloc videobuf2_memops videobuf2_v4
l2 videobuf2_common videodev ecdh_generic mc ecc rtw88_8822ce rtw88_8822c rtw88_pci rtw88_core amdgpu snd_hda_codec_realtek joydev snd_hda_codec_generic mac80211 mousedev snd_hda_codec_hdmi snd_hda_intel snd_intel_dspcfg soundwir
e_intel soundwire_generic_allocation soundwire_cadence snd_hda_codec snd_hda_core gpu_sched edac_mce_amd snd_hwdep i2c_algo_bit kvm_amd soundwire_bus ttm vfat huawei_wmi(OE) ledtrig_audio hid_multitouch sparse_keymap wmi_bmof fat
cfg80211 drm_kms_helper kvm snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_pcm cec syscopyarea snd_timer irqbypass sysfillrect sysimgblt rfkill snd rapl snd_rn_pci_acp3x sp5100_tco eeprom pcspkr fb_sys_fops libarc4 sou
ndcore k10temp snd_pci_acp3x i2c_piix4 wmi video tpm_crb i2c_hid mac_hid tpm_tis
[   23.647762] Bluetooth: RFCOMM TTY layer initialized
[   23.647775] Bluetooth: RFCOMM socket layer initialized
[   23.647783] Bluetooth: RFCOMM ver 1.11


Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2
wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: HUAWEI product: KLVL-WXX9-PCB

Please help.

Give this a shot…

Thanks, but, as already mentioned, already applied everything mentioned in this how-to article.