Sound not working on ALC892 Analog


#16

http://www.alsa-project.org/db/?f=e8342a6c079256a411a32fd53d0a9934d38a7c42

Result of alsa-info.sh. A great script btw.


#17

if it shows as 0/1, it doesnt necessarily mean its not working. right now all my hdmi’s show 1/1 but im not using hdmi and my sound is working fine.

~ >>> aplay -l                                                                                                                                                    
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pulseaudio --kill
speaker-test


#18

I did do that, it is not a pulse problem as alsa has already no way of playing. I tried to make that clear before (the aplay output would be device busy in this case) .
soundtest should be the very same as aplay but with predefined audio, as far as i know. However, it does not prompt errors but the devices plugged in remains silent.


#19

From an outside source reply, while was doing changes in alsamixer from terminal

I had a look at the link you postes and with my limited understanding, i saw nothing wrong there. Hopefully you will get this sorted out.


#20

Well, thank you for your time spent!
I will check auto mute.
Edit: auto-mute is not the issue.


#21

Are you trying to play sound through the lineout or the headphones jack?


#22

Actually I am at the point where I have headphones on both connectors (back and case front) as well as stereo on lineout connected. Nothing is working.
Originally I did try to get the headphone jack working.


#23

from the info you posted from also-info.sh i noticed your bios are v1.70 from back in 2014. there is a beta one from 2018 you could try. if you dont want to go that route, since your hardware is older possibly install an older kernel like linux414 or linux49 (it doesnt hurt to have a backup installed anyhow)

another thing you should do first regardless is go back to the start and try a different mode of attack so your not battling against problems you may or may not have added to your original problem along the way.

pulseaudio --kill

backup and then delete the contents of ~/.config/pulse/ and /etc/pulse/ then reinstall via pacman (re-install, not uninstall/install, if you try and uninstall pulseaudio, expect bigger problems than audio. do it like this and new configs will be created during re-install. this also avoids dependency hell, i learned the hard way :grinning:)

sudo pacman -S pulseaudio pulseaudio-alsa
reboot
test it out and run/post that alsa-info.sh script again before changing anything. it much easier to diagnose/fix something from a clean slate.

as it is now that whole output from alsa-info.sh is

id : (null),(null),(null),(null),(null),(null),(null)

#24

Your guess is not correct - speaker-test function is very different to aplay
The point of using terminal command for this is to see accurate response data
The times when you say aplay commands appeared to work may have given some clues to help you find the problem in your system

suggest you go to pavucontrol --tab 5 and set profile on all listed devices to ‘Off’
( there are many other ways to suspend/stop or disconnect Pulseaudio from ALSA )
then find an audio player or similar sound source, that can be set to playback direct to hardware
use that as reliable audio source whilst investigating alsamixer and pavucontrol

I noticed in amixer part of alsa-info script that the LFE channel appears to be muted.
This would not make a difference for stereo ALSA playback but it might be causing a problem in Pulseaudio with the surround sound profiles


#25

I will try older Kernels, but nothing important should have dropped out in this case. The Bios-Update does not change anything but the cpu microcode. In the use case of this machine I prefer to not get them.
I did try on a second installation (complete fresh install) too with same (non existent) success.


#26

speaker-test, looking at the source code, is playing audio the very same way aplay does after decoding unsing asoundlib? If one works, the other should too and the other way around, assuming decoding is working. In any way, I did use both, speaker-test and aplay many times now.

As I said before, its not an issue with pulse. Aplay (and speaker-test respectivly) does not prompt errors, but no audio is played either. It is just dead silent while the system appears to not recognize any exceptions. There is no way of playing any audio atm. I would not mind to use alsa directly. Actually, I don’t know which clue to get other than it is not an issue with pulse (which might exist in addition, but is obviously not causing the issue).

What you suggest is basically what I am doing all along, isn’t it? Please correct me if I am wrong.

I can unmute lfe, but this would be very strange reason. However, I will do that when I am back at home.

I might also pxe install a few other distros (got a few spare drives I can use for that) and see if sound is working out of the box with any of those and if so, compare the systems.


#27

you’d be surprised of the effects pulse can have, do some searching and you’ll see for yourself. either way, my suggestion of backup/delete pulse configurations and re-install pulse without removing any dependencies was more towards cleaning the slate after trying other “fixes” that could also be contributing to your problem. (eg. starting with one problem and created two more along the way attempting to fix it.)

good idea, only takes minutes. alot of people use older kernels that work better with older hardware, you wont know until you try.
mhwd-kernel -i linux414
or
mhwd-kernel -i linux49
or even earlier kernels? and again good practice for running down the actual cause would be to test your sound configurations with each of them using a clean slate/default configuration. otherwise you may end up treating a symptom of the issue instead of the issue itself. spending 2 minutes now could save you 2 hours later.


#28

yes it is a strange one. It was something I saw recently with another audio codec that i had not seen before.
Pulseaudio uses udev to detect audio device and creates the surround sound profiles. In one other case I found that muting even the unused LFE channel muted all surround sound profiles including 2.0 stereo

I am not criticising your methodology on this, just lack of data on aplay/speaker-test commands. I have had problems in past with people used to non-Linux OS had problems getting the right device and parameters to get a result with aplay.
I am 99% confident that if you had posted the ‘working’ aplay response i wouldn’t find any problem
just a tiny possibility that audio was playing to incorrect ALSA device/sub-device or something was not quite right with audio samplerate; number of channels etc
This is not a big deal and do not consider it productive to keep trying further.

The solution you is probably to use hdajackretask to correct or disable the jack detection function so the audio jack is not showing as unplugged
(hdajackretaskis included with package alsa-tools)

I have suggested using this tool this a few times, but not had anyone return to explain if it ever worked, or how to use the tool to repair a specific problem


#29

This seems to be what I need for my desktop. Can you elaborate on this?


#30

I am starting to think it might be easier to just get a audio card like back in the old days.
Using hdajackretask I managed to get rid of the unplugged information, it still does not work though. However, when choosing the device as output using pavucontrol I can now hear the jack beeing activated, just a short static sound. I unmuted the LFE channel, that did not change anything. I will check all channels and stuff again now, I changed so much, maybe I failed to revert something.
I will also add another speaker-test output.
I also tried a quick leap into Ubuntu, very same issue there.

At the moment I am about to install the “old” Kernel 4.9, but if this would work I will consider this a temporary workaround. What use is a rolling release distro when using old kernels.


#31

The 4.9 kernel is LTS, is at 4.9.149 version and that makes it quite mature, not old. A true old kernel would be an obsolete one IMO.

If you have the time and want to take a look at this topic
https://bbs.archlinux.org/viewtopic.php?id=182023
especially the post 15 and 16

I understand it’s been a frustrating journey and none of our proposals helped, but don’t give up. :slight_smile:


#32
speaker-test -D front:CARD=PCH,DEV=0 -c 2

speaker-test 1.1.7

Playback device is front:CARD=PCH,DEV=0
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 1048576
Period size range from 32 to 524288
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.935241
 0 - Front Left

Output of speaker test. Its the same device that gets blocked when using pulseaudio with the headphone device. I also tried using vlc where I can select every device using the front end in case i miss something here. As expected vlc did not change anything.

Kernel 4.9 did not help either. I agree its not an obsolete kernel, my CentOS machines still run some old 3.10 (of course with all current patches). Still I would love to keep track, also on this machine.

I will now have a look at the archlinux forum thread. Maybe I find something additional useful there. If this would be my machine I would propably just use it without sound, but since this one is intended for my wife this is not an option. This machine is mainly used for rawtherapee (thanks to the great openCl implementation the cpu is still running ok for this one in combination with a nice gpu), but I think some youtube videos might be a relevant usecase too.

Thanks for all your work spent here too.


#33

wish I could elaborate more on use of hdajackretask, but still hard to find much mention of it online

I used this tool once 3-4 years ago to reassign audio from a broken headphone jack on a laptop to the microphone jack

For jack detection problem like OP, run hdajackretask and enable option “advanced override” to see jack detection setting, like this:
https://i.stack.imgur.com/d2lRy.png

‘apply now’ will only apply changes for current session
if i recall correct ‘install boot override’ makes change permanent by writing a conf file to /etc/modprobe.d


#34

Then this is much more than just a Manjaro issue
suggest you check https://bugzilla.kernel.org/ if bug has been reported
and if not, file your own report


#35

Thanks, I’ll take a look at this during this week (I don’t use my desktop that much during the week anymore). The issue I have there is precisely jack detection not working and so plasma-pa doesn’t show analog devices. I worked around that issue, but I’d rather have them shown on the applet. You can take a look at it on this topic.