Sound not working, not in any distro, only in Windows. Tried basically everything

Hi there, a friend of mine has a laptop of which the sound is not working on Linux.
From the application ‘Speccy’ in Windows it seems like the laptop has two different sound cards. Neither he or I is specialized in sound cards or sound in Linux in general, so we don’t really know what we’re doing.

Things we’ve tried:
pacmd list-sinks

name: <alsa_output.pci-0000_00_lf.3.analog.stereo>
driver: <module-alsa-card.c>
suspend cause: IDLE
priority 9039
volume: front-left: 30419 / 46% / -20.00 dB, front-right: 30419 / 46% / -20.00 dB balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 0
sample spec: s161e 2ch 44100Hz
channel map: front-left, front-right Stereo
used by: 0
linked by: 0
configured latency: 0.00ms; range is 0.50 .. 2000.00 ms
card: 0 <alsa_card.pci-0000_00_1f.3>
module: 6
  alsa.resolution._bits = "16"
  device.api = "alsa"
  device.class = "sound"
  alsa.class "generic"
  alsa.subclass = "generic-mix" "ALC298 Analog" "ALC298 Analog"
  alsa.subdevice = "0"
  alsa.subdevice_name = "subdevice #0"
  alsa.device = "0"
  alsa.card = "0"
  alsa.card_name = "HDA Intel PCH"
  alsa.long_card_name = "HDA Intel PCH at 0xdf638000 irq 132"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:1f.3"
  sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
  device.bus = "pci" = "8086" = "Intel Corporation" = "9d71" = "Sunrise Point-LP HD Audio"
  device.form_factor = "internal"
  device.string = "front:0"
  device.buffering.buffer_size = "352800"
  device.buffering.fragment_size = "176400"
  device.access_mode = "mmap+timer" = "analog-stereo"
  device.profile.description = "Analog Stereo"
  device.description = "Built-in Audio Analog Stereo"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"
  analog-output-speaker: Speakers (priority 100000, latency offset 0 usec, available: unknown)
        device.icon_name = "audio-speakers"
active port: <analog-output-speaker>

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC298 Analag [ALC298 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In Pavucontrol there are no devices listed at all

Output of lspci | grep -i audio

00:1f.3 Multimedia audio controller: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

We’ve tried putting the following lines in /etc/modprobe.d/50-alsa.conf (one by one, rebooting after each):
options snd-hda-intel index=1,0
options snd-hda-intel index=2,0
options snd-hda-intel index=3,0

options snd_hda_intel enable=1 index=0
options snd_hda_intel index=1

And a lot of other things we found online that I can’t remember anymore.

Does anybody know how to make this work? Thanks!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

As it’s a friend’s laptop, I’d prefer not to put system information in my profile

Information from within Windows:
Sound Cards

  • Realtek High Definition Audio(SST)
  • Intel Display Audio

Playback Device

  • Speakers (Realtek High Definition Audio(SST))

Recording Device

  • Microphone Array (Realtek High Definition Audio(SST))

Output of the inxi command:

  Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=<filtered> rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Detachable System: SAMSUNG product: Galaxy Book 12 v: P04HAC 
  serial: <filter> Chassis: type: 32 serial: <filter> 
  Mobo: SAMSUNG model: SM-W720NTKBXAR v: SGL8766A2F-C01-G001-S0001+10.0.14393 
  serial: <filter> UEFI: American Megatrends v: P04HAC.000.180220.WY.1219 
  date: 02/20/2018 
  ID-1: BAT1 charge: 27.5 Wh (83.1%) condition: 33.1/39.0 Wh (84.8%) 
  volts: 8.4 min: 7.7 model: SAMSUNG Electronics SR Real Battery type: Li-ion 
  serial: <filter> status: Charging cycles: 591 
  RAM: total: 3.74 GiB used: 1.78 GiB (47.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber/Kaby Lake note: check family: 6 model-id: 8E (142) stepping: 9 
  microcode: EA cache: L2: 3 MiB bogomips: 21607 
  Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Samsung Co driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300 
  Display: wayland server: 1.20.11 compositor: gnome-shell driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.5 
  direct render: Yes 
  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging 
  vendor: Samsung Co driver: ipu3-imgu alternate: ipu3_imgu bus-ID: 00:05.0 
  chip-ID: 8086:1919 class-ID: 0480 
  Device-2: Intel CSI-2 Host vendor: Samsung Co driver: ipu3-cio2 
  alternate: ipu3_cio2 bus-ID: 00:14.3 chip-ID: 8086:9d32 class-ID: 0480 
  Device-3: Intel Sunrise Point-LP HD Audio vendor: Samsung Co 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0401 
  Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Samsung Co driver: ath10k_pci v: kernel port: f040 bus-ID: 01:00.0 
  chip-ID: 168c:003e class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb 
  v: 0.8 bus-ID: 1-3:3 chip-ID: 0cf3:e300 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 148.97 GiB used: 22.95 GiB (15.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SS32G size: 29.72 GiB block-size: 
  physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: MBR 
  ID-2: /dev/sda maj-min: 8:0 vendor: LITE-ON model: CV3-8D128 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 003 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 46.85 GiB size: 45.82 GiB (97.79%) used: 8.87 GiB (19.3%) 
  fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: <filtered>
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 32 MiB (6.3%) 
  fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A uuid: <filtered> 
  ID-3: /run/media/nightwind/Local Disk raw-size: 29.72 GiB 
  size: 29.72 GiB (100.00%) used: 14.06 GiB (47.3%) fs: ntfs 
  dev: /dev/mmcblk0p1 maj-min: 179:1 label: Local Disk uuid: <filtered> 
  Alert: No swap data was found. 
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: ext4 label: N/A 
  uuid: <filtered>
  ID-2: /dev/sda3 maj-min: 8:3 size: 47.04 GiB fs: ntfs label: N/A 
  uuid: <filtered> 
  ID-3: /dev/sda4 maj-min: 8:4 size: 24.83 GiB fs: ntfs label: Local DIsc 
  uuid: <filtered> 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Samsung type: Mouse,Keyboard,HID 
  driver: hid-generic,hid-multitouch,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 04e8:a00a class-ID: 0300 
  Device-2: 1-3:3 info: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA 
  chip-ID: 0cf3:e300 class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 36.0 C mobo: 34.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 262 Uptime: 20h 20m wakeups: 11 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1138 lib: 296 
  flatpak: 0 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06 

Thank you!

  1. First of all: my apologies for shouting at you. There was a rogue - below my original post. :sob:

  2. I"ve never seen a machine type like this: Is this a notebook hooked up to a docking station?
    Please update your UEFI firmware first if there is one (might also be called “BIOS update” on the manufacturer’s web site)

  3. Execute:


    and use the and to bring the volume to max

  4. Execute:

    pamac install alsa-tools

    and provide a screenshot of that.


Thank you for the response! In no way felt it rogue, don’t feel bad…

Anyways, it’s not hooked up to a docking station. It’s a tablet-like computer, just look up Galaxy Book :slight_smile:
There is no UEFI firmware update available. We’ve used alsamixer to turn up the volume.

This is a screenshot of tho hdjackretask command:
This is what it looks like when ‘Show unconnected pins’ is toggled on:

Thank you for your replies!

The first screenshot seems to have been deleted???

But from the second one I can see that your internal speaker is connected! :thinking:

So now my advice gets a bit more fuzzy as I don’t have your exact hardware:

  • Uncheck the Advanced override mode
  • Check Override on pin 0x13 (The first unconnected pin)
  • use the drop-down menu and choose the first thing that contains speaker except Internal speaker as that is already connected to 0x17
  • go down the list of unconnected pins and take the second, thirs, … hardware item that contains any speaker not connected yet.
  • When done with all speakers, click Apply now
  • If you get an error message:
    • Click Install boot override
    • Reboot
  • Test again.


I suggest you install v5.13 kernel. It might have been patched to detect this audio device correctly

Use either Manjaro Settings Manager GUI - manjaro-settings-manager -m msm_kernel
or this command

sudo mhwd-kernel -i linux513

If a later kernel does not help you might be able to get information about the working audio codec configuration using this guide:
How to sniff verbs from a Windows sound driver · ryanprescott/realtek-verb-tools Wiki · GitHub
Data from a working audio codec will help developers to create a kernel patch

1 Like

Hi there, sorry for the late response.

Weird that the link isn’t working, here is a new one:

Tried what you said, no luck sadly…

Any other ideas?

Follow @nikgnomic 's advice and report back, please.