Sound not working after upgrade

Yeah Gnome is probably the biggest departure from Windows, at least in the DE world. If it isn’t working for you, one thing you might try is changing the layout from the Manjaro Hello menu, one or two are more traditional with the panel and app menu on the bottom of the screen. Otherwise your best bet is probably something like XFCE or Mate.

I use XFCE and this is also an issue for me :frowning:
Unfortunately, pulseaudio -k hasn’t helped me either.

I created my first script ever in Linux and added it in the Autostart to execute at startup. It works for me. I will remove the script after each major update to see if they fixed it. Someone else replied that this is probably a race condition and this kind of confirms for me anyways that it is. Anyways I’m going to stick with Manjaro KDE.
sleep 15s
systemctl --user restart pulseaudio.service

PS. Remember this issue and failure signature originated with people with MSI B450 motherboards. I can’t speak for other motherboards as the symptoms and fixes may vary.


Another Update today. Still doesn’t work. Script still does though.

Guys, I just finished to update the archlinux-keyring and that fix for me.

Try to update that, there is the kernel 5.4.60-2-MANJARO.

Until now, I can start pulseaudio without the script.

I have this problem on Gigabyte motherboard.
And someone reports it exist on KDE Neon

And another case
and another

Looks like a bug in Plasma or pulseaudio

lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 01)
        Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD (Realtek ALC887) [1458:a002]
        Kernel driver in use: snd_hda_intel
01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be3] (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8354]
        Kernel driver in use: snd_hda_intel

This is unrelated to KDE as it happens in XFCE and I3wm as well.

None of the above solutions worked for me so I’m using EndeavourOS without sound issues on KDE Plasma.

1 Like

Hi guys, I found that the audio kinda works after loggout, but does not work after fresh reboot. So I gotta loggout everytime I reboot. LMAO.
What a weird bug.
BTW, I’m using Manjaro i3wm.


I have the Problem sometimes with my headset, the mic doesn´t work or the mic of the usb Camera is aktive or all is wrong.
I deaktivatet all out and input i don´t use in the moment but that is not really good for me, i need sometimes the other outputs.
Sometime i logout and login again and it works, so it can be that is kde related.

           tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z270 Gaming K4 serial: <superuser/root required> UEFI: American Megatrends 
Inxi -A
 Audio:     Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel 
           Device-3: Microdia type: USB driver: snd-usb-audio,uvcvideo 
           Device-4: C-Media USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.7.17-2-MANJARO ```

```14: PCI 1f.3: 0403 Audio device                                 
  [Created at pci.386]
  Unique ID: nS1_.NmpVsLdBa_E
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel 200 Series PCH HD Audio"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0xa2f0 "200 Series PCH HD Audio"
  SubVendor: pci 0x1849 "ASRock Incorporation"
  SubDevice: pci 0x1221 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xdff40000-0xdff43fff (rw,non-prefetchable)
  Memory Range: 0xdff20000-0xdff2ffff (rw,non-prefetchable)
  IRQ: 129 (3040 events)
  Module Alias: "pci:v00008086d0000A2F0sv00001849sd00001221bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

17: PCI 100.1: 0403 Audio device
  [Created at pci.386]
  Unique ID: NXNs.doyuXdAXYq0
  Parent ID: vSkL.U0F4Ujmaax4
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.1
  SysFS BusID: 0000:01:00.1
  Hardware Class: sound
  Model: "ATI Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0xaaf0 "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
  SubDevice: pci 0xaaf0 
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xdfe60000-0xdfe63fff (rw,non-prefetchable)
  IRQ: 130 (1267 events)
  Module Alias: "pci:v00001002d0000AAF0sv00001462sd0000AAF0bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

24: USB 00.2: 0401 Multimedia audio controller
  [Created at usb.122]
  Unique ID: WiL4._7Ow72zD9G2
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.2
  SysFS BusID: 1-2:1.2
  Hardware Class: sound
  Model: "C-Media Electronics USB Audio Device"
  Hotplug: USB
  Vendor: usb 0x0d8c "C-Media Electronics, Inc."
  Device: usb 0x0012 "USB Audio Device"
  Revision: "1.00"
  Driver: "snd-usb-audio"
  Driver Modules: "snd_usb_audio"
  Speed: 12 Mbps
  Module Alias: "usb:v0D8Cp0012d0100dc00dsc00dp00ic01isc02ip00in02"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #34 (Hub)

I’m having the same problem: Finding Dummy Output on startup, I have to unplug and plug or change to another profile and then back to Stareo or Duplex. If I made a pulseaudio -k after login it solves the problem. Now I need to check if I can execute it automatically. In my case is only KDE related. Gnome and XFCE on the same machine working just fine. I can’t post a link but I made a post called “Dummy output on restart/power-on on KDE” in post subforum.

1 Like

Just updating everyone after big updated today. I thought it was working at first but on second restart my settings were still set correctly at Analog Surround 5.1 but only two speakers where shown. After switching profiles to something else and back to 5.1 all the speakers were displayed and started working. So for now I will keep using start up script:
sleep 15s
systemctl --user restart pulseaudio.service

1 Like
systemctl --user restart pulseaudio.service

also fixes it for me!

In my case, my headset remained functional as an input device (I could record audio and everything) but disappeared as an output device. Restarting pulseaudio.service got it to show up as an output device again.

Did not solve for me:

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
Manufacturer: Micro-Star International Co., Ltd.
Product Name: Z390-A PRO (MS-7B98)
Version: 1.0
Serial Number: J716045591
Asset Tag: Default string
Board is a hosting board
Board is replaceable
Location In Chassis: Default string
Chassis Handle: 0x0003
Type: Motherboard
Contained Object Handles: 0

this command causes my pc to hang when starting the script, how do I run the command pulseaudio -k instead of restart pulseaudio.service?

I recently installed Manjaro i3 to a new dual booting (Win10) HP EliteBook 840 G2 laptop. Sound did not work and I tried many options. It works under same machine using a live Ubuntu system and Win10.

After 2-3 hours of work I finally realized that the ALSA system was setting “Card 0” (the HDMI interface) to default, and not “Card 1” (the PCM interface). It should be Card 1. I forced ALSA to use Card 1 as the default sound card and all is now fine.

This may not be the issue for others here, but is something everyone should check.

Same problem here. Running on a Gigabyte B550M motherboard with AMD Starship/Matisse HD Audio

I only get HDMI audio

None of the proposed solutions worked for me. I can’t hear audio after multiple attempts to

pulseaudio -k
systemctl --user restart pulseaudio.service

and rebooting. I am also on KDE like many others in this thread, and installed the pavucontrol-qt without success. Can anyone please help debug this further? How can I make these external speakers produce any sound again? I can control the volume with the keyboard keys, but no sound is produced.

Hey guys, since all of you that posted here seemed to suffer from these issues starting with this major “update” a few months back (it was in August, right? or around that time) I’m gonna ask here for an issue that could potentially stem from that same update as well.
Have you guys ever faced problems with Xfce (or any other desktop) not saving Settings between reboots? I mean, things like keyboard layout are not saved, Thunar settings, panel settings…
Were these things working before? (can you remember exactly what was the last month it worked fine?) I’ve seen a lot of people complaining about this “bug” and these issues can potentially stem from the same root cause, probably, remotely.
Seems to me something changed in the “core” of the whole Manjaro system, the devs don’t know exactly what broke it and they have been silent ever since, which leaves me worried a bit. I’ve seen someone suggesting EndeavorOS, I will try that, hopefully it will work with my ryzen hardware. If not, I’m back to Xubuntu once again, where I had none of these issues ever.
Is Debian recommended for Ryzen hardware? I need 3D and video encoding performance.
I liked the convenience of the Apt-Get package manager, so I will give priority to Debian-based distros for this moment.

Have you guys ever faced problems with Xfce (or any other desktop) not saving Settings between reboots?

I’ve not had this on KDE. This may be a harsh suspicion, but I would attribute something like this to “Xfce jankyness”. Xfce is a janky DE that I’d only use if I were on some weak lappy. Otherwise, try KDE; that’s the best DE. :yum: (I’m also on Ryzen hardware, btw.)

As for the sound issue, it’s long resolved for me. I had automated a restart of the pulseaudio service (systemctl --user restart pulseaudio.service) on a nightly script for a week or two, then I disabled it, to see if the issue just stopped. And it did!

I never needed a script to restart Pulseaudio, a simple “Sudo alsa force-reload” would suffice (this on Xubuntu 16.04, which I used for 4 years before being forced to move by a hardware upgrade)
Xfce on Xubuntu 16.04 worked fine, I had startup scripts to reload Xfce settings across multiple Live-Sessions, they would always work. Just replace the XML files and after a logoff/login it would read these new values. Simple and easy.
The problem is that something must have happened with recent Xfce updates to have changed how this mechanism works, and something broke along the way (they read values from multiple places, this can only increase the chances of something going wrong)
More details from another user are reported here:
And a portion of my script there, just to have an idea of how simple it was back then.
Xfce guys, get your stuff back together. This is going to affect all major distros.