Sound not playing from gnome-calendar notifications

Apologies in advance if this question has already been asked before, but I feel like this may be a bit of a unique situation. Also, this is a bit of a mix of gnome and xfce, so I didn’t know which forum to post it in sorry!

I am currently facing a problem with notification sounds, since I get regular pop up desktop notifications on Manjaro XFCE, yet no sounds ever play (even when I specify).
I’ve already followed the steps on this page from ToZ, and have tried changing my soundtheme to freedesktop, and gnome, but it still does not work.
The application from which I am trying to get sound notifications is the gnome-calendar, which is the first result you get if you search up ‘calendar’ on the add/remove software store, as a reminder for an event. Is it something to do with the fact that it’s gnome?
Thank you in advance!

you need to go into notifications settings & turn off “do not disturb”

Do not disturb is already off in my case, unfortunately

did you do the show preview, see if notifications is working.
have you got gnome-services checked

what do you mean by checking gnome-services?

the preview does not play any sound, does it usually play sound?

advanced settings, for gnome-stuff.

no the notifications are silent, just a popup.

sorry, I still don’t seem to be registering any sound. It’s only desktop notifications by the way, thunderbird notifications work and I can assure you my earphones work! :smiley:
Thank you for helping so far

Im using the freedesktop sound theme, since it seems the most complete at the moment

try running it in terminal, see what error it throws.

I ran the command “gnome-terminal --debug” and set an arbritrary reminder, but no error shows. It’s weird because the evolution calendar reminders work but not gnome-calendar

I had Xfce sound effects working from this discussion - Setting up Sound Effects
and toz on Archwiki - XFCE System sounds / Newbie Corner / Arch Linux Forums

The freedesktop theme didn’t work for me, but sound-theme-smooth from AUR works
Or the suggested Borealis theme can be downloaded and extracted to /usr/share/sounds/

I’ve tried everything from these threads, and nothing seems to work :frowning: . Do sound notifications on gnome-calendar work for you?

I use orage on Xfce
panel-plugins:orage:start [Xfce Docs]
that allows use of other commands to play audio instead of ‘canberra-gtk-play’

check PulseAudio Volume Control > Playback tab ( pavucontrol --tab=1 ) is showing System Sounds are not muted

Check system sounds are turned on and theme selected

xfconf-query -c xsettings -lv | grep -i sound

Check if canberra-gtk-module is loaded

env | grep GTK_MODULE

and check what sound effects are available

ls /usr/share/sounds/$(xfconf-query -c xsettings -p /Net/SoundThemeName)/stereo

If that is all in order, you should be able to play sound with a command like this

canberra-gtk-play -i desktop-login

If no audio is heard and there is no error message to show why playback failed there may be a problem in a later part the audio playback chain