Sound not as good as windows

Bhai I need help. I really want to run Linux on my laptop. It’s an HP pavilion 14bf-125tx laptop with soundcard realtek alc295. I can’t get the audio to work properly on Linux. I tried various distros- manjaro Fedora and pop os. All have the same issue. The sound is not loud enough. Probably the back speakers (or subwoofer) is not working properly. Please help.
tried alsamixer already without any results.
i am newbie, so i would happily provide any results one might need of commands in the terminal. i just want this problem to be diagnosed. thanks

Backspeakers and subwoofer? What exactly are you trying to power with a laptop in-built sound chip? 5.1 surround?

In my experience realtek is crappy crappy.
I know this isn’t likely what you want to hear but you’d probably be better off buying an external USB DAC/AMP. They’re not that cheap however.

On windows my asus xonar audio card had multiple gain profiles for headphone impedance but on linux I only get a single volume slider that’s incapable of driving the same volumes.

I wrote that down as the price of freeing myself of windows.

Personally i can only redirect you to some documentation.
I believe ALSA/Pulseaudio is still the default setup.
https://wiki.archlinux.org/title/Sound_system

HP documentation and manuals only mention 2 speakers (above keyboard)

https://support.hp.com/in-en/product/hp-pavilion-14-bf100-laptop-pc/16842295/model/18161570/document/c05669182
Audio features - B&O PLAY, dual speakers, HP Audio Boost

If you boot to other OS the audio driver settings might allow disabling of proprietary software enhancements to check if unprocessed audio still has higher level

HP specifications do not mention any built-in microphone
8th Gen Intel (kabylake refresh) will probably have a digital microphone array, but the snd_soc_skl driver to support the microphones has been problematic in kernel v5.10

I suggest you install kernel v.5.13 that may have bugfixes for the audio driver
You can use Manjaro Settings Manager GUI - manjaro-settings-manager -m msm_kernel
or this command

sudo mhwd-kernel -i linux513

Welcome to the forum! :wave:

Please post your system info as outlined here:

did you try the audio boost feature?
What desktop are you on?