Sound juicer problems

I’ve inherited a big pile of classical music CDs and decided to rip them. Sound juicer seems to be the default app for this on manjaro/xfce. About 60% rip ok, and 40% fail. All the ones that fail play ok in other applications. I don’t have much faith in the actual error messages that sound juicer is coming up with: they all start ‘Sound juicer could not read the track listing on this CD’ , though the detailed reason can vary (the one I’m looking at at the moment says ‘Reason: cannot access CD the name 1,211 was not provided by any .service files’). Googling finds me lots of people with similar problems round about 2011-2012, but nothing much more recent. The CDs that fail are a mix, some quite old (80s or 90s) some more recent (up to about 2010). Quite often one CD out of a series with the same date and manufacturer will fail and the others all work ok.

Any ideas?

I’ve tried on two different laptops, one with an internal CD reader, one external, both running manjaro with sound juicer 3.38.0, and they fail the same cds with the same ‘could not read the track listing’ error message.

I’ve also tried using the same external cd reader on a laptop with gentoo, but also with sound juicer 3.38.0. On that laptop the error that comes up is ‘cd not found on music brainz’ with the option to add it. So it looks like either there is a problem in the manjaro binary, or maybe I’m missing some library dependency?


Wrote too quickly. The gentoo laptop has a networking problem that stops it accessing musicbrainz at all. The behaviour of soundjuicer 3.38.0 on gentoo and manjaro is identical.


Maybe just switch the tool if the issue is old, known and reproducible on multiple distros, chances are that it is this tool that has an issue.

Check existing issues, here a search for “cannot access CD” Issues · GNOME / sound-juicer · GitLab

Maybe report the issue too?