Sound input and output randomly cuts off when using digital output

When I use my external DAC over digital output (Toslink) from my mainboard’s soundcard as default device, PulseAudio sometimes just stops playing sound (e.g. music) or sending input (e.g. mic input to Discord) for about 1-4 seconds. This only seems to happen with digital output selected.
Also, KDE’s microphone icon in the taskbar just keeps disappearing randomly for a few milliseconds.

How can I fix this?

pacmd list-sinks (only digital output device)

* index: 2
        name: <alsa_output.pci-0000_00_1b.0.iec958-stereo>
        driver: <module-alsa-card.c>
        state: RUNNING
        suspend cause: (none)
        priority: 9037
        volume: front-left: 64861 /  99% / -0.27 dB,   front-right: 64861 /  99% / -0.27 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 7.57 ms
        max request: 1 KiB
        max rewind: 1 KiB
        monitor source: 4
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
        used by: 2
        linked by: 2
        configured latency: 7.52 ms; range is 0.50 .. 2000.00 ms
        card: 3 <alsa_card.pci-0000_00_1b.0>
        module: 9
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
       = "ALC1150 Digital"
       = "ALC1150 Digital"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "1"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xfb330000 irq 51"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
       = "8086"
       = "Intel Corporation"
       = "8d20"
       = "C610/X99 series chipset HD Audio Controller"
                device.form_factor = "internal"
                device.string = "iec958:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
       = "iec958-stereo"
                device.profile.description = "Digital Stereo (IEC958)"
                device.description = "Built-in Audio Digital Stereo (IEC958)"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)

        active port: <iec958-stereo-output>


System:    Kernel: 5.13.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: X99 Extreme4 serial: <filter> UEFI: American Megatrends v: P3.40 date: 06/03/2016 
CPU:       Info: 6-Core model: Intel Core i7-5930K bits: 64 type: MT MCP arch: Haswell rev: 2 cache: L2: 15 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 84006 
           Speed: 1660 MHz min/max: 1200/3700 MHz Core speeds (MHz): 1: 1660 2: 1961 3: 1200 4: 1793 5: 3002 6: 1200 7: 1200 
           8: 3531 9: 1200 10: 3461 11: 3313 12: 1200 
Graphics:  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: ZOTAC driver: nvidia v: 470.63.01 bus-ID: 02:00.0 
           chip-ID: 10de:2182 
           Device-2: Logitech BRIO Ultra HD Webcam type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-2:2 
           chip-ID: 046d:085e 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia resolution: 1: 1920x1080 
           2: 1920x1080~60Hz s-dpi: 92 
           OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: Intel C610/X99 series HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:8d20 
           Device-2: NVIDIA TU116 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus-ID: 02:00.1 
           chip-ID: 10de:1aeb 
           Device-3: RODE Microphones Podcaster type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-12:4 
           chip-ID: 19f7:0001 
           Device-4: Logitech BRIO Ultra HD Webcam type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-2:2 
           chip-ID: 046d:085e 
           Sound Server-1: ALSA v: k5.13.11-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: kernel port: f020 bus-ID: 00:19.0 
           chip-ID: 8086:15a1 
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 3.67 TiB used: 1.01 TiB (27.4%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> temp: 33.9 C 
           ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> 
           ID-3: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> 
           ID-4: /dev/sdc vendor: Crucial model: CT525MX300SSD1 size: 489.05 GiB speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 463.17 GiB used: 39.24 GiB (8.5%) fs: ext4 dev: /dev/dm-0 
           mapped: luks-cd30fb77-e732-4a06-b6a7-5469cca30ecf 
           ID-2: /boot/efi size: 299.4 MiB used: 440 KiB (0.1%) fs: vfat dev: /dev/sdc1 
Swap:      ID-1: swap-1 type: partition size: 17.1 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1 
           mapped: luks-21e703d9-f76c-4e28-bb5e-2e4ed9ab2646 
Sensors:   System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 32% 
Repos:     Packages: 1457 pacman: 1452 flatpak: 5 
           Active pacman repo servers in: /etc/pacman.d/mirrorlist 
Info:      Processes: 364 Uptime: 29m Memory: 15.55 GiB used: 3.94 GiB (25.3%) Init: systemd v: 248 Compilers: gcc: 11.1.0 
           alt: 10 clang: 12.0.1 Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.06 

There are 2 incompatible sound servers running

           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 

Pipewire cannot support audio unless PulseAudio is removed and replaced, but it might be causing interruptions to PulseAudio

Use this command to stop, disable and mask Pipewire

systemctl --user disable --now pipewire.socket && systemctl --user disable --now pipewire.service && systemctl --user mask pipewire.socket

The microphone icon in the taskbar is still disappearing randomly, even with pipewire disabled.
I even tried uninstalling pusleaudio for pipewire, but the problem is persistent.
Also just as a sidenote: This even happens on a fresh install of Manjaro Pahvo.

I suggest

  • Disconnect both USB devices
  • Stop, disable and mask pipewire.socket and pipewire.service as per post#2
  • Change the PulseAudio profile for the 2 remaining devices to Off
  • Use a simple music player connected direct to digital output in ALSA to play local audio files

If audio can play direct to ALSA without interruption, change the PulseAudio profile for onboard audio to use Digital Output (S/PDIF) and reconfigure the music player to use PulseAudio

If audio can play through PulseAudio without interruption, add the other devices back to PulseAudio one by one

Okay, it seems like setting my capture card’s profile to off may have solved the issue:

    index: 23
        name: <alsa_card.usb-AVerMedia_AVerMedia_USB_Device_52021031000990-02>
        driver: <module-alsa-card.c>
        owner module: 45
                alsa.card = "3"
                alsa.card_name = "AVerMedia USB Device"
                alsa.long_card_name = "AVerMedia AVerMedia USB Device at usb-0000:04:00.0-2, super speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:04:00.0-usb-0:2:1.2"
                sysfs.path = "/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/usb8/8-2/8-2:1.2/sound/card3"
       = "usb-AVerMedia_AVerMedia_USB_Device_52021031000990-02"
                device.bus = "usb"
       = "07ca"
       = "AVerMedia Technologies, Inc."
       = "0570"
       = "AVerMedia USB Device"
                device.serial = "AVerMedia_AVerMedia_USB_Device_52021031000990"
                device.form_factor = "webcam"
                device.string = "3"
                device.description = "AVerMedia USB Device"
                module-udev-detect.discovered = "1"
                device.icon_name = "camera-web-usb"
                input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
                input:iec958-stereo: Digital Stereo (IEC958) Input (priority 55, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <off>
                analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: unknown)

                iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)

Emphasize is on may here because it’s hard to make this issue happen in the first place. The flickering mic icon is gone though!

EDIT: After a week without problems it’s safe to say, that this was the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.