Sound doesn't change to headphones

I’m not sure when the issue happened. Maybe it came with Plasma 5.24 or maybe sooner. I’m not using headphones too often, but I still do it from time to time.

Today, when I plugged the headphones, nothing happened. I checked, and the system changes from speakers to headphones, but the sound still comes from speakers. Nothing I do changes anything.

I’m using pulseaudio.

Any idea how to fix it?

I tried various headphones, the same.
I added the USB-jack transformator and then headphones are working through it. This suggests, the issue is with drivers or… configs of those. Or I may be wrong, sound system on Linux is too complicated and confusing.

When plugging headphones, Port changes to Headphones and shows Speaker as unavailable. However, I can still choose the speaker and test the sound, it works. So no matter if I have Speaker or headphone, I hear sound from speakers, also from the test. The only difference is, that speakers are a bit louder when speaker is selected.

I logged in to a vanilla, test user and the issue was present there as well, so it’s not a matter of a user config.

1 Like

Please add a reply with your solution, mark it :white_check_mark: as such and edit your topic title to remove [Solved].

I found the solution! I went to alsamixer and the settings: HP/Speaker and HP/Speaker Auto Detect were MM (muted). I unmuted them and now headphones work, no sound from speaker. When unplugged, voice switches to speakers correctly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.