Sound card not detected by ALSA on fresh Gnome install

Hi, I have a fresh install of Gnome minimal, and having issues with sound. USB headset sound works, but built-in speakers and headphone jack aren’t, just getting dummy output. shows ALSA is not detecting my soundcard:

& here is inxi -Aa:

  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_soc_skl v: kernel alternate: snd_hda_intel, snd_soc_avs,
    snd_sof_pci_intel_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0401
  API: ALSA v: k6.1.22-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.67 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl

I’d really appreciate help solving this (& I’m somewhat new to this kind of troubleshooting, newb-friendly explanations super appreciated). thanks in advance!

Welcome to Manjaro forum

I suggest you update system BIOS to latest version 1.18 — Support for SF314-54 | Acer United States

If audio is still not working as expected with latest BIOS, use this command to force use of snd_hda_intel driver

sudo tee /etc/modprobe.d/inteldsp.conf <<< 'options snd-intel-dspcfg dsp_driver=1'

snd_hda_intel driver does not support internal digital microphone array, but should allow ALSA to detect onboard audio device for audio to speakers or headphones

Thanks for these suggestions! I did both but unfortunately neither solved it - still no soundcard detected. I’d previously had Manjaro on this laptop and the sound output worked (but, like you say, no mic) and so I tried out earlier kernels, and running 5.4.240-1 the sound works again. I can just stick with it, but if there’s a way to figure it out with the newer kernel I would like to make that work.

Kernel 5.4 can only use legacy driver snd_hda_intel and cannot support internal digital mic array

Kernel 5.11 was patched by ALSA developers to support external headset microphone

LKML: gregkh@linuxfou ...: [PATCH 5.11 01/44] ALSA: hda/realtek: Enable headset mic of Acer SWIFT with ALC256

The Acer SWIFT Swift SF314-54/55 laptops with ALC256 cannot detect both the headset mic and the internal mic.
Introduce new fixup to enable the jack sense and the headset mic.
However, the internal mic actually connects to Intel SST audio.
It still needs Intel SST support to make internal mic capture work.

Intel SST driver snd_soc_skl is still not working correctly to support internal mic.
ALSA data in post #1 shows a number of errors with driver failing to load firmware; then “Failed to init topology” and “failed to instantiate card”