Sound card not being recognized by ALSA on Lenovo Yoga C930

Hi, I’m having problems getting the speaker and microphone to work on my Lenovo Yoga C930.

This is largely a continuation of the discussion started a while back regarding Yoga c930’s microphone titled Microphone on Lenovo Yoga C930 not working, I’m waiting on SOF-firmware to support intel Kabylake CPUs. Checking the GitHub feature request that was linked in that post, I found that it seems someone who works at Intel responded with instructions on how to enable support for Kabylake. I tried following the instructions but when I tried to compile the topology, I got multiple error messages. It still generated a .bin file so I just wanted to test my luck and continued up to “NHLT Overriding” where I got stuck (I don’t know what I should be doing for that part). In the end, mic and speakers both still don’t work. If anyone has figured this process out, I’d appreciate some help.

When I ran and generated the results, I noticed that although it can detect the sound card, ALSA doesn’t recognize it.

It should be noted that setting options snd_intel_dspcfg dsp_driver=2 does allow for some speakers to work. If I understand correctly, it’s forcing use of a legacy Intel driver.

If anyone has any ideas on how to proceed from here, I’d greatly appreciate it.

(by the way, I can’t currently include links in my posts as I just created this account)

1 Like

Welcome to Manjaro Forum

I found the other discussion you mentioned - Microphone on Lenovo Yoga C930 not working
SOF Firmware support for the digital microphone array should be working now
The bug report for Kabylake support has been closed, and another bug about C930/C940 laptops has also been closed
[BUG] Fedora 31 (kernel 5.4.7) SOF firmware load fails on Yoga C940 (i7-1065G7 Ice Lake) · Issue #2264 · thesofproject/sof · GitHub
You should be able to remove the modprobe option and have microphone working with sof-firmware driver
(but it may be better to comment it out with a ‘#’ in case you need it back)

The speaker issue has not been resolved yet so the workaround suggested in the previous post is the only other option for now
GitHub - droserasprout/lenovo-yoga-c930-linux: Varions fixes to provide full hardware support of Lenovo Yoga C930 on Linux
But there is another bug report about the speakers

I have a Lenovo C940, which I think is a similar device. I had huge problems with sound last year, but they are all fixed now. Make sure to use sof-firmware (install it from package manager), get the latest version of pulseaudio (at least 14) and use the latest kernel possible. (I currently use 5.11 but 5.12 which is coming up soon is promising to be even better)

I think if you use a non-thinkpad Lenovo laptop from 2020 or 2021, you need a kernel that’s at least 5.5. But keep your kernels updated because Ideapads and Yogas are behind in their drivers. This is suprising because Thinkpads usuallz have great Linux support, but other Lenovos are always running behind.

I believe this is because Lenovo developers fixed something in the BIOS for the C940 and also released some patch for Linux. Unfortunately, following the posts, they decided they would not produce a fix for the C930.

Glad to hear things are working out for your C940 though!

So if I’m completely honest, I had forgotten about trying to do this and returned to Windows for a while. Back on Manjaro now and yes the microphone works. I followed these instructions.

As you’ve said, speakers are still a problem but I can deal with 2-3 speakers working for now. In case anyone else is dealing with this issue and wants direct instructions, the above link should be useful. Feel free to trace the conversation via all other links provided.


I just noticed now there’s a typo here. I said options snd_intel_dspcfg dsp_driver=2 whereas options snd_intel_dspcfg dsp_driver=1 is the one that forces legacy driver.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.