Somehow wayland appeared on my machine. Why?

Somehow wayland appeared on my machine. Why?
Why didn’t send me a message the system updater about this severe change?

My system uses Cinnamon DE.
Now, the first issue is OBS Studio wont work because some encoder errors occured.
How can I get back to the well work Xorg?

Log out and choose cinnamon from the drop down menu

You tell us.

grep -i wayland /var/log/pacman.log

I found something interesting thing:

echo $XDG_SESSION_TYPE
x11

So, now I am really confused.
But the issue with OBS encoder error is still standing.

grep -i wayland /var/log/pacman.log
[2023-11-04T08:14:58+0100] [ALPM] installed egl-wayland (2:1.1.10-1)
[2023-11-04T08:14:59+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2023-11-04T09:08:00+0100] [ALPM] upgraded wayland (1.20.0-2 -> 1.22.0-1)
[2023-11-04T09:08:00+0100] [ALPM] upgraded egl-wayland (2:1.1.10-1 -> 2:1.1.12-1)
[2023-11-04T09:08:01+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2023-11-04T09:08:04+0100] [ALPM] installed wayland-protocols (1.32-1)
[2023-11-04T09:08:24+0100] [ALPM] upgraded lib32-wayland (1.20.0-2 -> 1.22.0-1)
[2023-11-04T09:55:39+0100] [ALPM] installed qt5-wayland (5.15.11+kde+r59-1)
[2023-11-06T23:39:14+0100] [ALPM] upgraded egl-wayland (2:1.1.12-1 -> 2:1.1.13-1)
[2023-11-06T23:39:17+0100] [ALPM] upgraded qt5-wayland (5.15.11+kde+r59-1 -> 5.15.11+kde+r60-1)
[2023-11-15T15:05:20+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2023-12-01T18:54:44+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2023-12-01T18:54:44+0100] [ALPM] installed xorg-xwayland (23.2.2-1)
[2023-12-19T15:48:14+0100] [ALPM] upgraded xorg-xwayland (23.2.2-1 -> 23.2.3-1)
[2024-01-15T18:23:53+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2024-01-15T18:24:16+0100] [ALPM] upgraded qt5-wayland (5.15.11+kde+r60-1 -> 5.15.12+kde+r61-1)
[2024-03-03T16:30:15+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service
[2024-03-03T16:31:03+0100] [ALPM] upgraded wayland-protocols (1.32-1 -> 1.33-1)
[2024-03-03T16:31:15+0100] [ALPM] upgraded xorg-xwayland (23.2.3-1 -> 23.2.4-2)
[2024-03-17T11:47:23+0100] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service

I found the error message in the OBS log file:

[NVIDIA NVENC H.264 (FFmpeg) encoder: 'simple_video_recording'] ffmpeg_video_encode: Error encoding: Invalid argument

I didn’t change any argument. So, I don’t know what should I do.
I appreciate any help that takes forward to the solution.

you tried this ?

So it looks like various wayland packages have been on your system since November last year.
xorg-xwayland was added in December.
Since then no wayland packages have been added.

So to answer your title query …

It didnt.

Cinnamon uses lightdm by default

Well, as I wrote earlier, it turned out my system uses Xorg. That is OK.

The other issue is still standing: How can fix the OBS problem.

Should I open a neew thread for this?

There are packages that depend on wayland no matter if you’re using a Wayland or Xorg session. You can see what it’s required by or optional for with…

pamac info wayland

or

pacman -Qi wayland

You dropped this. :wink: :point_down:

?

Yes.

However, before you leave this thread, please mark one of the replies by our helpful volunteers as the Solution :white_check_mark: if one solved your issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.