Some websites display - ERR_INTERNET_DISCONNECTED only on wired connection

Some websites, e.g. forbes. com, reddit. com, display ERR_INTERNET_DISCONNECTED, but only when I’m connected via cat 6 cable to the router. If I connect via wifi these sites work fine. Other sites work fine regardless of connection.

Rebooting does not solve the problem.

Hi and welcome to the Forum :+1:

It’s highly doubtful to get a “404” (Not found) error code while using the SAME internet connection…
So check if you have any VPN running on either your wired or wireless connection, because some sites only allow connections from certain Geo-Locations.

There’s no VPN running. And yes, this scenario seems abnormal to me as well. We are indeed talking about the same router, and same internet connection.

Also, pinging the sites returns their IP addresses, so I don’t think it’s DNS.


Oh… and now the sites load again. Bizarre. I want to say that during the window when they did not load… they still loaded via my mobile phone connection, as well as with the laptop using wifi. So it’s not that the sites were down. And even though the situation is resolved in this moment, it has been happening intermittently for several weeks.

Is it possible that the ARP cache is getting out of sync? Any thoughts on how I could troubleshoot that or bring quicker resolution?

404 is the server responding, so it is not your connection.

Are you using a proxy maybe?

1 Like

I’m sorry, I mispoke. It’s ERR_INTERNET_DISCONNECTED. [editing original post]

But at the same time while experiencing this, other sites load.

Apparently I’m not allowed to post screenshots or links.

  1. Your cable is broken.
  2. Your driver is not working. Please add information.

not sure where or when you see this

but this would (could) mean that the built in connectivity check of NetworkManager fails for some reason.

not sure what the IP is that it pings to determine “connectivity”

… search and you shall find … :wink:

to be more definitive, I’d have to do that very same search myself -
as I don’t remember off the top of my head …

If the cable or the driver are broken, why are other sites working fine?

That’s probably from a chromium based browser.

Can you provide a log or basic system information?

I see this in the browser when I attempt to load the site. Again, why would it only display this for some sites and not others?

no idea - it’s the first time you mention it :wink:

Yes, it’s Chromium. Good question… I’ll see if I can grab the logs.

I restarted Chromium with the flag --enable-logging=stderr as mentioned here: www.chromium .org/for-testers/enable-logging/

Honestly that’s a tremendous amount of data whizzing past… but I’ll see if I can catch this if it happens again.

Any other ideas?

Chromium: Version 111.0.5563.64 (Official Build) Manjaro Linux (64-bit)

I notice that if I have both the wifi and wired connections turned on and I run the arp command I get:

Address                  HWtype  HWaddress           Flags Mask            Iface
_gateway                 ether   d0:76:8f:22:85:b3   C                     enp58s0u2u2
_gateway                 ether   d0:76:8f:22:85:b3   C                     wlp3s0

I wonder if the laptop could be remembering the route from when the wifi was on? I tried to reproduce by turning only wifi on, visiting a url I have never visited, then switching wifi off and plugging in the cat6. But the site still loads.

Not sure what the steps to reproduce are.

Update: Now getting ERR_NAME_NOT_RESOLVED on linkedin. com. I connected wifi and could load the site. I disconnected wifi, falling back to wired, and now the site displays ERR_INTERNET_DISCONNECTED.

Arp only displays:

Address                  HWtype  HWaddress           Flags Mask            Iface
_gateway                 ether   d0:76:8f:22:85:b3   C                     enp58s0u2u2

So it has no memory of the wifi gateway.

ip a
could be more helpful

enp58s0u2u2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        ether 20:7b:d2:4c:e1:e2  txqueuelen 1000  (Ethernet)
        RX packets 410407  bytes 395749559 (377.4 MiB)
        RX errors 0  dropped 386  overruns 0  frame 0
        TX packets 179275  bytes 55163902 (52.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::dc57:a1b0:24be:b467  prefixlen 64  scopeid 0x20<link>
        ether e0:9d:31:db:52:45  txqueuelen 1000  (Ethernet)
        RX packets 19917  bytes 20389126 (19.4 MiB)
        RX errors 0  dropped 13  overruns 0  frame 0
        TX packets 5053  bytes 1265869 (1.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Now LinkedIn is loading again. So the disconnect only lasted a few minutes this time, but in some cases it lasts for hours, and even after reboot.

two interfaces

wired and wireless

with the same IP
seem strange to me

am I wrong?

don’t know …

someones opinion or, even better: knowledge?

That has nothing todo with your OP…

This is a completely different error as you startd the topic with…

So it sounds to me like you have a problem with your DNS config on your wired connection…

Seeing as the topic changed and is now getting confused…
Can you tell us HOW you configure your network connections?
(Are you using NetworkManager, or systemd-networkd, or something else or a combination?)


To solve networking problems, don’t use a browser, but use dedicated software for that purpose, like ping / dig / etc…

I had the same problem happen to me, it was sometime working and others not. And it was a cable problem. Not sure in your situation though.

IPv6 setup on the wifi NIC but not on the wired NIC, would explain the site-specific behaviour.

Also agree with the others, the same IPv4 address on both NICs, or a faulty cable/connector, might explain the dropped packets, causing errors.